Author Topic: uDMX  (Read 2499 times)

Offline StrangeSparks

  • Newbie
  • *
  • Join Date: Nov 2015
  • Location:
  • Posts: 8
  • Kudos: 0
uDMX
« on: November 22, 2015, 01:10:22 AM »
Hi all,
probably an easy fix, but I cant get it to work.
I'm running FPP 1.6, on a Pi B.
I have a uDMX dongle which I have managed to get working via a PC. so all seems to be good.
what setting should I be using? I can't see the uDMX, I have tried the DMXpro and openDMX, resetting and rebooting etc. but I'm not getting anything out.
is there a way to install a driver?

Offline CaptainMurdoch

  • Administrator
  • *****
  • Join Date: Sep 2013
  • Location: Washington
  • Posts: 8,345
  • Kudos: 157
Re: uDMX
« Reply #1 on: November 22, 2015, 01:55:28 AM »
It looks like you will have to use  FPP's OLA channel output with that dongle.  The Open Lighting Architecture program can be used to actually talk to the dongle and FPP will send OLA the sequence data.  Have you used OLA before?  There isn't a config UI for the OLA channel output but I can tell you how to modify the config file.  Then you will need to go into the OLA web interface and configure it to use your uDMX dongle.
-
Chris

Offline StrangeSparks

  • Newbie
  • *
  • Join Date: Nov 2015
  • Location:
  • Posts: 8
  • Kudos: 0
Re: uDMX
« Reply #2 on: November 22, 2015, 11:00:10 PM »
It looks like you will have to use  FPP's OLA channel output with that dongle.  The Open Lighting Architecture program can be used to actually talk to the dongle and FPP will send OLA the sequence data.  Have you used OLA before?  There isn't a config UI for the OLA channel output but I can tell you how to modify the config file.  Then you will need to go into the OLA web interface and configure it to use your uDMX dongle.
I was hoping it would be an easier fix. No I haven't used OLA. But I'm guessing I'm going to learn.
Just so you know who you are instructing; I have a bit of understanding about programming, but no real experience. But willing to give it a crack

Offline StrangeSparks

  • Newbie
  • *
  • Join Date: Nov 2015
  • Location:
  • Posts: 8
  • Kudos: 0
Re: uDMX
« Reply #3 on: November 24, 2015, 01:06:20 AM »
So trying to get my head around OLA,
I need to install extra OLA software, and then edit the config to get the two to talk?
Sorry, going back to basics here.

Offline CaptainMurdoch

  • Administrator
  • *****
  • Join Date: Sep 2013
  • Location: Washington
  • Posts: 8,345
  • Kudos: 157
Re: uDMX
« Reply #4 on: November 24, 2015, 09:47:27 PM »
So trying to get my head around OLA,
I need to install extra OLA software, and then edit the config to get the two to talk?
Sorry, going back to basics here.

No, FPP includes OLA, you just need to edit a file in FPP and then reboot the FPP system with your dongle plugged in.  Once it is rebooted, go to the OLA web page running on the FPP system and configure the OLA output.

FPP stores it's newer channel output configs in a file called /home/fpp/media/config/channeloutputs.json.  You can SSH into the FPP system by using the SSH menu option under the help menu.  Once on the system, run this:

Code: [Select]
nano /home/fpp/media/config/channeloutputs.json

In that file, you want to add the following:

Code: [Select]
{
        "channelOutputs": [
                {
                        "type": "OLA",
                        "enabled": 1,
                        "startChannel": 1,
                        "channelCount": 512,
                        "universes": [
                                {
                                        "active": 1,
                                        "universe": 1,
                                        "startChannel": 1,
                                        "channelCount": 512
                                }
                        ]
                }
        ]
}

To save the file press CTRL-O, accept the filename, then hit CTRL-X to exit.

Once you have saved the file, you can exit the shell by typing "exit" and hitting ENTER.

After editting the file, you need to reboot the system so that it can see that you have the OLA channel output configured and startup OLA.  Once rebooted, you can browse to the OLA configuration UI at http://fpp:9090/ and configure OLA.  With the above config file, FPP is setup to send OLA one universe with channels 1-512 in it, so you will configure universe 1 in OLA.  If you need further help on configuring OLA, you may need to read up on their site.

Offline StrangeSparks

  • Newbie
  • *
  • Join Date: Nov 2015
  • Location:
  • Posts: 8
  • Kudos: 0
Re: uDMX
« Reply #5 on: November 24, 2015, 11:33:11 PM »
So trying to get my head around OLA,
I need to install extra OLA software, and then edit the config to get the two to talk?
Sorry, going back to basics here.

No, FPP includes OLA, you just need to edit a file in FPP and then reboot the FPP system with your dongle plugged in.  Once it is rebooted, go to the OLA web page running on the FPP system and configure the OLA output.

FPP stores it's newer channel output configs in a file called /home/fpp/media/config/channeloutputs.json.  You can SSH into the FPP system by using the SSH menu option under the help menu.  Once on the system, run this:

Code: [Select]
nano /home/fpp/media/config/channeloutputs.json

In that file, you want to add the following:

Code: [Select]
{
        "channelOutputs": [
                {
                        "type": "OLA",
                        "enabled": 1,
                        "startChannel": 1,
                        "channelCount": 512,
                        "universes": [
                                {
                                        "active": 1,
                                        "universe": 1,
                                        "startChannel": 1,
                                        "channelCount": 512
                                }
                        ]
                }
        ]
}

To save the file press CTRL-O, accept the filename, then hit CTRL-X to exit.

Once you have saved the file, you can exit the shell by typing "exit" and hitting ENTER.

After editting the file, you need to reboot the system so that it can see that you have the OLA channel output configured and startup OLA.  Once rebooted, you can browse to the OLA configuration UI at http://fpp:9090/ and configure OLA.  With the above config file, FPP is setup to send OLA one universe with channels 1-512 in it, so you will configure universe 1 in OLA.  If you need further help on configuring OLA, you may need to read up on their site.
Awesome.
Most of that made sense. Except I don't recall setting up a login or password. Is there a default?

Offline CaptainMurdoch

  • Administrator
  • *****
  • Join Date: Sep 2013
  • Location: Washington
  • Posts: 8,345
  • Kudos: 157
Re: uDMX
« Reply #6 on: November 24, 2015, 11:35:56 PM »
Most of that made sense. Except I don't recall setting up a login or password. Is there a default?

The login is 'fpp' and password is 'falcon'.

Offline StrangeSparks

  • Newbie
  • *
  • Join Date: Nov 2015
  • Location:
  • Posts: 8
  • Kudos: 0
Re: uDMX
« Reply #7 on: November 26, 2015, 12:19:53 AM »
Thank you for your help so far.
I have added the lines into the config, and rebooted, restarted etc. but cannot see the OLA in the channel outputs?
Also do I need to set the OLA to receive from FPP?

Offline CaptainMurdoch

  • Administrator
  • *****
  • Join Date: Sep 2013
  • Location: Washington
  • Posts: 8,345
  • Kudos: 157
Re: uDMX
« Reply #8 on: November 26, 2015, 09:02:07 AM »
OLA will not show in the UI, I haven't done the UI work for it yet, that is why you have to hand edit the file.

The channel output in FPP will send one universe of data to OLA.

In OLA, you will just need to setup an output to tell it where to send universe 1.

Offline StrangeSparks

  • Newbie
  • *
  • Join Date: Nov 2015
  • Location:
  • Posts: 8
  • Kudos: 0
Re: uDMX
« Reply #9 on: November 26, 2015, 01:06:32 PM »
OK that make sense. I'll stop looking for it in the UI and focus on setting up the OLA.
So I am assuming that as this is my only universe and output, I need to make sure that all others are not activated to prevent a conflict.




Sent from my Vodafone 985N using Tapatalk


Offline CaptainMurdoch

  • Administrator
  • *****
  • Join Date: Sep 2013
  • Location: Washington
  • Posts: 8,345
  • Kudos: 157
Re: uDMX
« Reply #10 on: November 26, 2015, 10:28:54 PM »
By default, OLA has no outputs configured, you need to go in and add one for your dongle type.

Offline StrangeSparks

  • Newbie
  • *
  • Join Date: Nov 2015
  • Location:
  • Posts: 8
  • Kudos: 0
Re: uDMX
« Reply #11 on: November 26, 2015, 11:49:46 PM »
Thanks for all your help getting me on the right track.
I appreciate that it must be a busy time with so many leaving it until now to get things going.

Sent from my Vodafone 985N using Tapatalk


Offline CaptainMurdoch

  • Administrator
  • *****
  • Join Date: Sep 2013
  • Location: Washington
  • Posts: 8,345
  • Kudos: 157
Re: uDMX
« Reply #12 on: November 27, 2015, 12:15:20 AM »

I appreciate that it must be a busy time with so many leaving it until now to get things going.

The site has definitely been hopping the past few days.  :)

Offline Arti G

  • Newbie
  • *
  • Join Date: Jun 2017
  • Location:
  • Posts: 22
  • Kudos: 1
Re: uDMX
« Reply #13 on: September 30, 2017, 02:18:07 PM »
Any luck? I can't make it working. I have OLA setup page, but when I try to add universe there is no udmx adapter to choose :( I also tried to add:
Code: [Select]
SUBSYSTEM=="usb|usb_device", ACTION=="add", ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="05dc", GROUP="plugdev" https://www.youtube.com/watch?v=BR9gvpTyPY0 /lib/udev/rules.d/10-local-rpi.rules

EDIT:
WORKING!

I also tried this:
https://www.illutzmination.de/udmxdriver.html?&L=1
Quote
create a file z65-anyma-udmx.rules in folder /etc/udev/rules.d with the following content:
Code: [Select]
SUBSYSTEM=="usb*", ACTION=="add|change", ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="05dc", MODE="0666"
SUBSYSTEM=="usb*", ACTION=="add|change", SYSFS{idVendor}=="16c0", SYSFS{idProduct}=="05dc", MODE="0666"

I also added this code to /lib/udev/rules.d/10-local-rpi.rules :
Code: [Select]
SUBSYSTEM=="usb|usb_device", ACTION=="add", ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="05dc", GROUP="plugdev"
SUBSYSTEM=="usb*", ACTION=="add|change", ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="05dc", MODE="0666"
SUBSYSTEM=="usb*", ACTION=="add|change", SYSFS{idVendor}=="16c0", SYSFS{idProduct}=="05dc", MODE="0666"

Now it appears. I can add universe in OLA setup page with anima udmx, when going to fpp:9090

But I had to change start channel to 0, because channels were shifted by 1:
Code: [Select]
{
        "channelOutputs": [
                {
                        "type": "OLA",
                        "enabled": 1,
                        "startChannel": 0,
                        "channelCount": 512,
                        "universes": [
                                {
                                        "active": 1,
                                        "universe": 1,
                                        "startChannel": 0,
                                        "channelCount": 512
                                }
                        ]
                }
        ]
}
« Last Edit: October 01, 2017, 12:24:25 PM by Arti G »

 

Back to top