Author Topic: Falcon pi player not finding wifi IP anymore after using a Hanson's pihat  (Read 1220 times)

Offline Dutchsanta

  • Newbie
  • *
  • Join Date: Oct 2016
  • Location:
  • Posts: 38
  • Kudos: 0
That would be my fault....
After JNEALAND reply I did a 5th check to make sure the SSID and Password are correct and I tried uppercases ...
I forget to put it back to lower cases before I did your codes..


Attached you will find the new results using lower cases...and yes...this is MUCH smaller hahaha..
I am sorry for my stupid mistake!!!.


*********************************************
Ok..little update...
I have logged out all my wifi products...3 laptops, 1 pc, 3 tablets, 3 smartphones...
I deleted all WIFI date on those products.


1 for 1 I connected them back to wifi, by searching the correct ssid and the correct password.
Everything is back online now..no problems. but not the pi!!


BUT....I have noticed 1 thing.
All products searching the ssid displayed the ssid in capitals!!!! even if the router itselfs has a sticker with lower casing.

But you have seen it in the attachements...As soon as I use capitals in FPP you get a 125 pages output and NO wifi.....If I change the ssid in FPP to lower case you get a more readable output but still NO wifi.


You can call me crazy, you can call me stupid but I am about to send the picap back to Australia including a bill for 2 new pi's..
* I did send a pm to ahh already asking him to take a look at this topic as it is his picap).






« Last Edit: April 14, 2017, 10:00:06 AM by Dutchsanta »

Offline ThreeSizes

  • Developer
  • ******
  • Join Date: Dec 2015
  • Location: Fulton, MD
  • Posts: 532
  • Kudos: 30
Here's what I'm seeing, when you have the SSID set to all caps, it actually is able to connect to the WiFi but fails to negotiate WPA. When the SSID is set to lower case, it does not even try (or at least there are no log entries saying it tried).

Can you rerun the "sudo grep wpa_supplicant /var/log/syslog" after the FPP has been booted for a little bit with the SSID set to lower case? Just want to eliminate that the Pi had enough time to try to connect. The log files for the attempt with all upper case spanned a greater time period.



"And what happened then? Well, in Whoville they say that the Grinch's small heart grew three sizes that day."

Offline Dutchsanta

  • Newbie
  • *
  • Join Date: Oct 2016
  • Location:
  • Posts: 38
  • Kudos: 0

fpp@FPP ~ $ sudo grep wpa_supplicant /var/log/syslog
Apr 14 15:32:11 FPP wpa_supplicant[2480]: wlan0: CTRL-EVENT-TERMINATING - signal 15 received

Offline ThreeSizes

  • Developer
  • ******
  • Join Date: Dec 2015
  • Location: Fulton, MD
  • Posts: 532
  • Kudos: 30
I can't say with 100% assurity, but I believe your SSID needs to be configured all upper case. The log messages are saying that when its negotiating the encryption, it is getting two conflicting answers from the Router/AP and because of that its refusing to connect. Now normally I would say its an issue with the Router/AP but I have seen weird behavior with the build of Raspbian used with FPP. The drivers for the Pi3 WiFi where back-ported to the older build of Raspbian being used. I have had personal experience with some parts of the WiFi and WPA stacks not working correctly between various different WiFi adapters and all those issues get magically resolved if I install the newer version of Raspbian and try the same thing.

We can take a look at the WiFi Router and see if its an issue there, but that is going to really hard to do. You can also try purchasing a USB WiFi Adapter and seeing if that works correctly. There are several popular ones mentioned here on the forums if you search.

If you want to take a quick look at the WiFi Router, send me the make and model of the unit you have.


Offline Dutchsanta

  • Newbie
  • *
  • Join Date: Oct 2016
  • Location:
  • Posts: 38
  • Kudos: 0
Ok..next update..yes I have a half day off to get this thing going.


I used the OLDER pi to flash the software to noobs light..( raspberry own software)
After 8 tries the install accepted and went trough.


I can select wifi and it is searching for the SSID...Within 2 secondes it found my SSID ( in capitals).
I entered the CORRECT password...and ....nothing!!!!


It is trying to connect for more then 15 minutes now....
So..I think we are 1 step futher???
It does connect to WIFI using capitals as ssid (dispite the router clearly has a sticker saying ssid is LOWER casing).
But there it stops...not connection after filling in the CORRECT password!!.

But strange thing is that the problems started AFTER I have plugged in the Picap!!!!! 


I can give you the link to the router but you will not be able to read anything about it.
https://www.kpn.com/service/internet/wifi-en-modems/handleidingen-experia-box.htm#!/device/internet/experia-box-v8
It is a Dutch product that our cable company installed.
It has glassfiber internet, glasfiber tv, glasfiber telephone and build in router..
..thats the only positive thing about it..we have glasfiber cables throughout the house all the way into the tv,telephone and computers..



« Last Edit: April 14, 2017, 10:23:53 AM by Dutchsanta »

Offline ThreeSizes

  • Developer
  • ******
  • Join Date: Dec 2015
  • Location: Fulton, MD
  • Posts: 532
  • Kudos: 30
Lets focus on the Older Pi with the NOOBS. What version of NOOBS? You mentioned Lite, is this Raspbian Jessie Lite?

Can you run the same set of commands on this unit and post the results?

Does the router give you any options to make configuration changes to the WiFi setup? Like WPA options, or do they keep it pretty simple?







Offline Dutchsanta

  • Newbie
  • *
  • Join Date: Oct 2016
  • Location:
  • Posts: 38
  • Kudos: 0
hahaha..damnd...I just flashed the older one back to FPP.


But it is already flashing again to NOOBS 2.3...It is now installing Rasbian Jessie....Never used that one so I will report back to you as I know more.


The router has no options...everything is blocked...like I can not change the 4th IP number.  192.168.XXX.XXX



Offline ThreeSizes

  • Developer
  • ******
  • Join Date: Dec 2015
  • Location: Fulton, MD
  • Posts: 532
  • Kudos: 30
Here's the plan, try it with Raspbian Jessie Lite and see if it will connect to the WiFi. If it does, then we know its an issue with the older image FPP uses and we'll have to wait for FPP 2.0 which will be based on Jessie. If it still does not connect to the WiFi, then I suggest you try getting another Router and connect the WAN port of the new Router to one of the ports on the KPN Router. You can then use this new Router for your show network but still allow the show network to get internet access. Anything you want on the show network connect to this new router using ethernet or WiFi.


Offline Dutchsanta

  • Newbie
  • *
  • Join Date: Oct 2016
  • Location:
  • Posts: 38
  • Kudos: 0
YES!!!!


I have made progress!!!.
Don't laugh !!


Ok..I installed a OLDER version of NOOBS.....
Noobs 3.4 this time.
It installed and I choose Rasbian JESSIE.
It installed Jessie and there was the gui.
Top right there was a WIFI symbol.
I entered the wifi password and TADAAAA ...connection!!!. see picture.


in IP4 AND IP6...
I disconnected the ethernet cable and wifi stayed on and I could browse internet.


So...my conclusion is indeed to wait for fpp2.0 and hope that wil fix the wifi problems.


Now let's hope the fpp 2.0 will come soon...


I have no idea why this all happens after I installed the picap but thats something I really don't want to get into anymore.
Looks like I have to get a real time clock thingy over here somehow because I really do not want to try it again with the picap.




I will keep the older pi with Jessie for now...If you want me to do some test on it just let me know...


THANK YOU THANK YOU THANK YOU so much for all your help and your time!!!!.










« Last Edit: April 14, 2017, 01:50:56 PM by Dutchsanta »

Offline ThreeSizes

  • Developer
  • ******
  • Join Date: Dec 2015
  • Location: Fulton, MD
  • Posts: 532
  • Kudos: 30
Glad to hear, glad to help.

If you want I would do the same with your other Pi just to make sure its fully working and there isn't anything wrong with it. I also do not think the PiCap had anything to do with this, if you wanted to revisit getting the PiCap working again, albeit without WiFi given your particular compatibility problem with your router.



Offline Dutchsanta

  • Newbie
  • *
  • Join Date: Oct 2016
  • Location:
  • Posts: 38
  • Kudos: 0
I will do the same to the other pi this weekend.
Indeed just to make sure wifi is working.


Ok..if you say it has nothing to do with the picap I will try the picap again...Now I know it is not frying the wifi chip anyway.


And it is a good way to see what happend last times...
Well..thanks again!!! I will keep a eye out for the FPP2.0 and see if that will work.


« Last Edit: April 15, 2017, 05:13:24 AM by Dutchsanta »

Offline AAH

  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Location: Australia
  • Posts: 500
  • Kudos: 14
  • Blinky blinky blinky
    • I love blinky lights
ThreeSizes thanks for helping out Dutchsanta. Your knowledge of FPP, Linux and wifi far exceeds mine so I was unable to do much more than watch the thread as you helped out. As I'm out of action still with a broken collarbone and opposite thumb I couldn't even build up a matching device and try it here. What I can do however is shoot you 1 of my rPi-28D's so that you have 1 on hand to play with and as thanks for helping out 1 of my customers. I'll shoot you a PM to get an address to send it to.

Alan
You can call me AAH, you can call me Al, or you can call me Alan.
http://www.hansonelectronics.com.au/wp-content/uploads/Catalogue.pdf Catalogue of my blinky bits
http://www.hansonelectronics.com.au/

Offline Dutchsanta

  • Newbie
  • *
  • Join Date: Oct 2016
  • Location:
  • Posts: 38
  • Kudos: 0
That's very nice of you Alan!! Maybe treesizes can use it someday to help people out... I hope your doing well soon!!.

I am going to do some test on my older pi myself....with and without your picap on it...but looks like fpp2.0 will do the trick...I hope so anyway

Offline Dutchsanta

  • Newbie
  • *
  • Join Date: Oct 2016
  • Location:
  • Posts: 38
  • Kudos: 0
SOLVED: Falcon pi player not finding wifi IP anymore
« Reply #43 on: April 15, 2017, 05:21:34 AM »
OK...New update and the problem is solved.


I had David Pitts teamview my system and TADAAAA he found the problem.


Our network was set tot WPA2 protocol....and the wifi of the pi uses WPA.
So David took a look at some settings and set our network to WPA/WPA2 and tadaaaaa we have wifi on the pi...


Nobody knows what the correlation is between losing wifi and plugging in the picap but who cares. most have bin coincidence....twice.


I want to thank Treesizes for his time and patience with me.
And THANK YOU DAVID for making some time to teamview with me and solving the problem!!!!!!


Just some info...David told me that FPP 1.8 and 1.9 are already running on Rasbian Jessie...


Thanks guys!!!...




Offline CaptainMurdoch

  • Administrator
  • *****
  • Join Date: Sep 2013
  • Location: Washington
  • Posts: 7,859
  • Kudos: 140
Re: SOLVED: Falcon pi player not finding wifi IP anymore
« Reply #44 on: April 17, 2017, 10:44:57 AM »
Just some info...David told me that FPP 1.8 and 1.9 are already running on Rasbian Jessie...

The FPP v1.5 and v1.8 SD images use the Raspbian Jessie kernel, but they are actually running the Raspbian Wheezy OS.  When the Pi 3 came out, we added the Jessie kernel and firmware to our existing Wheezy image to allow the newer hardware to work without having to build totally new SD images.  The new v2.0 SD image that we are working on will be built from Raspbian Jessie.
-
Chris

 

Back to top