Author Topic: RGB string becomes GBR string when testing?  (Read 187 times)

Offline Ken

  • Newbie
  • *
  • Join Date: Dec 2016
  • Location: Upstate, SC
  • Posts: 21
  • Kudos: 0
RGB string becomes GBR string when testing?
« on: April 19, 2017, 07:33:28 PM »
While testing my two PiCaps today I noticed something odd.  On one of my PiCaps my RGB strings appear to become GBR strings while in test mode.  I say that because when using the Fill option and setting the sliders to R=255, G=0 and B=0 the strings lights up green.  R=0, G=255 and B=0 lights them up blue and R=0, G=0 and B=255 lights them up red.

If I use the RGB Patterns I get the following results
Chase:R-G-B = None, Blue, Green
Chase:R-G-B-All = None, Blue, Green, White
Chase:R-G-B-None = Blue, Green, Red, None
Chase:R-G-B-All-None = Blue, Green, Red, White, None

Another odd thing is that when I play a test sequence from xLights to the same PiCap with the same strings attached they light up with the correct colors.  If I tell the string to be red it's red.  If I tell it to be green it's green.  So it looks like they're only displaying the wrong colors when using the test mode within FPP.  Also, if I connect the exact same strings using the same connectors to my second PiCap they display the colors correctly when in test mode.

I'm a noob so I'm assuming that I'm missing something somewhere but everything I've checked in both FPP and xLights shows the strings defined as RGB strings.  So what am I missing?



Offline AAH

  • Sr. Member
  • ****
  • Join Date: Jul 2014
  • Location: Australia
  • Posts: 478
  • Kudos: 14
  • Blinky blinky blinky
    • I love blinky lights
Re: RGB string becomes GBR string when testing?
« Reply #1 on: April 19, 2017, 09:03:07 PM »
I would imagine that the test mode is just set so that channel 1,4,7,10 etc is red, 2,5,8,11 etc is green and 3,6,9,12 is blue. In either the string setup or Xlights there may be a variation of the channel numbers compared to this "assumption". You may for example have the string in question as channels 2,3,4 as red,green and blue configured in your sequencer but as the channels you're using don't coincide to the generic 1,2,3 then the test mode shows the wrong colours.
You can call me AAH, you can call me Al, or you can call me Alan.
http://www.hansonelectronics.com.au/wp-content/uploads/Catalogue.pdf Catalogue of my blinky bits
http://www.hansonelectronics.com.au/

Offline CaptainMurdoch

  • Administrator
  • *****
  • Join Date: Sep 2013
  • Location: Washington
  • Posts: 7,854
  • Kudos: 139
Re: RGB string becomes GBR string when testing?
« Reply #2 on: April 20, 2017, 08:57:04 AM »
If you set the start/end channel range to coincide with your actual model or display feature then the color order should be correct.  FPP's test mode bases the R-G-B as starting on channels 1-2-3 if you leave the channel start/end range at the default.
-
Chris

 

Back to top