Author Topic: Best way to setup Raspberry Pi's using GPIO  (Read 165 times)

Offline Scottishsurfer

  • Newbie
  • *
  • Join Date: Mar 2016
  • Location:
  • Posts: 32
  • Kudos: 0
Best way to setup Raspberry Pi's using GPIO
« on: June 05, 2017, 11:40:29 AM »
Looking for the best way to setup my models in xlights and on the FPP. I have 2 raspberry Pi's using sainsmart relays connected via GPIO.  One has 8 channels using GPIO for my legacy lights, and the other has 8 channels to power my singing tree (legacy lights as well).  What's the best way to configure.  Right now I have set as Network Type=NULL.  Channels 1-8 and 9-16.  Is this the right way of connecting?

[/size]My Pixel controllers are all setup using e131 and have static IP addresses, they work great.  Just wanting to confirm that I have this setup the recommended way.[/color]

[/size]Using 3 Raspberry PI's.  One is master with nothing connected.  second has sainsmart ssr connected via GPIO, third is also sainsmart connected via gpio.
[/color]
[/size][/color]

Offline CaptainMurdoch

  • Administrator
  • *****
  • Join Date: Sep 2013
  • Location: Washington
  • Posts: 7,851
  • Kudos: 138
Re: Best way to setup Raspberry Pi's using GPIO
« Reply #1 on: June 05, 2017, 02:00:45 PM »
That xLights config should work fine.  You can also go into FPP's Channel Tester page and turn on the channel tester and see if your GPIO's activate.
-
Chris

Offline Scottishsurfer

  • Newbie
  • *
  • Join Date: Mar 2016
  • Location:
  • Posts: 32
  • Kudos: 0
Re: Best way to setup Raspberry Pi's using GPIO
« Reply #2 on: June 05, 2017, 04:51:00 PM »
Great.  Everything is working, but just wanted to make sure that I was setup correctly (recommended approach for my hardware).

Offline Griz

  • Full Member
  • ***
  • Join Date: Mar 2016
  • Location:
  • Posts: 106
  • Kudos: 3
Re: Best way to setup Raspberry Pi's using GPIO
« Reply #3 on: June 05, 2017, 08:04:13 PM »
Could you post a picture of your wiring setup?

I have had the most difficulties with GPIOs.  I bought a pi ezconnect, but haven't been able to get it to work.  I think the problem is the 1 and 10 kw resisters.


 

Back to top