Author Topic: Trouble with Pixel overlay Countdown - Illegal division by zero line 793  (Read 216 times)

Offline Jcherryfitter

  • Newbie
  • *
  • Join Date: Sep 2017
  • Location:
  • Posts: 6
  • Kudos: 0
I have been reading past posts on p10 overlays and tried many suggestions as I went along.  The problem I'm having is that I cannot get the pixel overlay scripts to work; clock, scroll, and countdown.  My overlay model is setup and will run in the Matrix Tools correctly.  I can upload an .eseq model with an effect from Xlights and trigger without an issue.  But when I try to run the countdown script, in the UI, I get nothing.  In ssh I used this command:
 /opt/fpp/scripts/eventScript /home/fpp/media/scripts/PixelOverlay-Countdown.pl
And Then I get this:
config version 0
total blocks 0
test mode 0
illegal division by zero opt/fpp/lib/perl/fpp/memory map.pm line 793
(see attachments)
To review the process that I used to set this up, I defined my pixeloverlay model.  Then dl the countdown script from repository.  Uploaded an .eseq Model export from Xlights with an effect.  Setup 0/0 event where effect seq. is my .eseq - which is the same name as my pixeloverlay model.  I edited the script to reflect my model name and setup a playlist with the events also.


Thanks in advance for taking a look at this!
James

Offline Jcherryfitter

  • Newbie
  • *
  • Join Date: Sep 2017
  • Location:
  • Posts: 6
  • Kudos: 0
Re: Trouble with Pixel overlay Countdown - Illegal division by zero line 793
« Reply #1 on: September 12, 2017, 03:25:05 PM »
Using ssh and the same command after a reboot I got this, new info but same error:

Offline Materdaddy

  • Moderator
  • *****
  • Join Date: Jul 2013
  • Location: Oceanside, CA
  • Posts: 2,048
  • Kudos: 9
    • Christmas On Quiet Hills
Re: Trouble with Pixel overlay Countdown - Illegal division by zero line 793
« Reply #2 on: September 12, 2017, 11:26:12 PM »
I don't know anything about that script other than I looked at line 793 and the denominator is string count.

Do you have your pixels configured with 0 strings?

Offline Jcherryfitter

  • Newbie
  • *
  • Join Date: Sep 2017
  • Location:
  • Posts: 6
  • Kudos: 0
Re: Trouble with Pixel overlay Countdown - Illegal division by zero line 793
« Reply #3 on: September 13, 2017, 04:16:38 AM »
The pixel overlay is setup with 64 strings. 

Offline Jcherryfitter

  • Newbie
  • *
  • Join Date: Sep 2017
  • Location:
  • Posts: 6
  • Kudos: 0
Re: Trouble with Pixel overlay Countdown - Illegal division by zero line 793
« Reply #4 on: September 13, 2017, 05:28:32 AM »
I replaced the stock name of the script with the name of my pixel overlay model.  I was under the impression that the script would seek the model by name and load those settings of my model through substitution.  Do I also need to edit the script with string count or is it an issue with the way I setup my model?

Sent from my SM-G930V using Tapatalk


Offline Jcherryfitter

  • Newbie
  • *
  • Join Date: Sep 2017
  • Location:
  • Posts: 6
  • Kudos: 0
Re: Trouble with Pixel overlay Countdown - Illegal division by zero line 793
« Reply #5 on: September 13, 2017, 02:32:58 PM »
Looks like you need to enable E.31 output on the channel settings page.

 

Back to top