(SOLVED) RPi Model A+ wifi?

Author Topic: (SOLVED) RPi Model A+ wifi?  (Read 542 times)

Offline 67comet

  • Newbie
  • *
  • Join Date: Oct 2017
  • Location: Roy, UT
  • Posts: 5
  • Kudos: 1
  • Look slow, go fast, and act surprised.
    • Justin's Blog Hole
(SOLVED) RPi Model A+ wifi?
« on: October 18, 2017, 05:34:56 PM »
I'm not a noob per-say (Have several RPi's around the house, from web cam, web/file server, media cernters (Clients and Servers) etc ..) but FPP is kicking my butt. A few years ago I used Lightshowpi and an 8 relay board, but that program is entirely random and never felt synced to the show.

I normally go in and edit wpa_suplicant.conf (old school was interfaces.conf) with my SSID and PW with static addresses in dhcpcd.conf and all is well. But in FPP it deletes all those edits, and puts them back to default (Even restarting networking doesn't do anything). I can NOT navigate to the pi because w/out editing those files, my pi is not on the network. I have logged in to the Model A+ by hooking a USB hub, HDMI monitor, but nothing I edit sticks.

Am I missing something in FPP? I can't hook a LAN cable to the Model A+ (It only has one USB port).

Ideas? I searched the forums for the last hour, but nothing seems to be the same as the issue I'm having, or they steer the question to using the web interface (that I can't do, because I can't get the little Model A+ on the network w/out first getting the WiFi set up.

Thank you all in advance, this looks like a great community.
« Last Edit: October 19, 2017, 09:27:02 AM by 67comet »
Linux abuser, FoMoCo driver, and Gov't worker.

Offline jnealand

  • Developer
  • ******
  • Join Date: Aug 2013
  • Location: Kennesaw, GA
  • Posts: 2,485
  • Kudos: 50
Re: RPi Model A+ wifi?
« Reply #1 on: October 19, 2017, 08:20:32 AM »
Start by using an ethernet cable.  Then using the web interface set the eth0 to DHCP and set you wifi to your static IP with correct SSID and password.  (Both are cap sensitive and no special character.)  Then shutdown. remove ethernet cable and reboot.  That should do it.
Jim Nealand
Kennesaw, GA Falcon and Lynx, all 12v Multisync with Pi and BBB P10 and P5

Offline 67comet

  • Newbie
  • *
  • Join Date: Oct 2017
  • Location: Roy, UT
  • Posts: 5
  • Kudos: 1
  • Look slow, go fast, and act surprised.
    • Justin's Blog Hole
Re: RPi Model A+ wifi?
« Reply #2 on: October 19, 2017, 08:50:47 AM »
It's a Model A+, it has no ethernet connection 🤪😀

Offline 67comet

  • Newbie
  • *
  • Join Date: Oct 2017
  • Location: Roy, UT
  • Posts: 5
  • Kudos: 1
  • Look slow, go fast, and act surprised.
    • Justin's Blog Hole
Re: RPi Model A+ wifi?
« Reply #3 on: October 19, 2017, 09:25:09 AM »
Got it to work by taking the MicroSD (in SD Adapter), put it in my old Raspbery Pi Model B that is my web/file/media server (yes, that old), and enabled wifi.


Put it back in the Model A+ and it's up and running.


How come FPP wipes all conf files related to normal WiFi details? If I hadn't had an extra LAN connected RPi hooked up, I'm not sure I could have gotten it to work.


Happily learning FPP now, thanks for all the hard work you developer gurus you! WHOOP!




Offline rmp2917

  • Newbie
  • *
  • Join Date: Aug 2014
  • Location:
  • Posts: 47
  • Kudos: 2
Re: (SOLVED) RPi Model A+ wifi?
« Reply #4 on: October 19, 2017, 04:11:03 PM »
There are 2 files that contain the network information.

The file interfaces under /root/etc/network contains the IP address information. There is also a duplicate of this file called interfaces.fpp in the same directory.

The file should look like this:
Code: [Select]
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet manual
  wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
wireless-power off

iface FPP-wlan0 inet static
  dns-nameservers 8.8.8.8 8.8.4.4
  address 10.10.10.100
  netmask 255.0.0.0
  network 10.0.0.0
  gateway 10.10.10.252

iface default inet dhcp

iface eth0:0 inet static
  address 192.168.0.10
  netmask 255.255.255.0
  network 192.168.0.0

wpa_supplicant.conf under root/etc/wpa_suspplicant contains the wireless SSID and password. There is a duplicate of this tile called wpa_supplicant.conf.fpp

The file should look like this:
Code: [Select]
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
  ssid="SSID"
  psk="password"
  scan_ssid=1
  id_str="FPP-wlan0"
}

You should be able to manually modify these 4 files with your information and get it to boot with the correct wireless settings.

 

Back to top