Author Topic: FPP on Pi not sending anything to Renard SS8  (Read 283 times)

Offline kdoyon

  • Newbie
  • *
  • Join Date: Oct 2017
  • Location:
  • Posts: 3
  • Kudos: 0
FPP on Pi not sending anything to Renard SS8
« on: October 24, 2017, 10:34:42 AM »
Hi everyone,


I have recently jumped into this hobby, and I am at a sticking point.


I am able to use vixen on my computer to send data to a Renard SS8, and the lights hooked up to it will light up. I am connecting the computer to the Renard with a USB to RS485 adapter. I did have to go in to display setup and tell Vixen that the Renard controller was on COM 4 instead of COM 3 like it first thought. Then everything works fine.


However, when I hooked up the Renard to my Raspberry Pi B with FPP running, I cannot get the lights to light. I have tried both the channel test and sequence test (uploaded a fseq file exported from vixen. The same file that works when the Renard is directly connected to the computer running Vixen.


I have attached a picture of how I have the Renard controller set up in Channel Outputs. The only thing I noticed that I don't understand is that the only choice for port was ttyAMA0. Not sure what that means or if it is what I need.





Any help would be appreciated.


Thanks!


Ken


Offline JonB256

  • Supporting Member
  • ******
  • Join Date: Mar 2013
  • Location: Granbury, Texas
  • Posts: 3,963
  • Kudos: 84
    • Granbury Christmas Lights
Re: FPP on Pi not sending anything to Renard SS8
« Reply #1 on: October 24, 2017, 10:48:36 AM »
Was the Renard USB dongle plugged in when the Pi booted? Many USB devices need to be sensed at boot to be properly listed by their tty address.


Offline kdoyon

  • Newbie
  • *
  • Join Date: Oct 2017
  • Location:
  • Posts: 3
  • Kudos: 0
Re: FPP on Pi not sending anything to Renard SS8
« Reply #2 on: October 24, 2017, 11:43:15 AM »
Darn. I was hoping that might be it. I rebooted and tried it again. Nothing. Then I did a full shutdown of the Pi and started it back up. Nothing.

Any other ideas?


Sent from my iPhone using Tapatalk

Offline JonB256

  • Supporting Member
  • ******
  • Join Date: Mar 2013
  • Location: Granbury, Texas
  • Posts: 3,963
  • Kudos: 84
    • Granbury Christmas Lights
Re: FPP on Pi not sending anything to Renard SS8
« Reply #3 on: October 24, 2017, 11:48:28 AM »
other than varying the baud rate or Com parameters, no.

There are others here who do Renard (I don't) who may know more.

Offline kdoyon

  • Newbie
  • *
  • Join Date: Oct 2017
  • Location:
  • Posts: 3
  • Kudos: 0
Re: FPP on Pi not sending anything to Renard SS8
« Reply #4 on: October 24, 2017, 11:56:25 AM »
Thanks for trying!


Sent from my iPhone using Tapatalk

Offline dakingus

  • Newbie
  • *
  • Join Date: Oct 2014
  • Location:
  • Posts: 5
  • Kudos: 0
Re: FPP on Pi not sending anything to Renard SS8
« Reply #5 on: November 04, 2017, 05:28:05 PM »

I use FPP to drive 32 channels of Renard.  On my Channel Outputs page the I have the port set to ttyUSB0.  You might try that. 


 





Online CaptainMurdoch

  • Administrator
  • *****
  • Join Date: Sep 2013
  • Location: Washington
  • Posts: 8,268
  • Kudos: 151
Re: FPP on Pi not sending anything to Renard SS8
« Reply #6 on: November 10, 2017, 11:35:51 PM »

I use FPP to drive 32 channels of Renard.  On my Channel Outputs page the I have the port set to ttyUSB0.  You might try that.

This is probably it.  ttyAMA0 is the onboard serial port on the Pi, so you only want ttyAMA0 if you are using something like a PiCap to convert that to RS-485.

For USB dongles, you want the ttyUSB0, ttyUSB1, etc. devices.
-
Chris

Offline XmasLightGuy

  • Newbie
  • *
  • Join Date: Jan 2016
  • Location: Colorado
  • Posts: 33
  • Kudos: 0
Re: FPP on Pi not sending anything to Renard SS8
« Reply #7 on: November 25, 2017, 05:41:03 PM »
I used ttyUSB0 for my renard going through a USB dongle.
But I also had to build a small crossover board to go between the dongle & Renard.
Then I was able to get lights :)

 

Back to top