Author Topic: Zeus 8 setup issues  (Read 231 times)

Offline Maniac

  • Newbie
  • *
  • Join Date: Oct 2017
  • Location:
  • Posts: 3
  • Kudos: 0
Zeus 8 setup issues
« on: October 24, 2017, 06:12:27 PM »
I know I'm super-late to the party.


I've got a Zeus 8 that I got from someone. As far as I can tell, I've loaded the FalconZeus v0.0.0_id_1.hex firmware on the pic using a breadboard and jumpers. It seemed to work as far as I can tell.


I put power to the board and hooked up a couple of pixels, put the program jumper into program and get a light pattern cycle.


I downloaded the Falcon Controller Software v1.2.3 and unzipped and installed.


Pixelnet universe jumpers on 1 (both). Lynx USB dongle flashed with pixelnet firmware, seems to work with hub and SSCs


controller details in software
name: zeus
Board Address: 1
Type: Zeus8
Universe:1
Standard mode


I only have 2 nodes hooked up to it for testing, so I put in start channel 1, pixel count 2, color order RGB. Forward Direction, standard grouping. I cloned the port 7x.


Method: Serial
Com Port: 4 (which again seemed to work with the hub)


I hit program and nothing happens. Do I need to leave the program jumper on or off? (i expect off, since on makes the test mode work)


What stupid thing am I missing?


Thanks in advance for any help / advice!










Offline tbone321

  • Hero Member
  • *****
  • Join Date: Oct 2014
  • Location:
  • Posts: 1,338
  • Kudos: 35
Re: Zeus 8 setup issues
« Reply #1 on: October 24, 2017, 09:25:08 PM »
The first thing I would do is check and make sure that you are getting power to the string.  A blown fuse will stop that.  Then I would confirm that the 2 pixel string is actually working and connected correctly.  It gets real easy to reverse a few wires or connect the string to the Zeus port on its output side.

Offline Maniac

  • Newbie
  • *
  • Join Date: Oct 2017
  • Location:
  • Posts: 3
  • Kudos: 0
Re: Zeus 8 setup issues
« Reply #2 on: October 25, 2017, 06:54:04 AM »
The 2 pixels lit up and cycled through the colors when I put the jumper in 'program'.

Offline tbone321

  • Hero Member
  • *****
  • Join Date: Oct 2014
  • Location:
  • Posts: 1,338
  • Kudos: 35
Re: Zeus 8 setup issues
« Reply #3 on: October 25, 2017, 08:47:41 PM »
I believe that your issue is that this program may not support the DMX dongle flashed with PixelNet but Dave would need to confirm that.  In most cases, when something is defined as serial, it is referring to a dumb device that requires the PC to format the data stream. The Lynks dongle is a smart device and expects raw unformatted data and will not work properly if formatted data is sent to it. 

Offline David Pitts

  • Administrator
  • *****
  • Join Date: Mar 2013
  • Location: Falcon, CO
  • Posts: 3,717
  • Kudos: 61
Re: Zeus 8 setup issues
« Reply #4 on: October 26, 2017, 02:22:47 AM »
I originally tested it with Lynx DMX dongle programmed with Pixelnet firmware.
PixelController, LLC
PixelController.com

Offline tbone321

  • Hero Member
  • *****
  • Join Date: Oct 2014
  • Location:
  • Posts: 1,338
  • Kudos: 35
Re: Zeus 8 setup issues
« Reply #5 on: October 26, 2017, 01:54:52 PM »
Have any changes been made to the serial output since then.  I have used the Lynks DMX dongle many times and it always gave me trouble when I sent it formatted data in DMX

Offline zwiller

  • Falcon Beta Team
  • **
  • Join Date: Mar 2013
  • Location: Sandusky, OH
  • Posts: 926
  • Kudos: 12
Re: Zeus 8 setup issues
« Reply #6 on: October 26, 2017, 03:23:50 PM »
The 2 pixels lit up and cycled through the colors when I put the jumper in 'program'.

That's a good thing!  Jumper means test mode works which is only with the Falcon ware.  Don't hold me to this but not sure the Zeus flashed like the others when programming but it still worked fine.  I also think maybe it took hitting the programming button more than once to get it to flash.  Also, be careful when programming not to have other stuff like FPP or XL on when doing this...  Real easy to leave that stuff on.  Also try another COM port for good measure.  I loved my DLA gear but it had it's nuances...

If that fails please send to me for proper disposal.  ;D  I know it works, I used 4 Falcon flashed Zeus 8's using a PN dongle myself.   
Sam

Last year's video: https://vimeo.com/150560653

Offline David Pitts

  • Administrator
  • *****
  • Join Date: Mar 2013
  • Location: Falcon, CO
  • Posts: 3,717
  • Kudos: 61
Re: Zeus 8 setup issues
« Reply #7 on: October 27, 2017, 12:28:58 AM »
I originally tested it with Lynx DMX dongle programmed with Pixelnet firmware.

I never used the Lynx dongle in DMX mode only with Pixelnet firmware.

Offline Maniac

  • Newbie
  • *
  • Join Date: Oct 2017
  • Location:
  • Posts: 3
  • Kudos: 0
Re: Zeus 8 setup issues
« Reply #8 on: October 27, 2017, 08:05:51 AM »
That what I was using, so it sounds like I at least tried to follow the process correctly, it just didn't work. I'll try again clean, I'll just reboot the computer and start the falcon programmer and try it.


Thanks for the info! (I ordered a falcon controller to just eliminate this problem and simplify my layout anyway, but I still want to get this working now)

 

Back to top