Author Topic: Setting up ArtNet on v1.9 FPP help  (Read 79 times)

Offline Redding43

  • Newbie
  • *
  • Join Date: Nov 2017
  • Location:
  • Posts: 4
  • Kudos: 0
Setting up ArtNet on v1.9 FPP help
« on: November 13, 2017, 01:58:24 PM »


Hi all. After a little newbie help please


Have a Pi3 running v1.9 FPP. Have an Artnet device which has a IP of 192.168.1.201.


When I plug the artnet directly into the router I can get to its config Page (see pic)


If I then disconnect and connect it instead to the Ethernet port of the Pi and setup the Pi for Artnet (see pic) and then run a ping I get an error. I also cant get to the artnet config Page anymore via directly typing the ip into a browser


Can anyone point out the obvious mistake I am making?


Pics are here: https://postimg.org/gallery/2gx8l7qrw/

Offline Redding43

  • Newbie
  • *
  • Join Date: Nov 2017
  • Location:
  • Posts: 4
  • Kudos: 0
Re: Setting up ArtNet on v1.9 FPP help
« Reply #1 on: November 13, 2017, 02:53:22 PM »
Just as a brief reply to my original post above.


Somebody told me to connect the artnet directly to the router rather than through the Pi. When I did this the ping was successful:
========================================================================== PING 192.168.1.201 (192.168.1.201) 56(84) bytes of data. 64 bytes from 192.168.1.201: icmp_req=1 ttl=64 time=6.17 ms 64 bytes from 192.168.1.201: icmp_req=2 ttl=64 time=9.44 ms 64 bytes from 192.168.1.201: icmp_req=3 ttl=64 time=9.15 ms --- 192.168.1.201 ping statistics --- 3 packets transmitted, 3 received, 0% packet loss, time 2003ms rtt min/avg/max/mdev = 6.171/8.255/9.441/1.478 ms ==========================================================================
I would prefer though not to have to run the artnet directly from the router as the artnet and the raspberry will be stored outside the house with the raspberry connected via WiFi. How can I work around this?


Putting the above aside even with the ping being successful when I go to the Display Testing and check the box to enable test mode the controllers connected to my lights dont work (powered on but no signal coming from the artnet). Help!


Offline jnealand

  • Developer
  • ******
  • Join Date: Aug 2013
  • Location: Kennesaw, GA
  • Posts: 2,189
  • Kudos: 41
Re: Setting up ArtNet on v1.9 FPP help
« Reply #2 on: November 13, 2017, 07:00:27 PM »
Forgot about artnet and read the many posts on how to talk to an F16v2/3 via the Pi over the network.  Your artnet device needs to be configured to work the same way via the network even though it is artnet.
Jim Nealand
Kennesaw, GA
Lynx, Falcon, XL, FPP

Offline Redding43

  • Newbie
  • *
  • Join Date: Nov 2017
  • Location:
  • Posts: 4
  • Kudos: 0
Re: Setting up ArtNet on v1.9 FPP help
« Reply #3 on: November 14, 2017, 12:16:06 AM »
Thanks for your reply. I will have a search

Offline Redding43

  • Newbie
  • *
  • Join Date: Nov 2017
  • Location:
  • Posts: 4
  • Kudos: 0
Re: Setting up ArtNet on v1.9 FPP help
« Reply #4 on: November 14, 2017, 04:22:13 PM »
Thanks again for all your help


I found this guide online and following wed the steps except the last part of how to change PC settings as thats not required for the Pi. I now have a artnet connected directly to the Pi with all lights working


https://www.brianhensley.net/2017/10/network-setup-falcon-player-fpp-falcon-f16v3-controller.html

 

Back to top