Author Topic: Sequence colors  (Read 864 times)

Offline Lightsonthelake

  • Newbie
  • *
  • Join Date: Dec 2017
  • Location: Shepherdsville kentucky
  • Posts: 28
  • Kudos: 0
Sequence colors
« on: January 06, 2018, 05:46:01 PM »
Ok so I got around to running some test sequences on my first setup. I have a mega tree test file I made that was red white and blue, then I made one that was just red. Both are set as spirals. When I upload it to the fpp and play it, the strings have colors I did not choose. On just the red it fills the gaps with blue and green. I'm not sure where those are coming from. Any input helps.

Offline CaptainMurdoch

  • Administrator
  • *****
  • Join Date: Sep 2013
  • Location: Washington
  • Posts: 9,020
  • Kudos: 178
Re: Sequence colors
« Reply #1 on: January 06, 2018, 07:24:55 PM »
Either your start channels are off or you have an issue with your universes.  Are all pixels the wrong color or just some?
-
Chris

Offline Lightsonthelake

  • Newbie
  • *
  • Join Date: Dec 2017
  • Location: Shepherdsville kentucky
  • Posts: 28
  • Kudos: 0
Re: Sequence colors
« Reply #2 on: January 06, 2018, 08:39:39 PM »
On the red test the nodes light up along the pattern correct. The nodes thst should be off are lit in other colors.

Offline jem5136

  • Full Member
  • ***
  • Join Date: Dec 2016
  • Location: Huntington, IN
  • Posts: 115
  • Kudos: 0
    • Lights of the Night
Re: Sequence colors
« Reply #3 on: January 07, 2018, 05:34:43 AM »
You might want to check your RGB order. The default is channel 1- red, channel 2- green, channel 3- blue, and so on, but some strings may be green, blue, red, or any other combination. Check your pixels to confirm which order they run and confirm your channel order matches in either xLights or your controller.

Offline Lightsonthelake

  • Newbie
  • *
  • Join Date: Dec 2017
  • Location: Shepherdsville kentucky
  • Posts: 28
  • Kudos: 0
Re: Sequence colors
« Reply #4 on: January 07, 2018, 08:09:29 AM »
Website said rgb and xlights is rgb aswell. I can set them in test mode on the v3 and show correct colors aswell. I don't think that is my issue. When I went through the fpp for test mode I could do there rgb chase test and everything worked fine. When I did the custom color it came up with the same error. I'm pretty confused at this point. I'd like to find out if it's something I'm doing or if there bad strings. I ordered them from amazon.

Offline Emuney18

  • Sr. Member
  • ****
  • Join Date: Nov 2015
  • Location: Apex, NC
  • Posts: 448
  • Kudos: 5
Re: Sequence colors
« Reply #5 on: January 07, 2018, 10:55:00 AM »
What do you mean by "when I did the custom color"?  Other than that statement it sounds like the channels or universes do not match between xlights, FPP and the V3. Are they all set to 510 or 512 which ever you use?  That's the most likely thing. Otherwise does your universe and start channel match on all 3 things?  Does the stringports on the Falcon match the right channels?  Post a screenshot of xlights network, FPP e131 and Falcon network and string ports.


Sent from my iPhone using Tapatalk

Offline jnealand

  • Developer
  • ******
  • Join Date: Aug 2013
  • Location: Kennesaw, GA
  • Posts: 2,559
  • Kudos: 51
Re: Sequence colors
« Reply #6 on: January 07, 2018, 11:31:27 AM »
If a vendor advertises RGB lights that is a "category" and not necessarily the color order that the string as built.  You must know the color order the string is manufactured to, which should be in the product details.  I have many different strings bought over 5 years.  Some are RGB, some BGR, some BRG, but all are RGB strings.
Jim Nealand
Kennesaw, GA Falcon and Lynx, all 12v Multisync with Pi and BBB P10 and P5

Offline Emuney18

  • Sr. Member
  • ****
  • Join Date: Nov 2015
  • Location: Apex, NC
  • Posts: 448
  • Kudos: 5
Re: Sequence colors
« Reply #7 on: January 07, 2018, 12:59:19 PM »
This is not an rgb order problem if the V3 test mode rgbw is correct which it sounds like it was.


Sent from my iPhone using Tapatalk

Offline Lightsonthelake

  • Newbie
  • *
  • Join Date: Dec 2017
  • Location: Shepherdsville kentucky
  • Posts: 28
  • Kudos: 0
Re: Sequence colors
« Reply #8 on: January 07, 2018, 06:02:32 PM »
This is not an rgb order problem if the V3 test mode rgbw is correct which it sounds like it was.

Correct. The v3 tests proved the rbg setting is correct.
Sent from my iPhone using Tapatalk

Offline Lightsonthelake

  • Newbie
  • *
  • Join Date: Dec 2017
  • Location: Shepherdsville kentucky
  • Posts: 28
  • Kudos: 0
Re: Sequence colors
« Reply #9 on: January 07, 2018, 06:04:38 PM »
What do you mean by "when I did the custom color"?  Other than that statement it sounds like the channels or universes do not match between xlights, FPP and the V3. Are they all set to 510 or 512 which ever you use?  That's the most likely thing. Otherwise does your universe and start channel match on all 3 things?  Does the stringports on the Falcon match the right channels?  Post a screenshot of xlights network, FPP e131 and Falcon network and string ports.


Sent from my iPhone using Tapatalk

Through the fpp in the test page. The bottom test allows custom color parameters. I changed it to orange when I saw the errors there.

Offline Lightsonthelake

  • Newbie
  • *
  • Join Date: Dec 2017
  • Location: Shepherdsville kentucky
  • Posts: 28
  • Kudos: 0
Re: Sequence colors
« Reply #10 on: January 09, 2018, 07:25:23 PM »
Sorry for the delay, kids and work keeping me busy. So I fixed the problem. When I first for my f16v3 I didn't have my pi. Well I set the universes one way. When I got my pi I had changed the on xlights and didn't update it on the f16. Everything is looking sweet now. Thanks for the help guys.

 

Back to top