Author Topic: Beta SD image for FPP running on Raspbian Stretch  (Read 17249 times)

Offline k6ccc

  • Sr. Member
  • ****
  • Join Date: Mar 2015
  • Location: Glendora, Calif, U.S.A. (near Los Angeles)
  • Posts: 317
  • Kudos: 3
    • Newburgh Lights
Re: Beta SD image for FPP running on Raspbian Stretch
« Reply #255 on: March 13, 2018, 10:35:08 PM »
Version Info
FPP Version:v2.x-master-501-g481933ff
FPP OS Build:v1.11beta
A little testing on the static vs DHCP IP issue.  Pi gets 192.168.203.81 via DHCP.  Gave it a static IP of 192.168.203.71.  Both respond and work from my desktop PC (which has to route through two routers to get there).  In order to get the router out of the picture and possible ARP caching, I brought up a device (my work iPhone) onto the same WiFi LAN that the Pi was connecting to.  That device had never pinged the Pi via WiFi so it should have not had anything cached.  Both addresses respond to a ping, and I can get to the web interface from either address.

Code: [Select]
eth0: flags=4163  mtu 1500
        inet 192.168.131.81  netmask 255.255.255.0  broadcast 192.168.131.255
        ether b8:27:eb:b2:3f:80  txqueuelen 1000  (Ethernet)
        RX packets 1253990  bytes 810959738 (773.3 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 10737  bytes 8632674 (8.2 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

eth1: flags=4163  mtu 1500
        inet 169.254.33.169  netmask 255.255.0.0  broadcast 169.254.255.255
        ether d8:eb:97:b9:34:e6  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 141713231  bytes 57195392737 (53.2 GiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 12738  bytes 2722209 (2.5 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 12738  bytes 2722209 (2.5 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4163  mtu 1500
        inet 192.168.203.71  netmask 255.255.255.0  broadcast 192.168.203.255
        ether b8:27:eb:e7:6a:d5  txqueuelen 1000  (Ethernet)
        RX packets 78512  bytes 4624516 (4.4 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 17372  bytes 8251977 (7.8 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Captain, I see you just replied, and your answer largely negates the need for this post, but I'm leaving it in for useful information....
Using LOR (mostly SuperStar) for all sequencing - using FPP only to drive P5 and P10 panels.
Jim

Offline CaptainMurdoch

  • Administrator
  • *****
  • Join Date: Sep 2013
  • Location: Washington
  • Posts: 9,020
  • Kudos: 178
Re: Beta SD image for FPP running on Raspbian Stretch
« Reply #256 on: March 13, 2018, 11:07:51 PM »
OK, the corrected FPP-v2.0-Alpha-Pi-20180313.zip image is uploaded and available again.  Same filenames for the .zip and .img, but the timestamp of both should say the 14th.  This update removes network-manager and disables dhcpcd.  It still works fine here, so I think dhcpcd was causing the double-IP issue.

If you want to run the commands manually without having to reinstall the SD, you can login to the Pi and run the following:

Code: [Select]
sudo systemctl disable network-manager.service
sudo systemctl disable dhcpcd.service
sudo apt-get -y remove network-manager
sudo apt-get -y purge network-manager

Effectively, those are the only changes between the new and old SD image.
-
Chris

Offline Sawdust

  • Hero Member
  • *****
  • Join Date: Nov 2015
  • Location: Northern CA
  • Posts: 518
  • Kudos: 6
Re: Beta SD image for FPP running on Raspbian Stretch
« Reply #257 on: March 14, 2018, 12:27:57 AM »
v2.x-master-508-g08dc9c70

I did the re-image and manually updated.  IP's appear to be stable and functional, until I introduce static ip for wlan0 when strange things happen.  Example: I do a reboot, and everything looks fine, then it re-boots on it's own(seen on HDMI Screen) upon competition of 2 boot, I did a multisync and my host names has a -2 following host name for both eth0 and wlan0.....but not on the network screen.

One more thing: FPPD is stopped.

Edit 3/14 8:30 AM PST - Re-did Image again: everything was fine until I did a manual update.  That is what is stopping FPPD
« Last Edit: March 14, 2018, 09:43:19 AM by Sawdust »

Offline CaptainMurdoch

  • Administrator
  • *****
  • Join Date: Sep 2013
  • Location: Washington
  • Posts: 9,020
  • Kudos: 178
Re: Beta SD image for FPP running on Raspbian Stretch
« Reply #258 on: March 14, 2018, 10:01:59 AM »
I did the re-image and manually updated.  IP's appear to be stable and functional, until I introduce static ip for wlan0 when strange things happen.  Example: I do a reboot, and everything looks fine, then it re-boots on it's own(seen on HDMI Screen) upon competition of 2 boot, I did a multisync and my host names has a -2 following host name for both eth0 and wlan0.....but not on the network screen.

One more thing: FPPD is stopped.

The fppd stopped issue is fixed now if you run another manual update.  I had a typo in a commit last night.  I thought I test compiled it prior to commit, but I might be thinking of something else.

Are you sure the reboot wasn't caused by changing the channel outputs to enable something that needed to disable the onboard sound, such as the RPIWS281x output or direct-attached LED Panel output?

Offline Sawdust

  • Hero Member
  • *****
  • Join Date: Nov 2015
  • Location: Northern CA
  • Posts: 518
  • Kudos: 6
Re: Beta SD image for FPP running on Raspbian Stretch
« Reply #259 on: March 14, 2018, 12:03:23 PM »
Preliminary test appears good - no issues to report - FPPD is running, static IP no issue.
Basic running is good - more testing later

HDMI Screen lists the IP's, but follower some IPV6 addresses.
Shutdown - restarts removes the PV6 addresses, but now only lists the wlan0 - elan0 still connects and shows in multisync.
Few more reboots with and without elan0 connected shows hit or missed on elan0, wlan0 always listed - and very few without IPV6 addresses.  wlan0 always works as expected, and eth0 always works when connected, whether shown or not.  IPV6 has no effect, just garbage on the screen.



Offline k6ccc

  • Sr. Member
  • ****
  • Join Date: Mar 2015
  • Location: Glendora, Calif, U.S.A. (near Los Angeles)
  • Posts: 317
  • Kudos: 3
    • Newburgh Lights
Re: Beta SD image for FPP running on Raspbian Stretch
« Reply #260 on: March 14, 2018, 01:14:57 PM »
OK, the corrected FPP-v2.0-Alpha-Pi-20180313.zip image is uploaded and available again.  Same filenames for the .zip and .img, but the timestamp of both should say the 14th.

I have the revised file (confirmed that the timestamp shows the 14th) and have written it to a SD card so when I get home this evening, I can stick it into the Pi that is driving my P10 matrix and test it out.  I will advise my results...

Online pixelpuppy

  • Hero Member
  • *****
  • Join Date: Aug 2015
  • Location: Dallas, TX
  • Posts: 941
  • Kudos: 30
Re: Beta SD image for FPP running on Raspbian Stretch
« Reply #261 on: March 14, 2018, 01:50:13 PM »
I have the revised file (confirmed that the timestamp shows the 14th) and have written it to a SD card so when I get home this evening, I can stick it into the Pi that is driving my P10 matrix and test it out.  I will advise my results...


Don't forget to do Manual Update after booting off the SD image.  There were a couple fixes today after the [20180313) SD image was posted last night
xLights and Vixen3 for sequencing / FPP for scheduling and playing / Falcon controllers for pixels / DIY controllers for everything else

Offline k6ccc

  • Sr. Member
  • ****
  • Join Date: Mar 2015
  • Location: Glendora, Calif, U.S.A. (near Los Angeles)
  • Posts: 317
  • Kudos: 3
    • Newburgh Lights
Re: Beta SD image for FPP running on Raspbian Stretch
« Reply #262 on: March 14, 2018, 01:55:35 PM »
Don't forget to do Manual Update after booting off the SD image.  There were a couple fixes today after the [20180313) SD image was posted last night

That was a given, but thanks for the reminder...  With the code writers changing the code as much as several times per day, I always check before I start testing stuff.

Online pixelpuppy

  • Hero Member
  • *****
  • Join Date: Aug 2015
  • Location: Dallas, TX
  • Posts: 941
  • Kudos: 30
Re: Beta SD image for FPP running on Raspbian Stretch
« Reply #263 on: March 14, 2018, 01:57:30 PM »
Preliminary test appears good - no issues to report - FPPD is running, static IP no issue.
Basic running is good - more testing later

I concur.  Currently at rev-509 with IP addresses working as expected and FPPD running.

The next minor thing I notice is the FPP Settings page always shows the SD Card selected for External Storage Device - even after changing to USB, rebooting, and confirming the files under File Manager.  The "About" screen also indicates the Media storage is a different device than Root storage but FPP Settings always says mmcblk0

Online pixelpuppy

  • Hero Member
  • *****
  • Join Date: Aug 2015
  • Location: Dallas, TX
  • Posts: 941
  • Kudos: 30
Re: Beta SD image for FPP running on Raspbian Stretch
« Reply #264 on: March 14, 2018, 01:59:27 PM »
Don't forget to do Manual Update after booting off the SD image.  There were a couple fixes today after the [20180313) SD image was posted last night
That was a given, but thanks for the reminder...  With the code writers changing the code as much as several times per day, I always check before I start testing stuff.
Thats good thinking.   ;)

I just wanted to point out that previously, auto-update was enabled by default but that has changed to auto-update is disabled by default now.

Offline Sawdust

  • Hero Member
  • *****
  • Join Date: Nov 2015
  • Location: Northern CA
  • Posts: 518
  • Kudos: 6
Re: Beta SD image for FPP running on Raspbian Stretch
« Reply #265 on: March 14, 2018, 02:11:40 PM »
Are you sure the reboot wasn't caused by changing the channel outputs to enable something that needed to disable the onboard sound, such as the RPIWS281x output or direct-attached LED Panel output?

Only changes were SD Size, Border Color, Time, and wlan0=SSID/Password.  Didn't look at other screens.
re-boot after size was normal, double re-boot was after I set wlan0.  re-booted to verify setting held

Didn't happen on the next two
« Last Edit: March 14, 2018, 02:38:32 PM by Sawdust »

Offline CaptainMurdoch

  • Administrator
  • *****
  • Join Date: Sep 2013
  • Location: Washington
  • Posts: 9,020
  • Kudos: 178
Re: Beta SD image for FPP running on Raspbian Stretch
« Reply #266 on: March 14, 2018, 02:51:44 PM »
The next minor thing I notice is the FPP Settings page always shows the SD Card selected for External Storage Device - even after changing to USB, rebooting, and confirming the files under File Manager.  The "About" screen also indicates the Media storage is a different device than Root storage but FPP Settings always says mmcblk0

I added a note to the Pi Stretch Regressions ticket to look into this.

Offline brichi

  • Sr. Member
  • ****
  • Join Date: Dec 2017
  • Location:
  • Posts: 488
  • Kudos: 1
Re: Beta SD image for FPP running on Raspbian Stretch
« Reply #267 on: March 14, 2018, 03:55:51 PM »
I updated and I still lose connection


I have it set where my Mac is set to a static of
192.168.1.1 -
255.255.255.0 -
192.168.1.1


plug into a switch along with the pi set static to

192.168.1.101 -
255.255.255.0 -
192.168.1.1


ill be fine for a few minutes and then ill try and go to another menu like "backup" and then I lose connection and cannot ping .101 anymore... I did not have this issue before the 313 release

Offline brichi

  • Sr. Member
  • ****
  • Join Date: Dec 2017
  • Location:
  • Posts: 488
  • Kudos: 1
Re: Beta SD image for FPP running on Raspbian Stretch
« Reply #268 on: March 14, 2018, 04:13:12 PM »
after a few reboots its holding steady so far


I do notice now I keep getting a "under voltage" message but im using the same P/s that came with the Pi the entire time, first time im seeing this

Offline Sawdust

  • Hero Member
  • *****
  • Join Date: Nov 2015
  • Location: Northern CA
  • Posts: 518
  • Kudos: 6
Re: Beta SD image for FPP running on Raspbian Stretch
« Reply #269 on: March 14, 2018, 06:32:24 PM »
v2.x-master-509-g338042bf

IP are stable and match.  V1.10 master reads stand-alones correctly.  Not loosing connections.
7 sets of IP's connected and tracking. 2-Pi Zero, Pi 2B & 3-Pi3 - all multisyncs are reading correctly.
Pi Zero runs P5 2X2 (4X2 32X32) as expected.

Hit post and ran to the market...and this appeared; holding my post
Warning - while you were typing a new reply has been posted. You may wish to review your post.

I checked the connections when I returned 1-1/2 to 2 hours later.
Lost connection on a Pi Zero, a Pi 2 and a Pi3. the remaining did not get results for multisync...and eventually dropped connection
 
Power cycled all, and they all connected.  17:37 PDT

18:07 PDT they started dropping WiFi connections.  They seem to flag an error about another FPP connection then drops WiFi.

« Last Edit: March 14, 2018, 08:55:01 PM by Sawdust »

 

Back to top