v2.x-master-582-g6ef7b300

Author Topic: v2.x-master-582-g6ef7b300  (Read 265 times)

Offline jbskelton

  • Newbie
  • *
  • Join Date: Feb 2016
  • Location: South Bend, In
  • Posts: 20
  • Kudos: 1
v2.x-master-582-g6ef7b300
« on: May 14, 2018, 05:43:36 PM »
I am trying to setup the RPIWS281X on a Pi3b with a attached Pi-Cap.When I enable output & save I get a "Error restarting FPPD"If I disable the output & save FPPD starts as expected.Any Ideas?

Offline JonB256

  • Supporting Member
  • ******
  • Join Date: Mar 2013
  • Location: Granbury, Texas
  • Posts: 4,333
  • Kudos: 89
    • Granbury Christmas Lights
Re: v2.x-master-582-g6ef7b300
« Reply #1 on: May 14, 2018, 06:19:37 PM »
I am trying to setup the RPIWS281X on a Pi3b with a attached Pi-Cap.When I enable output & save I get a "Error restarting FPPD"If I disable the output & save FPPD starts as expected.Any Ideas?

When you enable a Pi-Cap, several things happen. First, it needs to disable the internal Sound system because the GPIO outputs are needed to drive pixels. That requires a Reboot, so it isn't surprising that FPPD doesn't restart properly if you haven't done a full reboot.

If you have rebooted (one or more times) and it still won't start, the Log files for FPPD should tell you what the conflict is. Logs are on the File Manager page in their own tab.

Offline jbskelton

  • Newbie
  • *
  • Join Date: Feb 2016
  • Location: South Bend, In
  • Posts: 20
  • Kudos: 1
Re: v2.x-master-582-g6ef7b300
« Reply #2 on: May 15, 2018, 12:33:51 PM »
I decided to revert back to fpp version 1.10 where the pi-cap runs as expected. I could not get the pi-cap to run on any of the v2.0 updates. fppd would not run with outputs enabled.
Thanks for the reply

Offline JonB256

  • Supporting Member
  • ******
  • Join Date: Mar 2013
  • Location: Granbury, Texas
  • Posts: 4,333
  • Kudos: 89
    • Granbury Christmas Lights
Re: v2.x-master-582-g6ef7b300
« Reply #3 on: May 15, 2018, 06:09:47 PM »
I decided to revert back to fpp version 1.10 where the pi-cap runs as expected. I could not get the pi-cap to run on any of the v2.0 updates. fppd would not run with outputs enabled.
Thanks for the reply

I put a Falcon PiCap on a RasPi3B running v2.0-582.  Like you, when I configured and enabled the output, FPPD stopped. :(

Tried Standalone, Master, Bridge and Remote - no difference

In the fpp_init.log file, I get these entries:

Code: [Select]
pinMode: You have not called one of the wiringPiSetup
  functions, so I'm aborting your program before it crashes anyway.
pinMode: You have not called one of the wiringPiSetup
  functions, so I'm aborting your program before it crashes anyway.
pinMode: You have not called one of the wiringPiSetup
  functions, so I'm aborting your program before it crashes anyway.
FPP - Checking for Falcon hardware on SPI port

uncheck and save and FPPD restarts immediately.

Offline dkulp

  • Developer
  • ******
  • Join Date: Sep 2013
  • Location: Framingham, MA
  • Posts: 829
  • Kudos: 35
Re: v2.x-master-582-g6ef7b300
« Reply #4 on: May 15, 2018, 07:27:17 PM »



Fixed
Dan Kulp

Offline JonB256

  • Supporting Member
  • ******
  • Join Date: Mar 2013
  • Location: Granbury, Texas
  • Posts: 4,333
  • Kudos: 89
    • Granbury Christmas Lights
Re: v2.x-master-582-g6ef7b300
« Reply #5 on: May 16, 2018, 07:00:36 AM »



Fixed
Yes, it is!  FPPD is running now.

Sent from my SM-G955U using Tapatalk


 

Back to top