Author Topic: 2.x - Rasclock RTC no longer working  (Read 549 times)

Offline brichi

  • Sr. Member
  • ****
  • Join Date: Dec 2017
  • Location:
  • Posts: 498
  • Kudos: 1
2.x - Rasclock RTC no longer working
« on: August 08, 2018, 07:18:31 PM »
On my Pi3B+ I have a rasclock setup with no issues previously in 2.x, now I wiped the cards yesterday and did a fresh install so im now on v2.x-master-650-gb13a0353 (master branch) and no matter what I do, the RTC is not working. steps I have taken
[/color][/size]1. go into time/date and enable rasclock
2. reboot as instructed
3. go back in set the time/date and "submit"
[/font]
everything looks great but once I reboot or unplug power and power back on the time is off by the amount of time the Pi has been off, I shut it snow for 10 minutes and booted it back up and the time is off by 10 minutes now,
I will not have this on the internet at all so I need the RTC and I have tested the battery and the voltage is good.
Thanks guys for any info!

Offline dkulp

  • Moderator
  • *****
  • Join Date: Sep 2013
  • Location: Framingham, MA
  • Posts: 965
  • Kudos: 47
Re: 2.x - Rasclock RTC no longer working
« Reply #1 on: August 08, 2018, 08:22:30 PM »



This sounds like the crystal on the RasClock is dead.   (or battery isn't working, but you checked that) . If it's setting it to the time when the Pi was shutdown, it sound like it's getting the time from the chip OK, it's just not advancing when the power is not applied.   


If you log into the command line and run "sudo hwclock -r" a bunch of times.  If that's not advancing, it's definitely the crystal.   
Dan Kulp

Offline brichi

  • Sr. Member
  • ****
  • Join Date: Dec 2017
  • Location:
  • Posts: 498
  • Kudos: 1
Re: 2.x - Rasclock RTC no longer working
« Reply #2 on: August 08, 2018, 09:30:00 PM »



This sounds like the crystal on the RasClock is dead.   (or battery isn't working, but you checked that) . If it's setting it to the time when the Pi was shutdown, it sound like it's getting the time from the chip OK, it's just not advancing when the power is not applied.   


If you log into the command line and run "sudo hwclock -r" a bunch of times.  If that's not advancing, it's definitely the crystal.


ran that, maybe it blew out?. all I get is



fpp@MAINPI:~ $ sudo hwclock -r
hwclock: Cannot access the Hardware Clock via any known method.                                                   
hwclock: Use the --debug option to see the details of our search for an access method.   

Offline brichi

  • Sr. Member
  • ****
  • Join Date: Dec 2017
  • Location:
  • Posts: 498
  • Kudos: 1
Re: 2.x - Rasclock RTC no longer working
« Reply #3 on: August 08, 2018, 10:01:01 PM »
This sounds like the crystal on the RasClock is dead.   (or battery isn't working, but you checked that) . If it's setting it to the time when the Pi was shutdown, it sound like it's getting the time from the chip OK, it's just not advancing when the power is not applied.   If you log into the command line and run "sudo hwclock -r" a bunch of times.  If that's not advancing, it's definitely the crystal.



so I found my other RTC that I set fpp to ds1305/1307, in shell I type the command repeatedly and the time does advance, I have the time set right on my my clock but If I do a reboot of the pi, its now behind by 10 seconds , if I power it off, it doesn't keep time



fpp@MATRIX2
:~ $ sudo hwclock -r
2018-08-08 23:57:10.078952-0400                                                                   
fpp@MATRIX2:~ $ sudo hwclock -r
2018-08-08 23:57:15.235089-0400                                                                   
fpp@MATRIX2:~ $ sudo hwclock -r
2018-08-08 23:57:17.217192-0400                                                                   
fpp@MATRIX2:~ $ sudo hwclock -r
2018-08-08 23:57:18.710368-0400                                                                   
fpp@MATRIX2:~ $ sudo hwclock -r
2018-08-08 23:57:19.727159-0400                                                                   
fpp@MATRIX2:~ $ sudo hwclock -r
2018-08-08 23:57:20.606731-0400                                                                   
fpp@MATRIX2:~ $ sudo hwclock -r
2018-08-08 23:57:21.574197-0400                                                                   
fpp@MATRIX2:~ $

this is the model - https://www.amazon.com/gp/product/B00ZOXWHK4/ref=oh_aui_search_detailpage?ie=UTF8&psc=1
]it used to work with previous versions on my Pi, Ihaven't[size=78%] looked in a while so not sure how far back it stopped working[/size]

Offline dkulp

  • Moderator
  • *****
  • Join Date: Sep 2013
  • Location: Framingham, MA
  • Posts: 965
  • Kudos: 47
Re: 2.x - Rasclock RTC no longer working
« Reply #4 on: August 09, 2018, 12:52:38 AM »

ran that, maybe it blew out?. all I get is

fpp@MAINPI
:~ $ sudo hwclock -r
hwclock: Cannot access the Hardware Clock via any known method.                                                   
hwclock: Use the --debug option to see the details of our search for an access method.   


Can you run:


sudo modprobe i2c-dev
sudo i2cdetect 1


and let me know if any row/col does NOT have a -- in it?

Offline jbskelton

  • Newbie
  • *
  • Join Date: Feb 2016
  • Location: South Bend, In
  • Posts: 21
  • Kudos: 1
Re: 2.x - Rasclock RTC no longer working
« Reply #5 on: August 09, 2018, 05:59:57 AM »
I am also seeing the ras clock not working. I ran the commands suggested.
fpp@FPPB3-REMOTE:~ $ sudo hwclock -r
2018-08-09 07:51:23.474637-0400
fpp@FPPB3-REMOTE:~ $ sudo hwclock -r
2018-08-09 07:51:33.126960-0400
fpp@FPPB3-REMOTE:~ $ sudo hwclock -r
2018-08-09 07:51:36.110264-0400
fpp@FPPB3-REMOTE:~ $ sudo hwclock -r
2018-08-09 07:51:37.782967-0400
fpp@FPPB3-REMOTE:~ $ sudo hwclock -r
2018-08-09 07:51:41.991364-0400
fpp@FPPB3-REMOTE:~ $ sudo hwclock -r
2018-08-09 07:51:45.999782-0400
fpp@FPPB3-REMOTE:~ $ sudo hwclock -r
2018-08-09 07:51:47.632657-0400
fpp@FPPB3-REMOTE:~ $ sudo modprobe i2c-dev
fpp@FPPB3-REMOTE:~ $ sudo i2cdetect 1
WARNING! This program can confuse your I2C bus, cause data loss and worse!
I will probe file /dev/i2c-1.
I will probe address range 0x03-0x77.
Continue? [Y/n] y
     0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f
00:          -- -- -- -- -- -- -- -- -- -- -- -- --
10: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
20: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
40: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
50: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
60: -- -- -- -- -- -- -- -- UU -- -- -- -- -- -- --
70: -- -- -- -- -- -- -- --

Offline brichi

  • Sr. Member
  • ****
  • Join Date: Dec 2017
  • Location:
  • Posts: 498
  • Kudos: 1
Re: 2.x - Rasclock RTC no longer working
« Reply #6 on: August 09, 2018, 06:07:50 AM »

ran that, maybe it blew out?. all I get is

fpp@MAINPI
:~ $ sudo hwclock -r
hwclock: Cannot access the Hardware Clock via any known method.                                                   
hwclock: Use the --debug option to see the details of our search for an access method.   


Can you run:


sudo modprobe i2c-dev
sudo i2cdetect 1


and let me know if any row/col does NOT have a -- in it?


I will check later after work and report back

Offline jbskelton

  • Newbie
  • *
  • Join Date: Feb 2016
  • Location: South Bend, In
  • Posts: 21
  • Kudos: 1
Re: 2.x - Rasclock RTC no longer working
« Reply #7 on: August 09, 2018, 06:21:28 AM »
In the post above I am using a Pi-cap on the ras-pi

Offline AAH

  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Location: Australia
  • Posts: 602
  • Kudos: 19
  • Blinky blinky blinky
    • I love blinky lights
Re: 2.x - Rasclock RTC no longer working
« Reply #8 on: August 09, 2018, 07:54:38 AM »
I have heard reports that FPP2 isn't working with the same RTC on my Octoscrolla's. I am yet to transition to FPP2 on either BBB or Pi yet so I haven't been able to check.

Offline brichi

  • Sr. Member
  • ****
  • Join Date: Dec 2017
  • Location:
  • Posts: 498
  • Kudos: 1
Re: 2.x - Rasclock RTC no longer working
« Reply #9 on: August 09, 2018, 07:57:14 AM »
I have heard reports that FPP2 isn't working with the same RTC on my Octoscrolla's. I am yet to transition to FPP2 on either BBB or Pi yet so I haven't been able to check.


Yes, I had definitely emailed you I believe about that, I thought it was just my Octoscrolla but now im starting to believe its not

Offline brichi

  • Sr. Member
  • ****
  • Join Date: Dec 2017
  • Location:
  • Posts: 498
  • Kudos: 1
Re: 2.x - Rasclock RTC no longer working
« Reply #10 on: August 09, 2018, 02:56:55 PM »

ran that, maybe it blew out?. all I get is

fpp@MAINPI
:~ $ sudo hwclock -r
hwclock: Cannot access the Hardware Clock via any known method.                                                   
hwclock: Use the --debug option to see the details of our search for an access method.   


Can you run:


sudo modprobe i2c-dev
sudo i2cdetect 1


and let me know if any row/col does NOT have a -- in it?


ok so I ran the text above with  rasclock on my pi 3b+ and get



     0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f                                                               
00:          -- -- -- -- -- -- -- -- -- -- -- -- --                                                               
10: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --                                                               
20: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --                                                               
30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --                                                               
40: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --                                                               
50: -- 51 -- -- -- -- -- -- -- -- -- -- -- -- -- --                                                               
60: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --                                                               
70: -- -- -- -- -- -- -- --                               




and ran my other RTC ds1305/1307, on a pi 3B and got




  0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f                                                                         
00:          -- -- -- -- -- -- -- -- -- -- -- -- --                                                                          10: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --                                                                          20: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --                                                                          30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --                                                                          40: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --                                                                          50: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --                                                                          60: -- -- -- -- -- -- -- -- UU -- -- -- -- -- -- --                                                                         
70: -- -- -- -- -- -- -- --                                                                                                 

Offline dkulp

  • Moderator
  • *****
  • Join Date: Sep 2013
  • Location: Framingham, MA
  • Posts: 965
  • Kudos: 47
Re: 2.x - Rasclock RTC no longer working
« Reply #11 on: August 10, 2018, 06:55:28 AM »



I just pushed some changes for the RTC configuration to try and streamline things between the BBB and Pi.  I hope that fixes the issues.  I can confirm that the RTC is working on the BBB.   I don't have an RTC for the Pi so I'm not sure if  it fixes the Pi stuff as well. 


That said, I still think it's crazy that people are running their devices without internet access.   It's called "Internet of Things" for a reason.


Offline brichi

  • Sr. Member
  • ****
  • Join Date: Dec 2017
  • Location:
  • Posts: 498
  • Kudos: 1
Re: 2.x - Rasclock RTC no longer working
« Reply #12 on: August 10, 2018, 07:10:27 AM »



I just pushed some changes for the RTC configuration to try and streamline things between the BBB and Pi.  I hope that fixes the issues.  I can confirm that the RTC is working on the BBB.   I don't have an RTC for the Pi so I'm not sure if  it fixes the Pi stuff as well. 


That said, I still think it's crazy that people are running their devices without internet access.   It's called "Internet of Things" for a reason.


I've been keeping mine off my wifi being that when its on the wifi, if I have to reboot during a show, the entire show is delayed and jumpy for a few minutes until it all catches up for some reason. I reported that on GitHub I believe. plus I didn't know if that would effect my show with network traffic in my house


https://github.com/FalconChristmas/fpp/issues/378

Offline pixelpuppy

  • Hero Member
  • *****
  • Join Date: Aug 2015
  • Location: Dallas, TX
  • Posts: 991
  • Kudos: 32
Re: 2.x - Rasclock RTC no longer working
« Reply #13 on: August 10, 2018, 07:43:48 AM »
That said, I still think it's crazy that people are running their devices without internet access.   It's called "Internet of Things" for a reason.
I totally agree  :D    I wish my microwave and stove would get their time from the internet too  ;D   (the next model probably will  ::) )
« Last Edit: August 10, 2018, 07:53:26 AM by pixelpuppy »
xLights and Vixen3 for sequencing / FPP for scheduling and playing / Falcon controllers for pixels / homemade controllers for everything else

Offline brichi

  • Sr. Member
  • ****
  • Join Date: Dec 2017
  • Location:
  • Posts: 498
  • Kudos: 1
Re: 2.x - Rasclock RTC no longer working
« Reply #14 on: August 10, 2018, 07:47:11 AM »
That said, I still think it's crazy that people are running their devices without internet access.   It's called "Internet of Things" for a reason.
I totally agree  :D


doesn't it leaving it on the network cause flooding? or delays because I have a lot on my home network already

 

Back to top