Author Topic: FPP & RPi 3B: Trouble with WiFi & PSK P/W: Using ATT Uverse WiFi router  (Read 75 times)

Offline PapaStiff

  • Newbie
  • *
  • Join Date: Sep 2018
  • Location:
  • Posts: 2
  • Kudos: 0
Thanks, ahead of time, for the support. 

I have a RPi-3B, two F16V3's controllers, and a desktop PC running Windows 10 & xLights (latest version).  Ran FPP & transferred the music & sequence files.  Using Unicast.  The next step was the FPP Network connection page.  I have an AT&T Uverse wireless router.  Upon first entry into the FPP, and before I enter the enet0 address, I entered an unused WiFi address on my home network (192.168.1.xxx).  I also entered my AT&T home WiFi network SSID & PSK (password).  In brief, I can't get the wireless to work.

I noticed an odd problem.  I can't get the full AT&T password to stay in the FPP password block.  I'm not sure if this is a problem or not, but, a specific character keeps disappearing in the password: The "+" symbol.  I keep retyping it, and it keeps disappearing.  Is this normal?  Does FPP software have an issue with certain WiFi password characters?  My p/w also has a "%" symbol and that's fine.  Has anyone had issues or similar with the AT&T Uverse wireless routers? 

Since I typed this, I edited Wi-Fi settings in the wpa-supplicant config file by typing "sudo nano /etc/wpa_supplicant/wpa_supplicant.conf".  I did see the "network={ ssid=xxx & psk=xxx}" statement. My SSID was correct for my AT&T wireless router. I did see the same problem with the PSK/password. It correctly showed the p/w except for the "+" again (blank character). I tried to re-add the "+" in the editor & saved. It seems to take it until I rebooted. Still no WiFi.

Any ideas on what to try next?  I mean, short of chaning out my router.
 
Thanks!
« Last Edit: September 18, 2018, 11:47:54 PM by PapaStiff »

Offline PapaStiff

  • Newbie
  • *
  • Join Date: Sep 2018
  • Location:
  • Posts: 2
  • Kudos: 0
Re: FPP & RPi 3B: Trouble with WiFi & PSK P/W: Using ATT Uverse WiFi router
« Reply #1 on: September 19, 2018, 08:19:47 PM »
Update: 
As a troubleshooting idea, from a user in another forum, I created a hotspot with my Samsung Galaxy phone to avoid the AT&T Uverse WiFi router.  It worked! After changing the network SSID & PSK to that of my Samsung hotspot, through the Falcon Pi Player (FPP) interface software, I went back to my RPi Linux window and typed "ifconfig". It finally showed an IP address for the WiFi (I haven't been able to do that until now). As a back up check, I was able to ping my hotspot WiFi address from the Linux window.

Now I need to change my AT&T Uverse wireless router key/password. I'll need to google how to do that, but, I'm not expecting that to be an issue. I just find it strange that the FPP, or RPi, software doesn't like a "+" symbol in the PSK/password. But, okay, time to move past that and do an end-around to avoid it.  I'll hopefully make one more post to this string with the results after changing my AT&T router PSK.  Hopefully, I can do that.

 

Back to top