Author Topic: FPP and Video  (Read 207 times)

Offline fowler279

  • Newbie
  • *
  • Join Date: Sep 2016
  • Location:
  • Posts: 16
  • Kudos: 0
FPP and Video
« on: October 08, 2018, 08:18:13 AM »
Im really wanting to be able to use the FPP as a media player to run my projections but the resolution coming from the PI is way different than a standard media player.  Does anyone know how to correct this or can it even be corrected?  When my media player is hooked up the projection takes up the entire area of the window and then a little more on the sides.  When i change over to the Pi it shrinks down and only covers about 2/3's of the height and a little less on the sides.  Really want to be able to use the FPP to sync lights and video together but this issue is killing me.  Any help would be greatly appreciated.  Thanks

Offline Loopz

  • Newbie
  • *
  • Join Date: Nov 2016
  • Location: Lubbock, Tx
  • Posts: 49
  • Kudos: 0
Re: FPP and Video
« Reply #1 on: October 09, 2018, 01:53:13 PM »
what version of FP are you running
"It's the ship that made the Kessel Run in less than twelve parsecs. I've outrun Imperial starships. Not the local bulk cruisers mind you, I'm talking about the big Corellian ships now. She's fast enough for you old man. What's the cargo?" - Han

Offline Loopz

  • Newbie
  • *
  • Join Date: Nov 2016
  • Location: Lubbock, Tx
  • Posts: 49
  • Kudos: 0
Re: FPP and Video
« Reply #2 on: October 09, 2018, 01:58:56 PM »
I ask because of a few reasons, but mostly I believe you need to go to global settings and check the FORCE HDMI option when using a projector,  the omxplayer will not upscale or change the format of the original video.  you may need to change the video format size and re upload it.

Offline Loopz

  • Newbie
  • *
  • Join Date: Nov 2016
  • Location: Lubbock, Tx
  • Posts: 49
  • Kudos: 0
Re: FPP and Video
« Reply #3 on: October 09, 2018, 02:02:01 PM »
oh and here is the page in the manual


+https://falcon-player.gitbooks.io/falcon-player-manual/content/chapter_nine_miscellaneous_items/playing_video.html

Offline fowler279

  • Newbie
  • *
  • Join Date: Sep 2016
  • Location:
  • Posts: 16
  • Kudos: 0
Re: FPP and Video
« Reply #4 on: October 10, 2018, 07:40:25 AM »
Using the latest 2.1 version of FPP.  Im pretty sure it is forced but will verify tonight.  If that doesnt work will also look at changing the video format.  Thanks for the info.

Offline richardh

  • Newbie
  • *
  • Join Date: Jan 2017
  • Location:
  • Posts: 5
  • Kudos: 0
Re: FPP and Video
« Reply #5 on: October 10, 2018, 07:49:05 PM »
If you don't have the PI plugged into a HDMI monitor/projector when you boot it up, it will default to really low resolution which is kind of a safe mode.

I had this issue and I have forced my pi to display 1080p out of the HDMI port. This way if you turn on your pi without your display connected and on, it will always output 1080p

I did everything in the config.txt file that is on the pi. You can connect via a terminal session to the pi or login if you have a keyboard connected. I did everything in the config.txt file that is on the pi. You can connect via a terminal session to the pi or login if you have a keyboard connected. Once you are in do a

sudo nano /boot/config.txt

this will allow you to edit the config.txt file. Here is how I have mine setup which forces it into 1080p mode. Make sure you get all the stuff under the "# NOOBS Auto-generated Settings:" also

Code: [Select]
# For more options and information see
# http://www.raspberrypi.org/documentation/configuration/config-txt.md
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
hdmi_group=1
hdmi_mode=16

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README


# NOOBS Auto-generated Settings:
hdmi_force_hotplug=1
config_hdmi_boost=4
overscan_left=24
overscan_right=24
overscan_top=16
overscan_bottom=16
disable_overscan=0

# Enable SPI in device tree
dtparam=spi=on

# Enable I2C in device tree
dtparam=i2c=on

# Setting kernel scaling framebuffer method
scaling_kernel=8


# NOOBS Auto-generated Settings:
hdmi_force_hotplug=1
# Allow more current through USB
max_usb_current=1


# Configure onboard serial to allow DMX
init_uart_clock=16000000

# Switch Pi v3 onboard serial and Bluetooth to allow DMX on Pi v3
dtoverlay=pi3-miniuart-bt

Offline fowler279

  • Newbie
  • *
  • Join Date: Sep 2016
  • Location:
  • Posts: 16
  • Kudos: 0
Re: FPP and Video
« Reply #6 on: October 10, 2018, 09:42:39 PM »
Thanks ill give that a try.  I tried up converting the video as some are not full HD but that didnt change the size of the projection.  I have tried making sure that the projector was on and connected when the PI booted but didnt seem to make a difference either.  But will try the settings and see if that fixes anything.  Hopefully it does as im trying to automate as much as i can as well as have a pretty dynamic display instead of just video looping in these windows.  May have to result in making the video and stitching everything together to make it play the way i want it to,

Offline richardh

  • Newbie
  • *
  • Join Date: Jan 2017
  • Location:
  • Posts: 5
  • Kudos: 0
Re: FPP and Video
« Reply #7 on: October 10, 2018, 09:53:26 PM »
Mostly you need to uncomment the
hdmi_force_hotplug=1 (there are multiple places in the config file)

and make sure to uncomment and change the hdmi group and mode - I have it set for 1080p 60hz which is mode 16

hdmi_group=1
hdmi_mode=16

For a list of all the resolutions you can force it to in the config.txt file, Check out this link

https://raspberrypi.stackexchange.com/tags/config.txt/info

You will want to get your pi outputting 1080p if you can, but some monitors/projectors have a "pixel for pixel" feature and it may be turned on and your projector is showing the true resolution of the input signal and displaying black around it. You may want to go into your menu settings on your projector and see if there is anything like that and turn it off so it stretches any input signal it is getting to full screen.
« Last Edit: October 10, 2018, 10:05:02 PM by richardh »

Offline fowler279

  • Newbie
  • *
  • Join Date: Sep 2016
  • Location:
  • Posts: 16
  • Kudos: 0
Re: FPP and Video
« Reply #8 on: October 10, 2018, 10:04:16 PM »
Tried that and still looks the same.  Cutting the image down quite a bit on top and bottom.  Its the same when it boots so just think its a native resolution of the PI but to make the image big enough from the pi to fill my window it makes it way overshoot the sides.  Where the media player im using doesnt have that issue.  It fills the window and barely overshoots the sides but fills the top and bottom. 

Offline fowler279

  • Newbie
  • *
  • Join Date: Sep 2016
  • Location:
  • Posts: 16
  • Kudos: 0
Re: FPP and Video
« Reply #9 on: October 10, 2018, 10:22:20 PM »
Didnt think about the projector being the issue.  Ill have to look into that tomorrow.

Offline fowler279

  • Newbie
  • *
  • Join Date: Sep 2016
  • Location:
  • Posts: 16
  • Kudos: 0
Re: FPP and Video
« Reply #10 on: October 11, 2018, 09:42:08 PM »
So looks like its not the projector either.  Changed the aspect ratio on the projector checked all settings and it still cuts the image down.  Not sure what to really do at this point other than to accept that and move on with my original solution. 

 

Back to top