Falcon Christmas

Falcon Christmas => Falcon Smart String Utility => Topic started by: arw01 on June 30, 2014, 02:44:40 PM

Title: Checking on the latest version for SSCV4 and Zeus 8 and Zeus 16
Post by: arw01 on June 30, 2014, 02:44:40 PM
Ok, I THINK maybe I understand how to do this the first time, maybe.

The SSCV4 software linked here is the correct and most current version to use:

http://falconchristmas.com/forum/index.php?action=downloads;sa=view;down=31

Or do I need something else to program both SSCV4 and Zeus for the first time?

Next do I just use a picket 3 like normal on the SCSA pins?
Title: Re: Checking on the latest version for SSCV4 and Zeus 8 and Zeus 16
Post by: David Pitts on June 30, 2014, 03:13:08 PM
I cleaned it up a bit. Here are the latest downloads for SSCv4. The Zeus version is not complete.
Title: Re: Checking on the latest version for SSCV4 and Zeus 8 and Zeus 16
Post by: maffeirw on June 30, 2014, 03:28:12 PM
I cleaned it up a bit. Here are the latest downloads for SSCv4. The Zeus version is not complete.

Not quite sure where here is. The latest in the Wiki seems to be v0.0.4 from late Feb. is that it?
Title: Re: Checking on the latest version for SSCV4 and Zeus 8 and Zeus 16
Post by: David Pitts on June 30, 2014, 03:56:39 PM
I cleaned it up a bit. Here are the latest downloads for SSCv4. The Zeus version is not complete.

Not quite

sure where here is. The latest in the Wiki seems to be v0.0.4 from late Feb. is that it?

Nice catch. I forgot the link.
http://falconchristmas.com/forum/index.php?action=downloads;cat=11
Title: Re: Checking on the latest version for SSCV4 and Zeus 8 and Zeus 16
Post by: drlucas on November 07, 2014, 05:19:04 PM
I'm looking to add 6 mini trees to the front yard and pulling out a Zeus 16 that I haven't used yet....I saw once upon a time some alpha code out there...what's the latest on this - i'm willing to give it a test run.
Title: Re: Checking on the latest version for SSCV4 and Zeus 8 and Zeus 16
Post by: David Pitts on November 07, 2014, 06:06:05 PM
Try it out
Title: Re: Checking on the latest version for SSCV4 and Zeus 8 and Zeus 16
Post by: drlucas on November 07, 2014, 06:29:24 PM
Will do.....just took a look through my basement and realized I have three power supplies sitting there...one is 12v only, one is from an old Sun V120 server and another is from a HP desktop and NONE of them have the right power adapters on them...so tomorrow I'll go out and get another PSU for it...I have the icsp socket board to program the pics so maybe tonight I'll flash up the 16 chips. will report back later this weekend on how I make out.
Title: Re: Checking on the latest version for SSCV4 and Zeus 8 and Zeus 16
Post by: drlucas on November 07, 2014, 07:02:21 PM
Well...this pic isn't listed on my datasheet. Any thoughts on what one I might be able to program the PIC24F04KA200 with?

http://www.microbot.it/documents/mr004-001_datasheet.pdf

Connecting to MPLAB PICkit 3...
Firmware Suite Version.....01.33.20
Firmware type..............dsPIC33F/24F/24H

Target detected
Target Device ID (0xffff0000) does not match expected Device ID (0xd020000).
Title: Re: Checking on the latest version for SSCV4 and Zeus 8 and Zeus 16
Post by: David Pitts on November 07, 2014, 07:15:37 PM
Jim nealand had a diagram and picture showing how to set up the j1sys adapter.
Title: Re: Checking on the latest version for SSCV4 and Zeus 8 and Zeus 16
Post by: drlucas on November 07, 2014, 07:19:23 PM
http://falconchristmas.com/forum/index.php/topic,793.msg10998.html#msg10998 found it...will pull the breadboard out in the morning and wire it up.
Title: Re: Checking on the latest version for SSCV4 and Zeus 8 and Zeus 16
Post by: twooly on November 07, 2014, 07:55:37 PM
Another trick is to put the pic in a SSC v4 and flash it there if you don't want to worry about the wiring.
Title: Re: Checking on the latest version for SSCV4 and Zeus 8 and Zeus 16
Post by: drlucas on November 08, 2014, 06:45:42 AM
That would work for me too...I think I still have a v4 that hasn't been deployed in "the field" yet. Although with that approach and 32 pics to flash you can almost count on me bending a pin or two  :-[
Title: Re: Checking on the latest version for SSCV4 and Zeus 8 and Zeus 16
Post by: arw01 on November 08, 2014, 10:12:27 AM
That would work for me too...I think I still have a v4 that hasn't been deployed in "the field" yet. Although with that approach and 32 pics to flash you can almost count on me bending a pin or two  :-[

Of course I did bend a pin or two, but I got pretty good with a small flat screwdriver prying those pics out pretty much straight up after I loosened them from both ends.

Trick was to stick the screw driver under both ends and with give it a twist if the blade was wider than the shank or light slightly to loose the chip from the socket.  After I had done this 20+ times, the SSC4 socket wasn't so tight that I had to really pry anymore.

I think you could get away with not putting the chip all the way down in the socket pretty easy too, but I always do a verify after I write it to make sure the checksum matches.
Title: Re: Checking on the latest version for SSCV4 and Zeus 8 and Zeus 16
Post by: drlucas on November 08, 2014, 12:50:14 PM
OK...all 16 pics for the first Zeus has been flashed and my PSU has been acquired - bought a cheapo one. Threw the program jumper on and test mode is working just fine. Once I build up some star toppers and mini trees this afternoon I'll try to get to the more advanced testing. Rumor has it there will be an inch of snow coming our way by the end of next week so I best get at it!!!

....and good idea about the verify. I skipped it, so if I have any strange results, I'll pull the pic and reprogram.
Title: Re: Checking on the latest version for SSCV4 and Zeus 8 and Zeus 16
Post by: drlucas on November 08, 2014, 07:39:45 PM
I just realized a tiny issue. I have three square nodes at the end of the nodes. Is the best way to deal with this to use xlights and set the type of node for the the 9 channels (use rgb vs brg or whatever they actually are). So I will have 7 mini tree models and then 7 mini tree star models and on thee Zeus just set the color order as rgb ?
Title: Re: Checking on the latest version for SSCV4 and Zeus 8 and Zeus 16
Post by: drlucas on November 08, 2014, 07:40:30 PM
Oh and this is what these things look like. Hope they will be nice at night.

[attachment deleted by admin]
Title: Re: Checking on the latest version for SSCV4 and Zeus 8 and Zeus 16
Post by: drlucas on November 09, 2014, 03:14:53 PM
OK - Not working.

I am able to get test mode on the first 9 pics that I have connected, but when I go to program it's not working.

I am using port 2, 3rd pair off the FPD.
Using ID 0 for the hex file.
Firmware file: FalconZeus v0.0.0_id_0.hex.

Title: Re: Checking on the latest version for SSCV4 and Zeus 8 and Zeus 16
Post by: David Pitts on November 09, 2014, 03:16:39 PM
Please post screen shots of FPD screen and SSC/uSC control panel.
Title: Re: Checking on the latest version for SSCV4 and Zeus 8 and Zeus 16
Post by: drlucas on November 09, 2014, 04:08:27 PM
SSC control panel?? maybe that's what I'm missing as I'm just using the Controller software. see attached though.

[attachment deleted by admin]
Title: Re: Checking on the latest version for SSCV4 and Zeus 8 and Zeus 16
Post by: drlucas on November 09, 2014, 04:32:12 PM
I may have a work around....I used Universe 1 on the FPD instead of Universe 7....i'm now going to move the wire back over and see if that did the trick... looks promising though
Title: Re: Checking on the latest version for SSCV4 and Zeus 8 and Zeus 16
Post by: drlucas on November 09, 2014, 05:01:13 PM
OK... so something is just messed up with that one pair on that one port for some reason. Once I connected up port 3 and used the first pair it worked. I'm happy my 7 mini trees are working with the Zeus 16. YEAH!!!!

[attachment deleted by admin]
Title: Re: Checking on the latest version for SSCV4 and Zeus 8 and Zeus 16
Post by: onesmoothhead on November 12, 2014, 10:25:29 AM
Hello all, I had some issues with two Zeus 8 running a large (1680) node Vertical matrix.  The original firmware I was using was causing some flashing. I re-flashed both with Zeus/Falcon firmware and was able to use the programmer created by David.  All is working fine. I had universe jumpers set to the correct universe. I used .hex 0 for universe one for firmware and .hex 1 for universe 2.  I was able to program universe ones first PIC and then set the channel to 1217 and used the Clone box to program the other 7 section or PICS to complete the channel programming for Universe 1. I then created my model for Universe 2 and set the start channel to 4097 and cloned the next 7 in universe two. I used a Zeus 8 in each universe.  I must say this is great firmware David and thank you. Here is a FB link to a video of the results shot during the day. The video does not do justice.  This Matrix is so clean in the video it is a pix-elated. Not sure why. You may notice there is no stutter or delayed light movement. https://www.facebook.com/video.php?v=422892487864760
I have a video of it at night I can post this evening when I return home if you want to see how bright and clean the firmware makes the sign run. Kevin
Title: Re: Checking on the latest version for SSCV4 and Zeus 8 and Zeus 16
Post by: drlucas on November 12, 2014, 07:11:56 PM
Nice matrix!!! Mine is running off two F16s ....the Zeus was going to be used for that, but I ended up having much better power supplies to use (spare HP DL380 power supplies) so went with the Falcon. I am very happy though with that firmware David put ..now that I have resolved my other configuration issue on the software front I had with a mix of square nodes and pixels on the same string everything is working nicely for me!!!