Falcon Christmas

Falcon Christmas => Falcon Player (FPP) => Topic started by: ThreeSizes on January 13, 2016, 09:22:14 AM

Title: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: ThreeSizes on January 13, 2016, 09:22:14 AM
I have spent the last couple of months researching and planning for my show. There is a lot of information here in the forums on how to do it which is great, but some of the information is spread out, so this is my attempt to consolidate and boil down how I believe I can setup my show network using a Master FPP with one or more Remote FPP's over WiFi with some pretty graphics with the intent that over time I will fill out some of the missing information and morph this into a mini How-To and not just a walk-through of my setup. Now I'm a experienced systems/network/security engineer by day, so this really is to help out the community some.

The drawing attached to this post is my design for the network. I will have a Master FPP feeding the FM Transmitter, two Remote FPPs each feeding a F16V2, a Remote FPP controlling some house lights via zWave modules, and a Remote FPP controlling a P10 matrix. All of the FPPs will be connected to my main network via a WiFi adapter.

I have come up with four options to implement this and I'll go into each option in a separate post. Even though your show may be totally different with more or less FPPs, or even just one FPP, pick just a portion of my config or just focus in on Remote1 in my examples.

Some basic terminology:

wlan0The name of the WiFi network interface in FPP. If you don't see wlan0, then your WiFi adapter is not being seen by the FPP.
eth0The name of the Wired (RJ45/CAT5) network interface in FPP.
GatewayThe address of the primary network router. This is the address of last resort, if the FPP does not know itself were to send any packets, it will send it here. This is normally your internet router.
DHCPDHCP wil dynamically assign an IP address to the interface. This is also normally a function of your internet router.
Enable RoutingThis option allows the FPP to pass packets between the two network interfaces. In almost all circumstances, you will want to enable this option.
OctetAn individual number in an IP address. Each IP address has four octets separated by dots. Normally, the first three octets identify the subnet and the last octet identifies individual hosts on the subnet (assuming you have a 255.255.255.0 subnet mask, which most will have).
BehindFor our purposes here, anything connected "behind" the FPP is connected to the eth0 (Wired) network interface.
Main RouterThis is the same as the Gateway (above), unless you have a dedicated show router, this will be your internet router.

I've also added a "Why" section in Reply #6 for those wanting a deeper understanding of why all this is necessary.

You should do the following:

This gets you the base configuration, additional configuration is required and depending on your circumstances one of the options in the next couple of reply's are need. The are listed in order of preference, with Option 1 being the preferred option.
Title: Re: Master + Remotes + WiFi How-To
Post by: ThreeSizes on January 13, 2016, 09:26:10 AM
Option 1:

To be able to talk to the controller behind the two Remote FPPs, you can tell the main subnet router about the necessary routes to them. The exact specifics on how this is done is different for each router, but you want to add routes to the routing table for:

192.168.101.0/24 via 192.168.1.101   (for Remote1 FPP)
192.168.102.0/24 via 192.168.1.102   (for Remote2 FPP)

Note: /24 is shorthand for netmask 255.255.255.0, routers will use one or both notations.

Router Support Table
YESMAYBENO
Verizon FiOS-G1100ASUS RT-AC66UAT&T U-verse Gateways
SonicWall TZ-215
DD-WRT


If you have any additions to the list please PM them to me and I'll add them to the list here.


Title: Re: Master + Remotes + WiFi How-To
Post by: ThreeSizes on January 13, 2016, 09:32:56 AM
Option 2:

In some cases, you cannot add routes to the main router's routing table. In this case, you can always add the routes manually to each computer you want to be able to talk to the controller behind the Remote FPPs.

The syntax is different depending on your operating system.

For Windows:

Code: [Select]
route -p add 192.168.101.0 mask 255.255.255.0 192.168.1.101
route -p add 192.168.102.0 mask 255.255.255.0 192.168.1.102

Note the -p option makes the route persistent across reboots. If you use this option and things change or you make a mistake, you'll need to backout the route(s) using:

Code: [Select]
route delete 192.168.101.0 mask 255.255.255.0 192.168.1.101
route delete 192.168.102.0 mask 255.255.255.0 192.168.1.101

and you can inspect the routing table using:

Code: [Select]
route print
For Mac:

Code: [Select]
sudo route add 192.168.101.0/24 192.168.1.101
sudo route add 192.168.102.0/24 192.168.1.102

There is no straight forward way to make these persistent across reboots, so I'll just suggest consulting the Google, revisit Option #1, or look at Option #3.

To remove routes:
Code: [Select]
sudo route delete 192.168.101.0/24 192.168.1.101
sudo route delete 192.168.102.0/24 192.168.1.102

And to check routes:
Code: [Select]
sudo netstat -nr
For Linux:

You're using Linux, you probably already know this, but:

Code: [Select]
ip route add 192.168.101.0/24 via 192.168.2.101
ip route add 192.168.102.0/24 via 192.168.2.102

Code: [Select]
ip route del 192.168.101.0/24 via 192.168.2.101
ip route del 192.168.102.0/24 via 192.168.2.102

Code: [Select]
ip route list
Note: You can also use the older "route" command with slightly different syntax, again you are using Linux so you probably already know this.

How you make them persistent across reboots will vary depending on the distribution, so consult the Google.


Title: Re: Master + Remotes + WiFi How-To
Post by: ThreeSizes on January 13, 2016, 09:35:28 AM
Option 3:

DISCLAIMER: This option is not officially supported by FPP, make sure you thoroughly test it. Please send me any feedback if you do use this option.

This is a new option I'm throwing on the table, best I can tell its not been really tried yet in the community so YMMV. Some times for whatever reason, you can't or just don't want to mess with routing tables. You can configure the Remote FPP to have a NAT'd second address than can be used to access the controller behind the Remote FPP.

Using NAT, when you want to access the controller, you would use the NAT address instead of the main address. So if I want to log into the controller behind Remote1 instead of using http://192.168.101.50, I would use http://192.168.1.111.

To set this up, you have to run a few commands on the Remote FPP using SSH and as the root user. You can access SSH using the Help|SSH option in FPP.

For Remote1:
Code: [Select]
sudo su -
iptables -t nat -A PREROUTING -i wlan0 -d 192.168.1.111 -j DNAT --to 192.168.101.50
iptables -t nat -A POSTROUTING -o wlan0 -s 192.168.101.50 -j SNAT --to 192.168.1.111
ip addr add 192.168.1.111/24 dev wlan0

For Remote2:
Code: [Select]
sudo su -
iptables -t nat -A PREROUTING -i wlan0 -d 192.168.1.112 -j DNAT --to 192.168.102.50
iptables -t nat -A POSTROUTING -o wlan0 -s 192.168.102.50 -j SNAT --to 192.168.1.112
ip addr add 192.168.1.112/24 dev wlan0

You can make this persistent across reboots of the FPP, by adding the last three lines of code to /etc/rc.local before the last line containing exit.

In my testing, I also found that in the case of FPP behind another FPP, on the FPP behind the FPP, the Help|SSH option will not work, after clicking the option you will need to manually change the link it opens from the actual IP to the NAT'd IP. For example: https://192.168.101.50:4200 becomes https://192.168.1.111:4200.


BONUS:

If you happen to have more than one device behind the FPP (you'd need a switch), you can scale this out by adding additional IP addresses to the FPP. Just take the three commands and rinse and repeat as needed on the FPP. For example to add a second device (192.168.101.51) to Remote1:

Code: [Select]
sudo su -
iptables -t nat -A PREROUTING -i wlan0 -d 192.168.1.121 -j DNAT --to 192.168.101.51
iptables -t nat -A POSTROUTING -o wlan0 -s 192.168.101.51 -j SNAT --to 192.168.1.121
ip addr add 192.168.1.121/24 dev wlan0

That gives you:

192.168.1.101 to the FPP
192.168.1.111 to Device 1
192.168.1.121 to Device 2

Title: Re: Master + Remotes + WiFi How-To
Post by: ThreeSizes on January 13, 2016, 10:13:35 AM
Option 4:

Wireless Access Point or Wireless Ethernet Bridge

If you are daring enough, you can look here for a preview: http://falconchristmas.com/forum/index.php/topic,4137.msg46090.html#msg46090 (http://falconchristmas.com/forum/index.php/topic,4137.msg46090.html#msg46090)

Title: Re: Master + Remotes + WiFi How-To
Post by: ThreeSizes on January 13, 2016, 10:13:45 AM
TROUBLESHOOTING OPTION 1/2

For this scenario we are troubleshooting the connection to the controller behind the Remote1 FPP. The commands here are for Windows, similar commands exist for Mac and Linux. The timing values (X ms) will vary but they should not be too much higher, the higher the values the higher the latency in the network which may pose other problems. Depending on the operating system and routers involved, there may either three hops (Router + FPP + Controller) or two hops (FPP + Controller).


From a PC on the Home network, trace route to the controller behind Remote1:

Code: [Select]
tracert 192.168.101.50

If the response to the trace route is:

Code: [Select]
Tracing route to 192.168.101.50 over a maximum of 30 hops:

  1     1 ms     1 ms     1 ms  [192.168.1.101]
  2     1 ms     1 ms     1 ms  [192.168.101.50]

or

Code: [Select]
Tracing route to 192.168.101.50 over a maximum of 30 hops:

  1     1 ms     1 ms     1 ms  [192.168.1.1]
  2     1 ms     1 ms     1 ms  [192.168.1.101]
  3     1 ms     1 ms     1 ms  [192.168.101.50]

There does not appear to be a routing problem, stop here  ;D.

If the response to the trace route is:

Code: [Select]
Tracing route to 192.168.101.50 over a maximum of 30 hops

  1     1 ms     1 ms     1 ms  [Some IP Address NOT the FPP or Router]
  2     *        *        *     Request timed out.

or

Code: [Select]
Tracing route to 192.168.101.50 over a maximum of 30 hops

  1     1 ms     1 ms     1 ms  [192.168.1.1]
  2     1 ms     1 ms     1 ms  [Some IP Address NOT the FPP]
  3     *        *        *     Request timed out.

Check the routing table in the main router (Option 1) or the PC itself (Option 2), your traffic is being routed to the wrong place  :o.

If the response to the trace route is:

Code: [Select]
Tracing route to 192.168.101.50 over a maximum of 30 hops

  1     *        *        *     Request timed out.
  2     *        *        *     Request timed out.
  3     *        *        *     Request timed out.

or

Code: [Select]
Tracing route to 192.168.101.50 over a maximum of 30 hops

  1     *        *        *     [192.168.1.1]
  2     *        *        *     Request timed out.
  3     *        *        *     Request timed out.
  4     *        *        *     Request timed out.

then ping the eth0 address of the FPP:

Code: [Select]
ping 192.168.101.1

If the response to the ping is:

Code: [Select]
Pinging 192.168.101.1 with 32 bytes of data:
Reply from 192.168.101.1: bytes=32 time=1ms TTL=64
Reply from 192.168.101.1: bytes=32 time=1ms TTL=64
Reply from 192.168.101.1: bytes=32 time=1ms TTL=64
Reply from 192.168.101.1: bytes=32 time=1ms TTL=64

Check the "Enable Routing" option in the FPP network setup  :-[.

Quote
Yes, it might seem weird that you can ping the eth0 interface even with Enable Routing turned off, but the short answer is Enable Routing is really enable forwarding under the hood which allows devices connected after the eth0 interface to be visible. The eth0 interface is always visible.

If the ping response is:

Code: [Select]
Pinging 192.168.101.1 with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.

Check the eth0 network configuration of the FPP, if that is correct, check the routing table in the main router (Option 1) or the PC itself (Option 2) :o.

If the response to the trace route is:

Code: [Select]
Tracing route to 192.168.101.1 over a maximum of 30 hops:

  1     1 ms     1 ms     1 ms  [192.168.1.101]
  2     *        *        *     Request timed out.

or

Code: [Select]
Tracing route to 192.168.101.1 over a maximum of 30 hops:

  1     1 ms     1 ms     1 ms  [192.168.1.1]
  2     1 ms     1 ms     1 ms  [192.168.1.101]
  3     *        *        *     Request timed out.

Check the network settings especially the gateway in the controller ???.

Title: Re: Master + Remotes + WiFi How-To
Post by: ThreeSizes on January 13, 2016, 10:13:56 AM
The Why's

One Gateway to Rule Them All

You can have as many gateways as you want, you just have to understand the behavior.  The "gateway" or more technically "default gateway" or "gateway of last resort", is the last place the device uses to send its traffic. If the device cannot otherwise determine where to send the traffic it will send the traffic to the "gateway".  In the routing tables, routes have priorities. So if you have effectively two identical and functional routes (which is what you would have with two default routes/gateways), the tie breaker goes to the priority, and then finally order.  In the FPP software, there is no mechanism for you to configure these priorities on the gateway settings, and by default, the gateway assigned to ETH0 is before the gateway assigned to WLAN0. So without the priority setting, if both ETH0 and WLAN0 gateways are configured, the gateway assigned to ETH0 will always win. In the bigger world of networking in general, normally you only have multiple gateways configured for network redundancy and fail over, where you have redundant internet connections, etc.

So the simple answer is, only configure one gateway and configure that gateway on the interface facing the your internet router or show router (if you have one).

Subnets, Subnet Masks, and the Magical Third Octet

The Subnet Mask or (sub)NET MASK tells the system what part of the IP address is the subnet address and which part is the host address.  Everything eventually gets into binary form, so and IP address 192.168.1.1 is really 11000000.10101000.00000001.00000001 (I added decimals for ease of reading).  The subnet mask of 255.255.255.0 converts to 11111111.11111111.11111111.00000000. Starting from left to right, every sequential position that is a 1 means that is the subnet address, the remaining positions which are 0 are the host address.

Code: [Select]
11000000.10101000.00000001.00000001  (IP Address)
11111111.11111111.11111111.00000000  (Subnet Mask / Netmask / Prefix)
--------.--------.--------.--------
11000000.10101000.00000001           (Subnet Address 192.168.1)
                           00000001  (Host Address .1)

Octet means "group of eight", which is why we refer to the individual numbers in an IP address as octets because in binary they are groups of eight (highlighted by me adding the decimal after every 8).

You will also find Subnet Mask / Netmask also referred to as Prefix and the notation is /X, X is simply the number sequential 1's left to right of the subnet mask. 255.255.255.0 would be prefix /24 since it has 24 1's.

In IP networks, each separate network (ETH0 and WLAN0 here) must have its only Subnet Address (the first 3 octets here) and on each separate network, each host must have its own unique Host Address (the fourth octet here). The size of the subnet mask as determines how many hosts you can have on the subnet, with 255.255.255.0 you can have 254 hosts (actually its 256, but 0 and 255 are reserved for broadcast use).

You'll probably only ever see 255.255.255.0 subnet masks (/24 prefix), so the short hand to all of this boils down to just make sure "the 3rd octet needs to be different".

And as a bonus, 192.168.X.X (255.255.255.0) is reserved (along with 10.X.X.X, and 172.16.X.X-172.31.X.X for private use, which is way you most commonly see 192.168. subnets in this kind of environment, not to say using the other private ranges are not invalid either).
Title: Re: Master + Remotes + WiFi How-To
Post by: pixelpuppy on January 13, 2016, 10:39:33 AM
Hey!  That's my network!  LOL  ;D

Thanks for the write-up and pictures.  This should help a lot of people   8)
This topology worked very well for me this past year and I think a bunch of other people too.
My gut feeling is this topology will be the direction more and more people will be moving to.
Title: Re: Master + Remotes + WiFi How-To
Post by: Duramadmax on January 13, 2016, 11:03:43 AM
Looks good so far  :). I have been working on this also. My IP addresses are different behind the FPP's but the design is the same using a separate subnet. The only thing that bothers me is the Router username/password being shown on the FPP network setup page. I am sure this will be on the to-do list for this year.

I, as with some others, will probably be incorporating an AP (access point) in the mix to allow the new ESP devices to do wireless back to the show network. I am sure it is not a big deal to setup. I am using a WRT54G using DD-WRT. I was planning to use this AP to "access" my show from within but I see depending on how the network is designed can prohibit you from accessing all your controllers vs the home network gaining access inward to your show via routing tables.

Great writeup!!
Title: Re: Master + Remotes + WiFi How-To
Post by: K-State Fan on January 14, 2016, 06:50:05 AM
Thanks for this information.  This will make it easier for me to understand.  Is it OK to ask questions in this thread?
Title: Re: Master + Remotes + WiFi How-To
Post by: ThreeSizes on January 14, 2016, 08:52:52 AM
If they are specifically about the information/topic here, I don't see why not especially if its clarification of what's presented. My plan is to update my posts above as things progress and fill out any additional information as needed. If its not or it starts to muddy up the thread, we can always move the discussion to a new thread.
 
Title: Re: Master + Remotes + WiFi How-To
Post by: K-State Fan on January 14, 2016, 09:50:03 AM
On the remote 1 and 2 you have them set up with a different third octet do they have to be.  I know they have to be different than wlan but instead of 192.168.101.1 and 192.168.102.1 could they be 192.168.101.1 and 192.168.101.2? Now that I think about it Is that so the route tables work correctly?
Title: Re: Master + Remotes + WiFi How-To
Post by: ThreeSizes on January 14, 2016, 09:55:31 AM
On the remote 1 and 2 you have them set up with a different third octet do they have to be.  I know they have to be different than wlan but instead of 192.168.101.1 and 192.168.102.1 could they be 192.168.101.1 and 192.168.101.2? Now that I think about it Is that so the route tables work correctly?

Yes you are correct, they must be different subnets if you are using any kind of routing (Option 1 & 2).  I updated the posts above to reflect this.

Title: Re: Master + Remotes + WiFi How-To
Post by: ThreeSizes on January 14, 2016, 05:26:04 PM
I've started a table up in Reply #1 for known routers that do and do not support routing. If you have any additions please PM them and I'll add them.

Title: Re: Master + Remotes + WiFi How-To
Post by: ThreeSizes on January 14, 2016, 07:11:24 PM
I've posted a troubleshooting guide into Reply #5 on this thread.
Title: Re: Master + Remotes + WiFi How-To
Post by: Duramadmax on January 14, 2016, 07:43:13 PM
I know pictures are worth a thousand words, but you might want to reference the lines between the fpp's and the router with a different designation than a line. I keep thinking a physical cable connection than a wifi/wireless connection. Maybe a wifi symbol could be incorporated.
Title: Re: Master + Remotes + WiFi How-To
Post by: ThreeSizes on January 14, 2016, 08:07:09 PM
I know pictures are worth a thousand words, but you might want to reference the lines between the fpp's and the router with a different designation than a line. I keep thinking a physical cable connection than a wifi/wireless connection. Maybe a wifi symbol could be incorporated.

Good suggestion. I've added them to my master graphic so they will so up next time I update the images for option 4 when its ready.
Title: Re: Master + Remotes + WiFi How-To
Post by: rcowan on January 16, 2016, 06:01:47 PM
So I've got an overall question for this topic. I haven't installed FPP yet so I can't look at the config screens to know what is possible. With setting up a mater/remote scenario, is the master just simply used for timing (i.e. getting all of the clocks in sync) and then each Pi is simply responsible for it's portion of the sequence not knowing about the other Pis on the network. Or, is there a setting in FPP that says, this one is the master and this one is the remote and so the master is actually sending commands to the remote?
Title: Re: Master + Remotes + WiFi How-To
Post by: ThreeSizes on January 16, 2016, 06:05:41 PM
There is a setting in FPP to designate the FPP as Master or Remote. During playback of the sequence, the master sends periodic timing signals to the remotes to keep them in sync with the master.
Title: Re: Master + Remotes + WiFi How-To
Post by: rcowan on January 16, 2016, 06:21:15 PM
So do you put your complete sequence then on each Pi? Since the remote Pi is only connected to a specific controller (or possibly multiple) then it won't matter that it's sending out data for universes that are on other controllers because the controller will just ignore those.
Title: Re: Master + Remotes + WiFi How-To
Post by: ThreeSizes on January 16, 2016, 06:36:39 PM
So do you put your complete sequence then on each Pi? Since the remote Pi is only connected to a specific controller (or possibly multiple) then it won't matter that it's sending out data for universes that are on other controllers because the controller will just ignore those.

Your questions might be better addressed in a new thread as this one is really dealing with the network side of doing Master & Remotes overs WiFi.
Title: Re: Master + Remotes + WiFi How-To
Post by: Aaron Maue on January 21, 2016, 12:11:21 AM
Having trouble "seeing" my F16V2 on the other side of my FPP which is running in standalone mode.

My home router is 192.168.0.1.  I have my FPP connected to it via wlan0 at static address 192.168.0.201.  I can control the FPP with no problem.

I have eth0 set up as static 10.10.10.50.  Connected to it via an ethernet cable is my F16v2 with a static address of 10.10.10.101.  In FPP, I have no gateway identified for eth0.

I have the "enable routing" checkbox checked.

I've tried both Option 1 and Option 2, as you have described, although I'm not 100% sure whether I got the route entered correctly into the router.  In the router, I created a new static route with a Destination IP of 10.10.10.0, mask of 255.255.255.0, and gateway IP of 192.168.0.201.  I've also done the following command in Windows:  "route add 10.10.10.0 mask 255.255.255.0 192.168.0.201".  I didn't use the -p switch, as I didn't want to make it permanent until I got things working.

I can ping 10.10.10.50 (eth0).  I can't ping 10.10.10.101. tracert 10.10.10.101 times out.

If it helps with trouble-shooting, I can also ping 10.10.10.50 when I deselect the "enable routing" checkbox.  Which seems weird.  But, I'm not a networking guy.

Finally, in your final trouble-shooting step you say "if the result of the tracert looks like this...", then check the network settings especially the gateway in the controller.  My controller gateway is 0.0.0.0.  What should it be?  192.168.0.201?

Any advice would be greatly appreciated.  I don't want to have to access all my controllers via a hard-wire connection from my laptop once they're all deployed into the yard.

What else can I do to figure out why it might not be working?

Thanks.
Title: Re: Master + Remotes + WiFi How-To
Post by: Aaron Maue on January 21, 2016, 12:58:56 AM
Wahoo!  Figured it out.  I clued into the comment about the gateway setting on the controller.  Changed it to the same IP address as the wlan0 address and all works.  For now, I have it working via the PC route command.  Gonna try and get it to work through the router next, but I have it working!!!!!

Thanks for putting this step-by-step out there for all of us.  Including the trouble-shooting.
Title: Re: Master + Remotes + WiFi How-To
Post by: ThreeSizes on January 21, 2016, 07:24:25 AM
Wahoo!  Figured it out.  I clued into the comment about the gateway setting on the controller.  Changed it to the same IP address as the wlan0 address and all works.  For now, I have it working via the PC route command.  Gonna try and get it to work through the router next, but I have it working!!!!!

Thanks for putting this step-by-step out there for all of us.  Including the trouble-shooting.

Aaron, glad to hear you met with success. I took your comments and tweaked the how-to a little to make it easier for the next person to come along. Please take a look at it again and let me know if the tweaks would have helped you the first time through.

Title: Re: Master + Remotes + WiFi How-To
Post by: Aaron Maue on January 21, 2016, 10:26:34 AM

Aaron, glad to hear you met with success. I took your comments and tweaked the how-to a little to make it easier for the next person to come along. Please take a look at it again and let me know if the tweaks would have helped you the first time through.

That would have helped. Thanks for the change. One thing though... I didn't set the controller gateway to the eth0 IP address. I set it to the wlan0 address. And it worked. Is that what I should expect, similar to the reason I could ping eth0 even when I had deselected the enable routing checkbox? Would you recommend changing it to the eth0 address, as it's more correct?
Title: Re: Master + Remotes + WiFi How-To
Post by: ThreeSizes on January 21, 2016, 11:48:03 AM

Aaron, glad to hear you met with success. I took your comments and tweaked the how-to a little to make it easier for the next person to come along. Please take a look at it again and let me know if the tweaks would have helped you the first time through.

That would have helped. Thanks for the change. One thing though... I didn't set the controller gateway to the eth0 IP address. I set it to the wlan0 address. And it worked. Is that what I should expect, similar to the reason I could ping eth0 even when I had deselected the enable routing checkbox? Would you recommend changing it to the eth0 address, as it's more correct?

It would be best to set the controller to eth0 address and not the wlan0 address, even though its working now it might not down the road and might not with other devices. The "standard" is the gateway should always be within the local/directly connected subnet and not outside of it. And yes, the reason it primarily worked is the same reason why you could ping eth0 without enabling routing.

If anybody would like I more technical explanation of why certain things work the way to do, I'd be more than glad to but I don't want to confuse things here on this thread. Just ask and I'll start a new thread.



 
Title: Re: Master + Remotes + WiFi How-To
Post by: MartinP on February 01, 2016, 11:03:00 AM
Hi.
A complete FPP novice here  ::) Be gentle!

I am playing with one Pi B v2/ FPP v1.7 and a Sandevice E682 controller at the moment.
I have followed advice here on setting up the E682 controller and FPP. (The E682 does not have a gateway entry)
FPP warns that DNS servers must be configured when both I/F IPs are static - which appears to conflict with instructions here.

Ping and Tracert return successfully, so that side of things appear OK.
I can "talk" to / configure FPP over WiFi from the laptop OK
I can "talk" to / configure the E682, which is on a different subnet from the laptop via WiFi through the Pi/FPP.
My main router does not allow manipulation of route tables, so the route is added to the laptop as suggested.
A *.fseq, produced with XLights, loaded and run on FPP does not control the pixels I have connected, yet I can run that same sequence from the laptop, and it will control those lights over WiFi via the Pi/FPP/E682 setup.

There doesn't appear to be any E1.31 data travelling between Pi/FPP and E682, judging by the eth0 activity LEDs when the sequence is running in FPP.

FPP is in standalone mode - is this correct?

I'm stumped at the moment  :o

TIA
MArtin
Title: Re: Master + Remotes + WiFi How-To
Post by: ThreeSizes on February 01, 2016, 12:02:46 PM
Hi.
A complete FPP novice here  ::) Be gentle!

I am playing with one Pi B v2/ FPP v1.7 and a Sandevice E682 controller at the moment.
I have followed advice here on setting up the E682 controller and FPP. (The E682 does not have a gateway entry)
FPP warns that DNS servers must be configured when both I/F IPs are static - which appears to conflict with instructions here.

Ping and Tracert return successfully, so that side of things appear OK.
I can "talk" to / configure FPP over WiFi from the laptop OK
I can "talk" to / configure the E682, which is on a different subnet from the laptop via WiFi through the Pi/FPP.
My main router does not allow manipulation of route tables, so the route is added to the laptop as suggested.
A *.fseq, produced with XLights, loaded and run on FPP does not control the pixels I have connected, yet I can run that same sequence from the laptop, and it will control those lights over WiFi via the Pi/FPP/E682 setup.

There doesn't appear to be any E1.31 data travelling between Pi/FPP and E682, judging by the eth0 activity LEDs when the sequence is running in FPP.

FPP is in standalone mode - is this correct?

I'm stumped at the moment  :o

TIA
MArtin

I'll clarify the DNS server issue in the instructions.

Have you configured the E1.31 outputs on the FPP? That one tripped me up the first time around.

Title: Re: Master + Remotes + WiFi How-To
Post by: MartinP on February 01, 2016, 12:51:53 PM
Oh woe is me  :-[

Silly, silly old fart that I am - I had configured the E1.31 outputs previously when testing the E682 with an IP address within my home subnet, and had forgotten to change that! All working fine now  :D
It is always the simple things that seem to trip me up - I must overthink things  ::)

Thanks so much for the prompt reply, and sorry for wasting time.

Martin
Title: Re: Master + Remotes + WiFi How-To
Post by: pixelpuppy on February 02, 2016, 08:58:26 AM
I found typo in the setup for Option 3...

Option 3:
...
So if I want to log into the controller behind Remote1 instead of using http://192.168.101.50, I would use http://192.168.2.111.
...
Should be 192.168.1.111 to match the rest of the example.
Title: Re: Master + Remotes + WiFi How-To
Post by: ThreeSizes on February 02, 2016, 11:11:02 AM
I found typo in the setup for Option 3...

Option 3:
...
So if I want to log into the controller behind Remote1 instead of using http://192.168.101.50, I would use http://192.168.2.111.
...
Should be 192.168.1.111 to match the rest of the example.

Thanks for the catch. It's been fixed.
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: ccsuhr on February 14, 2016, 02:30:08 PM
Having a weird issue that the Static address I try to set for wlan0 is not staying when I update interface and is not there when I restart network on on reboot.

I have verified that the usb device is showing in lsusb
...
ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]

lsmod
...
8192cu                528485  0
...

iwconfig
wlan0     unassociated  Nickname:"<WIFI@REALTEK>"
          Mode:Auto  Frequency=2.412 GHz  Access Point: Not-Associated
          Sensitivity:0/0
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

lo        no wireless extensions.

eth0      no wireless extensions.


nano /etc/network/interface

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
  address 10.0.0.10
  netmask 255.255.255.0
  network 10.0.0.0

iface eth0:0 inet static
  address 192.168.0.10
  netmask 255.255.255.0
  network 192.168.0.0

Wireless router is running WPA2/WPA Mixed Personal
and I'm using the password where it reference a Pre Shared  Key (PSK)

Any Ideas what I'm missing or need to adjust 

Thanks in Advance

Charles
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: ThreeSizes on February 14, 2016, 05:25:45 PM
Having a weird issue that the Static address I try to set for wlan0 is not staying when I update interface and is not there when I restart network on on reboot.

Any Ideas what I'm missing or need to adjust 

Thanks in Advance

Charles


Have you configured the FPP's External Storage Device? If that is not configured, the FPP will forget its network settings across reboots.

Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: ccsuhr on February 14, 2016, 05:41:50 PM
ETH0 is staying the WLAN0 is where the issue is one note I found a issue with the password I use for wireless It contained an & sign and this was causing it to blank the inputs.  what I did was did the ip address then update network that stuck then tired the SSID and PSK that still blanked.  Tired a plain word as password and that stayed.  Change PSK on router and still no luck. 
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: ThreeSizes on February 14, 2016, 05:52:38 PM
ETH0 is staying the WLAN0 is where the issue is one note I found a issue with the password I use for wireless It contained an & sign and this was causing it to blank the inputs.  what I did was did the ip address then update network that stuck then tired the SSID and PSK that still blanked.  Tired a plain word as password and that stayed.  Change PSK on router and still no luck.

What are the contents of /home/fpp/media/config/interface.wlan0 and /home/fpp/media/config/interface.eth0?  The /etc/network/interfaces file is generated at each boot time based on the contents of these two files.



Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: ccsuhr on February 14, 2016, 06:03:23 PM
INTERFACE="wlan0"
PROTO="static"
ADDRESS="192.168.1.244"
NETMASK="255.255.255.0"
GATEWAY="192.168.1.1"
SSID='BlueDaemon'
PSK='*******'

*******  password redacted

INTERFACE="eth0"
PROTO="static"
ADDRESS="10.0.0.10"
NETMASK="255.255.255.0"
GATEWAY=""

Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: ThreeSizes on February 14, 2016, 06:09:20 PM
INTERFACE="wlan0"
PROTO="static"
ADDRESS="192.168.1.244"
NETMASK="255.255.255.0"
GATEWAY="192.168.1.1"
SSID='BlueDaemon'
PSK='*******'

*******  password redacted

INTERFACE="eth0"
PROTO="static"
ADDRESS="10.0.0.10"
NETMASK="255.255.255.0"
GATEWAY=""

Replied in the other thread:  http://falconchristmas.com/forum/index.php/topic,4458.0.html (http://falconchristmas.com/forum/index.php/topic,4458.0.html)
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: ThreeSizes on February 14, 2016, 08:35:25 PM
As a follow-up to some of my other posts, I started a "Why" section in this thread under Reply #6.
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: tmarshall on March 22, 2016, 04:02:23 PM
Thank you very much for providing this guide. It is very organized and concise and is a great help.

Nonetheless, I am having difficulties. Hopefully someone can steer me in the right direction.  I am trying to implement Option 1. I am starting with a very simplified network consisting of an Asus RT-AC68U router, a Raspberry Pi with a WiFi Adapter, and a Pixlite Controller.

I cannot access the Pixlite controller from the network. Hopefully someone can show me what I am doing wrong.

Here is my simplified network diagram:
(https://dl.dropboxusercontent.com/u/75341078/FalconChristmas/NetworkSetup/NetworkDiagram.png)
I have set the Pixlite to a static IP address of 192.168.101.50 with a subnetmask of 255.255.255.0. It's ethernet port is physically connected to the ethernet port on the Pi.

I can access the Pi on wlan0 just fine. My wlan0 configuration via the FPP interface is as follows:
(https://dl.dropboxusercontent.com/u/75341078/FalconChristmas/NetworkSetup/wlan0.png)

My eth0 configuration is as follows:
(https://dl.dropboxusercontent.com/u/75341078/FalconChristmas/NetworkSetup/eth0.png)

The static routes are setup in my router as follows:
(https://dl.dropboxusercontent.com/u/75341078/FalconChristmas/NetworkSetup/Routes.png)
Any ideas?
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: ThreeSizes on March 22, 2016, 04:18:19 PM
Remove the gateway on the FPP's eth0 and then also make sure the Pixlite has a gateway configured of 192.168.101.1.


Sent from my iPhone using Tapatalk
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: tmarshall on March 22, 2016, 05:33:00 PM
Remove the gateway on the FPP's eth0 and then also make sure the Pixlite has a gateway configured of 192.168.101.1.
I removed the gateway from the FPP's eth0. There is no option in the PixLite's interface to specify a gateway. The Pixlite does not have a web interface. Access to the controller settings is via their Advatek Assistant. I cannot access the PixLite via their Advatek Assistant. I can however, ping it and get a reply. I don't quite understand how I can get a reply if I cannot assign a gateway.
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: pixelpuppy on March 22, 2016, 06:02:58 PM
I can however, ping it and get a reply. I don't quite understand how I can get a reply if I cannot assign a gateway.
Because a "reply' knows where the original request came from.  Gateway is needed when a device inititiates the conversation.
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: tmarshall on March 22, 2016, 06:27:52 PM
I got it working. It was probably working as soon as I took out the gateway from eth0. I still cannot access the controller setup UI using the Advatek Assistant, but I can send e1.31 data to it.


I will just have to connect directly up to the controller and temporarily change my router's subnet mask to 255.255.0.0 to make changes to the controller setup then change everything back.


Thanks guys!
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: ThreeSizes on March 22, 2016, 06:38:10 PM
Because a "reply' knows where the original request came from.  Gateway is needed when a device inititiates the conversation.

A reply only knows the original source of the packet not the route the packet needs to take. Replies need a route just like any other packet. It is very common for the route to a host be different than a route from a host and for the route to even change between packets. Everybody only knows the next hop in the route not the full route.

In this case because the Pixlite is directly connected to the FPP, the FPP will see any packet put on the wire by the Pixlite and it will know what to do with the packet. This is very similar behavior to ProxyARP where the FPP advertises itself as the destination for anybody asking for a destination next hop via ARP. If there was a switch in-between the Pixlite and the FPP you would need to specifically turn on ProxyARP in the FPP to get the same behavior (echo 1 > /proc/sys/net/ipv4/conf/eth0/proxy_arp) since the switch would filter the traffic the FPP would see.

These statements were incorrect. See PixelPuppy's comments in the next couple of messages.
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: tmarshall on March 22, 2016, 06:55:28 PM
Because a "reply' knows where the original request came from.  Gateway is needed when a device inititiates the conversation.


A reply only knows the original source of the packet not the route the packet needs to take. Replies need a route just like any other packet. It is very common for the route to a host be different than a route from a host and for the route to even change between packets. Everybody only knows the next hop in the route not the full route.


In this case because the Pixlite is directly connected to the FPP, the FPP will see any packet put on the wire by the Pixlite and it will know what to do with the packet. This is very similar behavior to ProxyARP where the FPP advertises itself as the destination for anybody asking for a destination next hop via ARP. If there was a switch in-between the Pixlite and the FPP you would need to specifically turn on ProxyARP in the FPP to get the same behavior (echo 1 > /proc/sys/net/ipv4/conf/eth0/proxy_arp) since the switch would filter the traffic the FPP would see.


Good to know because, I may well want to control more than one PixeLite from the same Pi and have to introduce a switch.
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: ThreeSizes on March 22, 2016, 06:58:50 PM
Because a "reply' knows where the original request came from.  Gateway is needed when a device inititiates the conversation.


A reply only knows the original source of the packet not the route the packet needs to take. Replies need a route just like any other packet. It is very common for the route to a host be different than a route from a host and for the route to even change between packets. Everybody only knows the next hop in the route not the full route.


In this case because the Pixlite is directly connected to the FPP, the FPP will see any packet put on the wire by the Pixlite and it will know what to do with the packet. This is very similar behavior to ProxyARP where the FPP advertises itself as the destination for anybody asking for a destination next hop via ARP. If there was a switch in-between the Pixlite and the FPP you would need to specifically turn on ProxyARP in the FPP to get the same behavior (echo 1 > /proc/sys/net/ipv4/conf/eth0/proxy_arp) since the switch would filter the traffic the FPP would see.


Good to know because, I may well want to control more than one PixeLite from the same Pi and have to introduce a switch.

ProxyARP shouldn't been needed, but if it is I'm leaving this here as reference only:

If you do give it try let us know what happens.  To make the ProxyArp persistent across reboots you can add the following line to the bottom of /etc/sysctl.conf:

Code: [Select]
net.ipv4.conf.eth0.proxy_arp = 1
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: pixelpuppy on March 22, 2016, 08:16:39 PM
Because a "reply' knows where the original request came from.  Gateway is needed when a device inititiates the conversation.
A reply only knows the original source of the packet not the route the packet needs to take. Replies need a route just like any other packet. It is very common for the route to a host be different than a route from a host and for the route to even change between packets. Everybody only knows the next hop in the route not the full route.

In this case because the Pixlite is directly connected to the FPP, the FPP will see any packet put on the wire by the Pixlite and it will know what to do with the packet. This is very similar behavior to ProxyARP where the FPP advertises itself as the destination for anybody asking for a destination next hop via ARP. If there was a switch in-between the Pixlite and the FPP you would need to specifically turn on ProxyARP in the FPP to get the same behavior (echo 1 > /proc/sys/net/ipv4/conf/eth0/proxy_arp) since the switch would filter the traffic the FPP would see.

That's not what's happening.  The pixlite being directly connected to the FPP has nothing to do with it.  The Pixlite works the same way in other environments that don't have directly connected FPP and there is no proxy ARP enabled.  And it works the same way if there is a switch in the middle.  And it will still work if the ping came from off the LAN through a gateway.


The reply knows the requestor's  IP address AND it knows the MAC address of the packet that contained the request.   IF the request came from on the lan then the MAC is the address of the originator and that's where the reply gets sent  IF the request originated off the LAN then the MAC is the address of the gateway and gets sent back to the gateway for routing off the lan.  Therefore, the reply DOES know where to send the answer, regardless of whether the originator is on the same lan or not.   No proxy needed.


There are LOTS of IP enabled devices in the world that have no gateway configuration setting. If I remember, the SANDevices controllers are this way as well (no gateway setting). These are devices that do not initiatate an IP connection, they only answer or reply to incoming IP requests.  The simple IP stack sends the reply back to the MAC address of the packet that contained the request.  That's all it needs. 


The fact that the Pixlite being directly connected to the FPP is NOT the reason it answers.  This is NOT proxy ARP.   And it does not matter if they are direct connected or if there is a switch between them.  It still works because the reply goes back to the MAC address of the packet that contained the originating request.  This works the same if they are direct connected or through a switch.
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: ThreeSizes on March 22, 2016, 08:30:33 PM
Because a "reply' knows where the original request came from.  Gateway is needed when a device inititiates the conversation.
A reply only knows the original source of the packet not the route the packet needs to take. Replies need a route just like any other packet. It is very common for the route to a host be different than a route from a host and for the route to even change between packets. Everybody only knows the next hop in the route not the full route.

In this case because the Pixlite is directly connected to the FPP, the FPP will see any packet put on the wire by the Pixlite and it will know what to do with the packet. This is very similar behavior to ProxyARP where the FPP advertises itself as the destination for anybody asking for a destination next hop via ARP. If there was a switch in-between the Pixlite and the FPP you would need to specifically turn on ProxyARP in the FPP to get the same behavior (echo 1 > /proc/sys/net/ipv4/conf/eth0/proxy_arp) since the switch would filter the traffic the FPP would see.

That's not what's happening.  The pixlite being directly connected to the FPP has nothing to do with it.  The Pixlite works the same way in other environments that don't have directly connected FPP and there is no proxy ARP enabled.  And it works the same way if there is a switch in the middle. 


The reply knows the requestor's  IP address AND it knows the MAC address of the packet that contained the request.   IF the request came from on the lan then the MAC is the address of the originator and that's where the reply gets sent  IF the request originated off the LAN then the MAC is the address of the gateway and gets sent back to the gateway for routing off the lan.  Therefore, the reply DOES know where to send the answer, regardless of whether the originator is on the same lan or not.   No proxy needed.


There are LOTS of IP enabled devices in the world that have no gateway configuration setting. If I remember, the SANDevices controllers are this way as well (no gateway setting). These are devices that do not initiatate an IP connection, they only answer or reply to incoming IP requests.  The simple IP stack sends the reply back to the MAC address of the packet that contained the request.  That's all it needs. 


The fact that the Pixlite being directly connected to the FPP is NOT the reason it answers.  This is NOT proxy ARP.   And it does not matter if they are direct connected or if there is a switch between them.  It still works because the reply goes back to the MAC address of the packet that contained the originating request.  This works the same if they are direct connected or through a switch.


Agreed. It's been a long time since I dealt with the simpler IP stacks, thanks for refresher.





Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: ThreeSizes on March 23, 2016, 09:35:40 AM
Agreed. It's been a long time since I dealt with the simpler IP stacks, thanks for refresher.


I cleaned up a few of the previous posts to reflect the corrected information provided by PixelPuppy to avoid future confusion. I've also added a couple of additional words to the first post of the thread as well.



Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: abolton on May 20, 2016, 12:18:38 AM
I've been having some problems talking to the controller from my PC as well using Option 1. Wlan is set to 192.168.10.20. eth0 is 192.168.20.10 which I can ping but I cannot ping the controller 192.168.20.11 with a gateway of 192.168.20.10, SN /24 for all. I setup a route; host IP 191.168.20.0 ---> GW 192.168.10.20. Still cannot ping. When I set an additional route for 192.168.20.0 ----> Gateway 192.168.10.1 (Router Address), I can ping. I know it was stated that if you set the controllers GW to the router address it may break down the line but I'm not clear if I'm essentially doing the same thing just from the other direction or if I needed this additional route to be able to complete all the hops needed? Anyone have any ideas on this setup?


Well found one mistake - still having issues connecting to the interface though.
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: ThreeSizes on May 20, 2016, 04:59:34 PM
I've been having some problems talking to the controller from my PC as well using Option 1. Wlan is set to 192.168.10.20. eth0 is 192.168.20.10 which I can ping but I cannot ping the controller 192.168.20.11 with a gateway of 192.168.20.10, SN /24 for all. I setup a route; host IP 191.168.20.0 ---> GW 192.168.10.20. Still cannot ping. When I set an additional route for 192.168.20.0 ----> Gateway 192.168.10.1 (Router Address), I can ping. I know it was stated that if you set the controllers GW to the router address it may break down the line but I'm not clear if I'm essentially doing the same thing just from the other direction or if I needed this additional route to be able to complete all the hops needed? Anyone have any ideas on this setup?


Well found one mistake - still having issues connecting to the interface though.


If you want to recap your issue after correcting the mistake, I'd be glad to help.



Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: abolton on May 20, 2016, 10:50:22 PM
Thanks ThreeSizes and thanks to everyone else - Sadly I must admit I completely forgot to hook the patch cable back up to the Ethernet port after testing wireless. After correcting that I went back through and changed everything back to match up to the process and now I'm able to connect to the interface and FPP is driving the controller.


Thanks Again!
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: jholmes on June 09, 2016, 01:14:04 AM
Continuing the latest question regarding a PixLite controller and the Advatek Assistant.
Why do you think the AA cannot see the device when it is behind an FPP?


Here is a screen-shot of my AA window. You can see the IP is currently in the same subnet as my "adapter" (aka my wifi) but that is because I connected it directly to the router, bypassing the pi. When I change the IP and connect it behind the FPP, the Advatek software can no longer see it.


Funny enough, if I do connect the PixLite directly to the router and the IP address is in the wrong subnet, Advatek will STILL see the device, warn me of the IP issue, and prompt me to fix it.


Your thoughts are GREATLY appreciated.
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: ThreeSizes on June 09, 2016, 07:05:22 AM
Continuing the latest question regarding a PixLite controller and the Advatek Assistant.
Why do you think the AA cannot see the device when it is behind an FPP?


Here is a screen-shot of my AA window. You can see the IP is currently in the same subnet as my "adapter" (aka my wifi) but that is because I connected it directly to the router, bypassing the pi. When I change the IP and connect it behind the FPP, the Advatek software can no longer see it.


Funny enough, if I do connect the PixLite directly to the router and the IP address is in the wrong subnet, Advatek will STILL see the device, warn me of the IP issue, and prompt me to fix it.


Your thoughts are GREATLY appreciated.


I'm not familiar with the PixLite/AA and your screenshot didn't make it to the post. The first thing that comes to my mind given your last statement is the AA is doing some sort of local network discovery/communication at the ethernet layer (layer 2). Anything at the layer 2 is not routable and would not transit the FPP. This is way it can see the PixLite and complain about its IP address being incorrect.







Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: uzelessknowledge on August 08, 2016, 08:53:17 PM
Can you tell me if this will work?

Home network 192.168.2.x
Show network 192.168.3.x

FPP WLAN 192.268.2.151
FPP eth0 192.168.3.151
F16v2 192.168.3.161

The FPP and f16v2 are connected to the show router. There will eventually be 2 more f16v2 connected to the router.

Can I access the f16v2 from my home network?
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: ThreeSizes on August 08, 2016, 09:37:48 PM
Can you tell me if this will work?

Home network 192.168.2.x
Show network 192.168.3.x

FPP WLAN 192.268.2.151
FPP eth0 192.168.3.151
F16v2 192.168.3.161

The FPP and f16v2 are connected to the show router. There will eventually be 2 more f16v2 connected to the router.

Can I access the f16v2 from my home network?


In theory yes, but it depends on whether or not you can get the routing properly setup on the home router and whether you can disable NAT on the show router. I was just emailed back and forth with jnealand on a similar setup. We ran into a problem with the home router not properly handling the routes and the show router not able to disable NAT.


We can get into specifics, but this is what you want to try to do:


On the home router, setup routes 192.168.2.0 255.255.255.0 via 192.168.1.X and 192.168.3.0 255.255.255.0 via 192.168.1.X. (where 192.168.1.X is the IP address of the show router)
On the show router, setup route 192.168.3.0 255.255.255.0 via 192.168.2.151 and disable NAT.
On the FPP 192.168.2.151 make sure Enable Forwarding is checked in Network Setup and ETH0 has no gateway and WLAN0 has gateway of 192.168.2.1.
On the F16V2 make sure 192.168.3.151 is configured for the gateway.





Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: uzelessknowledge on August 08, 2016, 09:45:12 PM
Can you tell me if this will work?

Home network 192.168.2.x
Show network 192.168.3.x

FPP WLAN 192.268.2.151
FPP eth0 192.168.3.151
F16v2 192.168.3.161

The FPP and f16v2 are connected to the show router. There will eventually be 2 more f16v2 connected to the router.

Can I access the f16v2 from my home network?


In theory yes, but it depends on whether or not you can get the routing properly setup on the home router and whether you can disable NAT on the show router. I was just emailed back and forth with jnealand on a similar setup. We ran into a problem with the home router not properly handling the routes and the show router not able to disable NAT.


We can get into specifics, but this is what you want to try to do:


On the home router, setup routes 192.168.2.0 255.255.255.0 via 192.168.1.X and 192.168.3.0 255.255.255.0 via 192.168.1.X. (where 192.168.1.X is the IP address of the show router)
On the show router, setup route 192.168.3.0 255.255.255.0 via 192.168.2.151 and disable NAT.
On the FPP 192.168.2.151 make sure Enable Forwarding is checked in Network Setup and ETH0 has no gateway and WLAN0 has gateway of 192.168.2.1.
On the F16V2 make sure 192.168.3.151 is configured for the gateway.
Headed to bed and saw this.
Show router is 192.168.3.140. Didn't mention that. Where is the 192.168.1.x coming from?

Also, home router is an AirPort Extreme and doesn't allow static routes :(
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: ThreeSizes on August 08, 2016, 10:25:11 PM
Can you tell me if this will work?

Home network 192.168.2.x
Show network 192.168.3.x

FPP WLAN 192.268.2.151
FPP eth0 192.168.3.151
F16v2 192.168.3.161

The FPP and f16v2 are connected to the show router. There will eventually be 2 more f16v2 connected to the router.

Can I access the f16v2 from my home network?


In theory yes, but it depends on whether or not you can get the routing properly setup on the home router and whether you can disable NAT on the show router. I was just emailed back and forth with jnealand on a similar setup. We ran into a problem with the home router not properly handling the routes and the show router not able to disable NAT.


We can get into specifics, but this is what you want to try to do:


On the home router, setup routes 192.168.2.0 255.255.255.0 via 192.168.1.X and 192.168.3.0 255.255.255.0 via 192.168.1.X. (where 192.168.1.X is the IP address of the show router)
On the show router, setup route 192.168.3.0 255.255.255.0 via 192.168.2.151 and disable NAT.
On the FPP 192.168.2.151 make sure Enable Forwarding is checked in Network Setup and ETH0 has no gateway and WLAN0 has gateway of 192.168.2.1.
On the F16V2 make sure 192.168.3.151 is configured for the gateway.
Headed to bed and saw this.
Show router is 192.168.3.140. Didn't mention that. Where is the 192.168.1.x coming from?

Also, home router is an AirPort Extreme and doesn't allow static routes :(


Sorry I was headed to bed myself and should have kept going and waited for morning.  I seemed to have imagined an entirely different network for you.


You have two options: if you can disable NAT on the show router you can route through it to get to the F16V2, otherwise, you can also route through the FPP.


Option #1: Disable NAT on the show router, configure the F16V2 (or anything else you want to access) with a gateway of 192.168.3.140, and add a route to the computer you want to access the F16V2. The route you want is 192.168.3.0 255.255.255.0 via 192.168.2.X (whatever the WAN address of the show router is).


Option #2: Enable Forwarding on the FPP, configure the F16V2 (or anything else you want to access) with a gateway of 192.168.3.151, and add a route to the computer you want to access the F16V2. The route you want for this option is 192.168.3.0 255.255.255.0 via 192.168.2.151.


The command to the add the route to the computer varies depending on O/S and you can find them back on like the third port on this thread.



Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: uzelessknowledge on August 09, 2016, 06:33:02 AM
Sorry I was headed to bed myself and should have kept going and waited for morning.  I seemed to have imagined an entirely different network for you.


You have two options: if you can disable NAT on the show router you can route through it to get to the F16V2, otherwise, you can also route through the FPP.


Option #1: Disable NAT on the show router, configure the F16V2 (or anything else you want to access) with a gateway of 192.168.3.140, and add a route to the computer you want to access the F16V2. The route you want is 192.168.3.0 255.255.255.0 via 192.168.2.X (whatever the WAN address of the show router is).


Option #2: Enable Forwarding on the FPP, configure the F16V2 (or anything else you want to access) with a gateway of 192.168.3.151, and add a route to the computer you want to access the F16V2. The route you want for this option is 192.168.3.0 255.255.255.0 via 192.168.2.151.


The command to the add the route to the computer varies depending on O/S and you can find them back on like the third port on this thread.

Option 1: Not sure this will work. Show router is stand alone and not connected to home network. Show router is outside with no Ethernet back into the house. I didn't want to have to feed one and I didn't want someone to be able to come plug in from outside and be able to get to my network. I know I'm paranoid.

Option 2: Sounds like this will work. I will only be able to use a computer though to get to the F16v2 and can't use iPhone, right?

Hey, thanks for the help. Good to have someone with your knowledge available.
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: ThreeSizes on August 09, 2016, 08:03:41 AM

Option 2: Sounds like this will work. I will only be able to use a computer though to get to the F16v2 and can't use iPhone, right?

Hey, thanks for the help. Good to have someone with your knowledge available.


Yes, only things connected to the home network that can setup routes. For the iPhone you could always just temporally connect it to the show network WiFi if you need to get to it from the iPhone.



Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: uzelessknowledge on August 09, 2016, 08:59:20 AM

Option 2: Sounds like this will work. I will only be able to use a computer though to get to the F16v2 and can't use iPhone, right?

Hey, thanks for the help. Good to have someone with your knowledge available.


Yes, only things connected to the home network that can setup routes. For the iPhone you could always just temporally connect it to the show network WiFi if you need to get to it from the iPhone.

Thanks. That's what I was doing. I'll have to play around and see.
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: uzelessknowledge on August 10, 2016, 04:41:59 PM
Option #1: Disable NAT on the show router, configure the F16V2 (or anything else you want to access) with a gateway of 192.168.3.140, and add a route to the computer you want to access the F16V2. The route you want is 192.168.3.0 255.255.255.0 via 192.168.2.X (whatever the WAN address of the show router is).


Option #2: Enable Forwarding on the FPP, configure the F16V2 (or anything else you want to access) with a gateway of 192.168.3.151, and add a route to the computer you want to access the F16V2. The route you want for this option is 192.168.3.0 255.255.255.0 via 192.168.2.151.


The command to the add the route to the computer varies depending on O/S and you can find them back on like the third port on this thread.

Option 2 worked perfectly. THANKS!

Am I correct for option 1 to work that the show router would need to be connected to to the home network (WAN to LAN)?
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: ThreeSizes on August 10, 2016, 04:47:37 PM
Option #1: Disable NAT on the show router, configure the F16V2 (or anything else you want to access) with a gateway of 192.168.3.140, and add a route to the computer you want to access the F16V2. The route you want is 192.168.3.0 255.255.255.0 via 192.168.2.X (whatever the WAN address of the show router is).


Option #2: Enable Forwarding on the FPP, configure the F16V2 (or anything else you want to access) with a gateway of 192.168.3.151, and add a route to the computer you want to access the F16V2. The route you want for this option is 192.168.3.0 255.255.255.0 via 192.168.2.151.


The command to the add the route to the computer varies depending on O/S and you can find them back on like the third port on this thread.

Option 2 worked perfectly. THANKS!

Am I correct for option 1 to work that the show router would need to be connected to to the home network (WAN to LAN)?


Yes there has to be some sort of connection between the two. Most likely by connecting a Cat5 from the WAN port on the Show router to a port on the Home router.



Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: danj on August 23, 2016, 09:14:22 PM
Finally getting around to setting up my pi3's.   I have zero networking knowledge, so to copy an earlier post here at Falcon, "please be gentle"....  I have not been able to get wlan0 working and I <think> I have done the steps provided in threesizes' really great sticky post(s).  Since I am not network-knowledgable, not sure where to go next!   Thanks very much in advance.

I setup my first pi3 setup as the master.   On that pi3, eth0 is pingable at 192.168.0.110 (subnet 255.255.255.0) with a hardwire Ethernet cable hooked up from my laptop to my pi3 and my laptop at static ipv4 address--192.168.0.100 with subnet mask 255.255.255.0, default gateway not specified, DHCP not enabled.   I am on a shared apartment complex wireless system right now; it is setup as follows: ipv4--10.219.213.26 subnet mask--255.0.0.0 default gateway 10.128.128.128--I am able to ping this ip address.  I setup my wlan0 with ipv4--10.219.213.27 subnet mask 255.0.0.0 (I also tried 255.255.255.0 but this didn't work either) default gateway and DNS server both set to 10.128.128.128.   I tried pinging 10.219.213.27 and got no response.  When I input the network info into the pi3 UI, I am certain that I updated and restarted the interface.

With the pi3 hooked up to a monitor, I ran the "iwconfig" command and got the following:
wlan0 IEEE 802.11bgn ESSID: "TheInez"  ("TheInez" is the name of the apt wireless and I input the password, too.....)   <other items look reasonable>
lo        no wireless extensions
eth0    no wireless extensions
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: ThreeSizes on August 24, 2016, 04:18:57 PM
Finally getting around to setting up my pi3's.   I have zero networking knowledge, so to copy an earlier post here at Falcon, "please be gentle"....  I have not been able to get wlan0 working and I <think> I have done the steps provided in threesizes' really great sticky post(s).  Since I am not network-knowledgable, not sure where to go next!   Thanks very much in advance.

I setup my first pi3 setup as the master.   On that pi3, eth0 is pingable at 192.168.0.110 (subnet 255.255.255.0) with a hardwire Ethernet cable hooked up from my laptop to my pi3 and my laptop at static ipv4 address--192.168.0.100 with subnet mask 255.255.255.0, default gateway not specified, DHCP not enabled.   I am on a shared apartment complex wireless system right now; it is setup as follows: ipv4--10.219.213.26 subnet mask--255.0.0.0 default gateway 10.128.128.128--I am able to ping this ip address.  I setup my wlan0 with ipv4--10.219.213.27 subnet mask 255.0.0.0 (I also tried 255.255.255.0 but this didn't work either) default gateway and DNS server both set to 10.128.128.128.   I tried pinging 10.219.213.27 and got no response.  When I input the network info into the pi3 UI, I am certain that I updated and restarted the interface.

With the pi3 hooked up to a monitor, I ran the "iwconfig" command and got the following:
wlan0 IEEE 802.11bgn ESSID: "TheInez"  ("TheInez" is the name of the apt wireless and I input the password, too.....)   <other items look reasonable>
lo        no wireless extensions
eth0    no wireless extensions

You don't say what is configured for 10.219.213.26? The laptop? And what is configured for 10.219.213.27? You said WLAN0 so I assume that's the FPP.


The first thought I have is that it is possible to configure wireless network (station isolation) such that one thing connected to the WiFi cannot see another thing conneced to the WiFi, you can only see out the router to the Internet. This may be what's happening but that a guess at this point, especially if both thing can ping 10.128.128.128 but not each other.



Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: danj on August 24, 2016, 05:52:47 PM
sorry.  the apt wireless was setup at the .26 IP address.   I manually set the pi3 to the .27 IP address.  I figured since I could ping the wireless router but not the pi3 wlan0, that I setup something wrong in my subnet, DNS, etc...  assignment for the pi3 wlan0.  I had manually set my laptop to 192.168.0.xxx so it & the pi3's eth0 could talk via the hard line Ethernet cable.  I am going to read your "how to" once more, in detail, to see what I am missing.   I feel quite sure I missed some really simple little item...   thanks for the reply.
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: ThreeSizes on August 24, 2016, 07:08:03 PM
sorry.  the apt wireless was setup at the .26 IP address.   I manually set the pi3 to the .27 IP address.  I figured since I could ping the wireless router but not the pi3 wlan0, that I setup something wrong in my subnet, DNS, etc...  assignment for the pi3 wlan0.  I had manually set my laptop to 192.168.0.xxx so it & the pi3's eth0 could talk via the hard line Ethernet cable.  I am going to read your "how to" once more, in detail, to see what I am missing.   I feel quite sure I missed some really simple little item...   thanks for the reply.


Please post screen shots of the ETH0 and WLAN0 configuration pages in the FPP GUI. So the FPP was originally set for .26 and you moved it to .27? From where are you pinging the FPP at .27?



Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: danj on August 24, 2016, 08:19:00 PM
Threesizes--Here are screen shots as requested; also included screen shot of the apt wireless ip/gateway/etc from the "details" popup.   To clarify, I used the network/sharing center to determine the ip address, gateway, etc of the apt wireless router; these are as shown on the wireless screen shot.   I then set the static IP address, gateway, etc of the pi3 wlan0 (using the FPP UI) to 10.219.213.27 and other settings as shown in the screen shot.  I am pinging from my laptop, which is hooked up to the pi3's eth0 via a hardline Ethernet and connected to the apt complex wireless router.   I probably can't stress enough---I know very very little about networking so I am quite sure I am missing something really simple....  Thanks very much for your help
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: ThreeSizes on August 24, 2016, 09:19:01 PM
Threesizes--Here are screen shots as requested; also included screen shot of the apt wireless ip/gateway/etc from the "details" popup.   To clarify, I used the network/sharing center to determine the ip address, gateway, etc of the apt wireless router; these are as shown on the wireless screen shot.   I then set the static IP address, gateway, etc of the pi3 wlan0 (using the FPP UI) to 10.219.213.27 and other settings as shown in the screen shot.  I am pinging from my laptop, which is hooked up to the pi3's eth0 via a hardline Ethernet and connected to the apt complex wireless router.   I probably can't stress enough---I know very very little about networking so I am quite sure I am missing something really simple....  Thanks very much for your help


Can you remove the gateway setting from the ETH0 screen, just in case. I don't think how you have it set is an issue, the value is correct, we just don't normally set it in the both screens.


I also want you to try setting WLAN0 to DHCP and see what happens. Once you set it to DHCP, you will need to update / restart the interface in the GUI. Then go to Help > Troubleshooting commands and see what you get for wlan0 under ifconfig -a. It should be something in the 10.X.X.X subnet, but not necessarily the .27 you choose. Then try connecting to that IP from your laptop.


If you don't get an address for WLAN0, then its a connection issue to the WiFi. If you get an address, then we know you are connecting fine, and if you still can't ping then its most likely the station isolation preventing the communication between the two.



Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: danj on August 25, 2016, 07:57:43 PM
Thank you again.    Ok, here's what I did and the results...   Drum roll please....
I reset wlan0 to DHCP, updated/restarted, checked the troubleshooting screen and the IP address is now set to 10.237.123.208.  I checked the wireless again and it is set at 10.219.213.26.  I am able to ping eth0, which is at 192.168.0.10, but I am still not able to ping wlan0.   I was also able to ping the wireless.    I tried another pi3 just to make sure, and I got the same results...   Oh, I removed the gateway from eth0 as you recommended...
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: ThreeSizes on August 25, 2016, 08:24:56 PM
Thank you again.    Ok, here's what I did and the results...   Drum roll please....
I reset wlan0 to DHCP, updated/restarted, checked the troubleshooting screen and the IP address is now set to 10.237.123.208.  I checked the wireless again and it is set at 10.219.213.26.  I am able to ping eth0, which is at 192.168.0.10, but I am still not able to ping wlan0.   I was also able to ping the wireless.    I tried another pi3 just to make sure, and I got the same results...   Oh, I removed the gateway from eth0 as you recommended...


I think you are running into station isolation on the WiFi network. Can you try connecting to http://10.128.128.128 or https://10.128.128.128 from the laptop and see what you get? It might give us a clue about how the WiFi network is setup.
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: danj on August 25, 2016, 09:06:15 PM
Yes I am able to see the device mapped to 10.128.128.128; it is a wireless access point.   Here are a couple of snips from the page that comes up when I input 10.128.128.128 into my browser (attached).  If I am reading correctly, the AP is used as the master routing point for several wireless devices?   I see the "TheInez" wireless router to which I normally connect.   The AP is named "TheInez-3rdFloor"

For info, I will be running the pi3's thru my home network, not this apt network....  So maybe I'm making this harder than it has to be ??

THANKS SO MUCH FOR YOUR HELP
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: ThreeSizes on August 26, 2016, 09:24:41 AM
Yes I am able to see the device mapped to 10.128.128.128; it is a wireless access point.   Here are a couple of snips from the page that comes up when I input 10.128.128.128 into my browser (attached).  If I am reading correctly, the AP is used as the master routing point for several wireless devices?   I see the "TheInez" wireless router to which I normally connect.   The AP is named "TheInez-3rdFloor"

For info, I will be running the pi3's thru my home network, not this apt network....  So maybe I'm making this harder than it has to be ??

THANKS SO MUCH FOR YOUR HELP


Yeah, at this point I would assume station isolation is in place and that you're not going to get it working like you want on the Apt WiFi. I would wait until you get on your home WiFi.







Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: danj on August 26, 2016, 12:07:14 PM
Thanks so much for your help.   I'll post my results this weekend when I am at home.
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: danj on August 26, 2016, 10:46:38 PM
Ok.   I fired up everything at home; laptop wireless connection to router and router connected to pi3 via hardline Ethernet.   Left both eth0 & wlan0 as DHCP in FPP GUI as recommended.    DHCP assigned IPs are as follows: eth0 192.168.2.4, wlan0 192.168.2.5.   I am able to ping both devices, no problem.   In case it matters, over on the FPP screen (HDMI hooked up to pi3), the wlan0 shows "link encap: Ethernet".   That seems strange to me but I don't know network stuff....   This is probably really obvious, but I checked my router's GUI and it is "seeing" both IP addresses as "FPP"...  I'm not sure what the next step should be??  Try setting eth0 and wlan0 as static IPs??  Yet again, thanks in advance for your continued help
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: ThreeSizes on August 27, 2016, 07:29:50 PM
Ok.   I fired up everything at home; laptop wireless connection to router and router connected to pi3 via hardline Ethernet.   Left both eth0 & wlan0 as DHCP in FPP GUI as recommended.    DHCP assigned IPs are as follows: eth0 192.168.2.4, wlan0 192.168.2.5.   I am able to ping both devices, no problem.   In case it matters, over on the FPP screen (HDMI hooked up to pi3), the wlan0 shows "link encap: Ethernet".   That seems strange to me but I don't know network stuff....   This is probably really obvious, but I checked my router's GUI and it is "seeing" both IP addresses as "FPP"...  I'm not sure what the next step should be??  Try setting eth0 and wlan0 as static IPs??  Yet again, thanks in advance for your continued help


What are you trying to do with the Pi? Under normal circumstances you would not want the FPP connected to the same network via both the wired and wireless interfaces. The Wired interface will always take precedence over the wireless interface, so if you have both it will favor the wired.



Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: danj on August 27, 2016, 07:52:49 PM
Thanks again.    To answer your question, my goal is to be able to access my master & remote pi3's from my home wireless network.   So, I was expecting to be able to control the pi3 via wlan0 from the FPP GUI and have data streaming out of eth0 with a hard line Ethernet connected from eth0 to a controller.   I will go back and read your original post again and set the eth0/wlan0 IP addresses statically; the IP addresses shown in my last post from last night are the DHCP-assigned addresses.
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: Aesl1982 on August 27, 2016, 07:55:15 PM
Can we log into the fpp from cell phones if your away the house? 


Sent from my iPhone using Tapatalk
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: danj on August 27, 2016, 10:20:48 PM
I think so.   I'll try tomorrow night; I'll be at apt then..  I think I should be able to logon to an iPhone hot spot..
I was able to get my pi3 to talk with my router wirelessly tonight, after carefully following Threesizes original post where he showed a typical setup...
I can only "see" devices setup via DHCP in my router's GUI, which is very frustrating..   But it is working now, thanks to all the help I am getting!!!
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: Setarcos on September 01, 2016, 11:29:07 AM
Can we log into the fpp from cell phones if your away the house? 


Sent from my iPhone using Tapatalk

Yes, but you should be using a VPN to tunnel in to your home network. FPP's web interface wasn't designed with security in mind, so there are real risks if you open it up to access from the Internet.

Check if your home Internet router supports OpenVPN (many do). If it does, and you choose to take advantage of this, you can run an OpenVPN client on your smartphone and tunnel in to your home network to access FPP's web interface when needed.
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: michaelc on October 16, 2016, 08:03:14 PM
Do the Slave/Remote Pi's need to have a RAS clock or only the Master?  I've been running a single FPP for the last couple of years but am adding a BB P10 Matrix running FP, and 1 or 2 other FPP's to host video projection.  My plan was to hardwire all the ETH0 Ports of the BB and all Pi's to my router.  Each would just be another device on the 192.168.2.x subnet.  The only internet access would be through the master FPP on wLAN0 going back to my home network of 192.168.1.x.   If I'm reading this correct, it seems like I don't need to run each FP back to the router, but if I add WLAN0 to each of them, it would work since it's just timing signals and not the actual show files.  Is that correct?


Current Configuration:
Eth0:
Static:  192.168.2.111
Mask: 255.255.255.0
GW: 192.168.2.1


DNS:
Name: FPP
Manual
DNS Server 1:  8.8.8.8
DNS Server 2:


WLAN0:
DHCP
SSID: Gothambeat
WPA Pre Shared(PSK: *****


ENable routing checked.
Title: FPP Master + Remotes + WiFi having an issue....
Post by: windsurf on October 28, 2016, 09:11:18 PM
OK, got a little problem/question.

I am not using the slave to run lights off the ethernet.  I'm using the remote with the Pi Hat to run lights on a battery powered light up hat.  Everything works in stand alone.  I put the master in master mode, it keeps running the show.  HOwever, when I put the remote in remote player, it shows:
Syncing to Master: Elapsed: 00:00    Remaining: 00:00
So clearly something isn't right.  Note that my Master is on a wired network.  There is an access point to provide connectivity to the Remote.  I know that works since I can access both PI's from a laptop connected to the wireless.

My config:
  Master
Eth0
Static
IP Address:  192.168.1.200
Netmask:  255.255.255.0
Gateway: 192.168.1.1
DNS: 192.168.1.1
Routing disabled
 
Wlan0
Disabled
 
 
Remote:
Eth0
Static
IP Address:  192.168.2.203
Netmask:  255.255.255.0
Gateway:
DNS:
Routing enabled
 
Wlan0
Static
IP Address:  192.168.1.203
Netmask:  255.255.255.0
Gateway: 192.168.1.1
DNS: 192.168.1.1
Routing enabled
 
Am I missing something here?  Is this not a supported config?  Anyone done it before?
Title: Re: FPP Master + Remotes + WiFi having an issue....
Post by: CaptainMurdoch on October 29, 2016, 12:33:59 AM
Am I missing something here?  Is this not a supported config?  Anyone done it before?

On the master, did you check the box beside the remote on the MultiSync config screen?
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: michaelc on December 09, 2016, 06:45:57 AM
You mention in this thread to be sure to check forwarding on the Pi.  Where exactly is that setting?
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: ThreeSizes on December 09, 2016, 09:06:13 AM
You mention in this thread to be sure to check forwarding on the Pi.  Where exactly is that setting?


It's on the bottom of the Network Settings window in the FPP GUI.



Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: corydorning on December 09, 2016, 09:34:37 AM
Okay, so I'm trying to get all of this setup and I think I'm most of the way there. I can run a traceroute and ping successfully, can access fpp.local, but I can't figure out how to access the F16V2's web interface. My settings are as follows:

Interface: FPP eth0
Mode: Static
IP: 192.168.70.1
Netmask: 255.255.255.0
Gateway: (empty)

Interface: FPP wlan0
Mode: Static
IP: 192.168.1.70
Netmask: 255.255.255.0
Gateway: 192.168.1.1

F16V2
Mode: Static
IP: 192.168.70.2
Mask: 255.255.255.0
Gateway: 192.168.70.1
DNS: 0.0.0.0

Static Route
(https://s30.postimg.org/xh0quozcx/Screen_Shot_2016_12_09_at_11_33_16_AM.png)
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: jnealand on December 09, 2016, 10:06:11 AM
The only difference I see between yours and mine besides the actual numbers is that I do have dns set on the f16 to 192.168.1.1

Have you rebooted after setting all this.  Don't know why but sometimes I have seen that help.
Also I use a route setup in the computers that I use instead of a route setup in my routers.  I could never get it to work using routes in the router itself.
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: ThreeSizes on December 09, 2016, 10:10:21 AM
Okay, so I'm trying to get all of this setup and I think I'm most of the way there. I can run a traceroute and ping successfully, can access fpp.local, but I can't figure out how to access the F16V2's web interface. My settings are as follows:

Interface: FPP eth0
Mode: Static
IP: 192.168.70.1
Netmask: 255.255.255.0
Gateway: (empty)

Interface: FPP wlan0
Mode: Static
IP: 192.168.1.70
Netmask: 255.255.255.0
Gateway: 192.168.1.1

F16V2
Mode: Static
IP: 192.168.70.2
Mask: 255.255.255.0
Gateway: 192.168.70.1
DNS: 0.0.0.0

Static Route
(https://s30.postimg.org/xh0quozcx/Screen_Shot_2016_12_09_at_11_33_16_AM.png)


To confirm, you enabled Forwarding on the FPP in addition to what you stated?


When you say ping and traceroute, do you mean to the FPP or to the F16V2?







Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: corydorning on December 09, 2016, 10:10:44 AM
The only difference I see between yours and mine besides the actual numbers is that I do have dns set on the f16 to 192.168.1.1

Have you rebooted after setting all this.  Don't know why but sometimes I have seen that help.
Also I use a route setup in the computers that I use instead of a route setup in my routers.  I could never get it to work using routes in the router itself.


Just tried that. No luck. :/

Just to verify, to access the controller web interface, i'd go to http://192.168.70.2/ (http://192.168.70.2/) correct?
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: jnealand on December 09, 2016, 10:12:04 AM
yes
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: corydorning on December 09, 2016, 10:13:26 AM
Okay, so I'm trying to get all of this setup and I think I'm most of the way there. I can run a traceroute and ping successfully, can access fpp.local, but I can't figure out how to access the F16V2's web interface. My settings are as follows:

Interface: FPP eth0
Mode: Static
IP: 192.168.70.1
Netmask: 255.255.255.0
Gateway: (empty)

Interface: FPP wlan0
Mode: Static
IP: 192.168.1.70
Netmask: 255.255.255.0
Gateway: 192.168.1.1

F16V2
Mode: Static
IP: 192.168.70.2
Mask: 255.255.255.0
Gateway: 192.168.70.1
DNS: 0.0.0.0

Static Route
(https://s30.postimg.org/xh0quozcx/Screen_Shot_2016_12_09_at_11_33_16_AM.png)


To confirm, you enabled Forwarding on the FPP in addition to what you stated?


When you say ping and traceroute, do you mean to the FPP or to the F16V2?


Yes, forwarding has been enabled.


Controller:
  traceroute 192.168.70.2
traceroute to 192.168.70.2 (192.168.70.2), 64 hops max, 52 byte packets
 1  192.168.1.1 (192.168.1.1)  0.523 ms  0.295 ms  0.286 ms
 2  192.168.1.70 (192.168.1.70)  4.292 ms  5.974 ms  2.378 ms
 3  * * *


FPP:
ping 192.168.70.1
PING 192.168.70.1 (192.168.70.1): 56 data bytes
64 bytes from 192.168.70.1: icmp_seq=0 ttl=64 time=2.199 ms
92 bytes from 192.168.1.1: Redirect Host(New addr: 192.168.1.70)
Vr HL TOS  Len   ID Flg  off TTL Pro  cks      Src      Dst
 4  5  00 0054 39db   0 0000  3f  01 7970 192.168.1.12  192.168.70.1


64 bytes from 192.168.70.1: icmp_seq=1 ttl=64 time=1.968 ms
92 bytes from 192.168.1.1: Redirect Host(New addr: 192.168.1.70)
Vr HL TOS  Len   ID Flg  off TTL Pro  cks      Src      Dst
 
 4  5  00 0054 f9a0   0 0000  3f  01 b9aa 192.168.1.12  192.168.70.1
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: corydorning on December 09, 2016, 10:15:04 AM
(https://s24.postimg.org/ovj9o1d1x/Screen_Shot_2016_12_09_at_12_14_08_PM.png)
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: corydorning on December 09, 2016, 10:26:55 AM
delete
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: michaelc on December 09, 2016, 11:16:19 AM
You mention in this thread to be sure to check forwarding on the Pi.  Where exactly is that setting?


It's on the bottom of the Network Settings window in the FPP GUI.


When you say forwarding are you referring to the "Enable Routing Between Network Interfaces" option or something else?  I don't see anything other than that at the bottom.
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: corydorning on December 09, 2016, 11:17:09 AM
You mention in this thread to be sure to check forwarding on the Pi.  Where exactly is that setting?


It's on the bottom of the Network Settings window in the FPP GUI.

When you say forwarding are you referring to the "Enable Routing Between Network Interfaces" option or something else?  I don't see anything other than that at the bottom.

Sorry, yes this is what i meant
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: ThreeSizes on December 09, 2016, 11:23:24 AM
Okay, so I'm trying to get all of this setup and I think I'm most of the way there. I can run a traceroute and ping successfully, can access fpp.local, but I can't figure out how to access the F16V2's web interface. My settings are as follows:

Interface: FPP eth0
Mode: Static
IP: 192.168.70.1
Netmask: 255.255.255.0
Gateway: (empty)

Interface: FPP wlan0
Mode: Static
IP: 192.168.1.70
Netmask: 255.255.255.0
Gateway: 192.168.1.1

F16V2
Mode: Static
IP: 192.168.70.2
Mask: 255.255.255.0
Gateway: 192.168.70.1
DNS: 0.0.0.0

Static Route
(https://s30.postimg.org/xh0quozcx/Screen_Shot_2016_12_09_at_11_33_16_AM.png)


To confirm, you enabled Forwarding on the FPP in addition to what you stated?


When you say ping and traceroute, do you mean to the FPP or to the F16V2?


Yes, forwarding has been enabled.


Controller:
  traceroute 192.168.70.2
traceroute to 192.168.70.2 (192.168.70.2), 64 hops max, 52 byte packets
 1  192.168.1.1 (192.168.1.1)  0.523 ms  0.295 ms  0.286 ms
 2  192.168.1.70 (192.168.1.70)  4.292 ms  5.974 ms  2.378 ms
 3  * * *


FPP:
ping 192.168.70.1
PING 192.168.70.1 (192.168.70.1): 56 data bytes
64 bytes from 192.168.70.1: icmp_seq=0 ttl=64 time=2.199 ms
92 bytes from 192.168.1.1: Redirect Host(New addr: 192.168.1.70)
Vr HL TOS  Len   ID Flg  off TTL Pro  cks      Src      Dst
 4  5  00 0054 39db   0 0000  3f  01 7970 192.168.1.12  192.168.70.1


64 bytes from 192.168.70.1: icmp_seq=1 ttl=64 time=1.968 ms
92 bytes from 192.168.1.1: Redirect Host(New addr: 192.168.1.70)
Vr HL TOS  Len   ID Flg  off TTL Pro  cks      Src      Dst
 
 4  5  00 0054 f9a0   0 0000  3f  01 b9aa 192.168.1.12  192.168.70.1


What kind of router are you using? We'd had some problems with certain ones before not routing properly.  And that appears to me to be your case with what showed with the traceroute and ping commands. Can you try manually configuring a route on your PC and see if that enables you to access the F16V2. There should be instructions on how to do the manual routes in the beginning of this thread.



Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: ThreeSizes on December 09, 2016, 11:24:26 AM
You mention in this thread to be sure to check forwarding on the Pi.  Where exactly is that setting?


It's on the bottom of the Network Settings window in the FPP GUI.


When you say forwarding are you referring to the "Enable Routing Between Network Interfaces" option or something else?  I don't see anything other than that at the bottom.


Yes, we then to refer to that option using forwarding as shorthand.



Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: corydorning on December 09, 2016, 11:29:24 AM
Okay, so I'm trying to get all of this setup and I think I'm most of the way there. I can run a traceroute and ping successfully, can access fpp.local, but I can't figure out how to access the F16V2's web interface. My settings are as follows:

Interface: FPP eth0
Mode: Static
IP: 192.168.70.1
Netmask: 255.255.255.0
Gateway: (empty)

Interface: FPP wlan0
Mode: Static
IP: 192.168.1.70
Netmask: 255.255.255.0
Gateway: 192.168.1.1

F16V2
Mode: Static
IP: 192.168.70.2
Mask: 255.255.255.0
Gateway: 192.168.70.1
DNS: 0.0.0.0

Static Route
(https://s30.postimg.org/xh0quozcx/Screen_Shot_2016_12_09_at_11_33_16_AM.png)


To confirm, you enabled Forwarding on the FPP in addition to what you stated?


When you say ping and traceroute, do you mean to the FPP or to the F16V2?


Yes, forwarding has been enabled.


Controller:
  traceroute 192.168.70.2
traceroute to 192.168.70.2 (192.168.70.2), 64 hops max, 52 byte packets
 1  192.168.1.1 (192.168.1.1)  0.523 ms  0.295 ms  0.286 ms
 2  192.168.1.70 (192.168.1.70)  4.292 ms  5.974 ms  2.378 ms
 3  * * *


FPP:
ping 192.168.70.1
PING 192.168.70.1 (192.168.70.1): 56 data bytes
64 bytes from 192.168.70.1: icmp_seq=0 ttl=64 time=2.199 ms
92 bytes from 192.168.1.1: Redirect Host(New addr: 192.168.1.70)
Vr HL TOS  Len   ID Flg  off TTL Pro  cks      Src      Dst
 4  5  00 0054 39db   0 0000  3f  01 7970 192.168.1.12  192.168.70.1


64 bytes from 192.168.70.1: icmp_seq=1 ttl=64 time=1.968 ms
92 bytes from 192.168.1.1: Redirect Host(New addr: 192.168.1.70)
Vr HL TOS  Len   ID Flg  off TTL Pro  cks      Src      Dst
 
 4  5  00 0054 f9a0   0 0000  3f  01 b9aa 192.168.1.12  192.168.70.1


What kind of router are you using? We'd had some problems with certain ones before not routing properly.  And that appears to me to be your case with what showed with the traceroute and ping commands. Can you try manually configuring a route on your PC and see if that enables you to access the F16V2. There should be instructions on how to do the manual routes in the beginning of this thread.


I'm using an ASUS RT-N56U router. I'll take a look at the beginning of the thread for manual routes.
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: ThreeSizes on December 09, 2016, 11:53:09 AM
[I'm using an ASUS RT-N56U router. I'll take a look at the beginning of the thread for manual routes.


Asus brand routers are one of the ones we've issues with doing routing.



Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: Bshaver on December 09, 2016, 11:55:05 AM
I just did this on my PFSENSE enterprise router system today. Wow. doing HEX conversion was fun, but it works! DHCP option 121!
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: corydorning on December 09, 2016, 12:04:45 PM
[I'm using an ASUS RT-N56U router. I'll take a look at the beginning of the thread for manual routes.


Asus brand routers are one of the ones we've issues with doing routing.


Figures lol. Anyways, this did the trick:
sudo route add 192.168.70.0/24 192.168.1.70


Thanks for the help!
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: corydorning on December 09, 2016, 01:29:58 PM
On second thought, I'm not sure this is working entirely. When I access the controller webpage via 192.168.70.2, I'm not able to save anything.
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: ThreeSizes on December 09, 2016, 03:34:40 PM
On second thought, I'm not sure this is working entirely. When I access the controller webpage via 192.168.70.2, I'm not able to save anything.


Routing is not the first thing I would suspect, if you can browse around to multiple places in the controller webpage and if data on the webpage is updating as you go, like times statistics etc. The function of interacting with a webpage occurs at a much higher level in the network stack. You can verify this by opening a command prompt on your PC and do a continuous ping to the controller. On Mac or Linux, ping is continuous by default, on Windows add -t to the ping command. You should not see any breaks (or lost pings) while you are using the webpage and attempting to update/save your settings.



Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: corydorning on December 12, 2016, 11:46:38 AM
Everything working. Thanks guys!
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: JoelRose on December 12, 2016, 05:50:52 PM
OK my turn,  My head hurts just trying to read this thread.

I made the common mistake of placing everything on 192.168.1.xx

The home network was being flooded and master/remote response was only about 80% even after adding 5 second pauses between songs.

I configured a second router as 192.168.10.xx
It has no physical connection to anything (except when I swap my network connection cable from my pc, no wireless.)

In case the pictures do not come through

FPP is the master and is
eth0  DHCP  (only connected to hub to run wired show, no connection to outside)
WLAN  192.168.10.40

FPP10  is a remote
eth0  DHCP  not even connected.
WLAN  192.168.10.41

FPP6  is a remote  sending 48 channels to an ESP  192.168.10.203 unicast
eth0  DHCP  not even connected
WLAN  192.168.10.42

I can talk to all three devices with no problem.
I can also play sequences from the playlist in standalone mode.
Even the ESP response is smooth being driven from a BBB driving a 64x64 matrix.

But when they are in remote mode there is no output. :(
When they were all on the 192.168.1.XX network they did work, just not all the time.

Has to be something simple,  what did I miss.

Joel
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: ThreeSizes on December 12, 2016, 05:57:46 PM
OK my turn,  My head hurts just trying to read this thread.

I made the common mistake of placing everything on 192.168.1.xx

The home network was being flooded and master/remote response was only about 80% even after adding 5 second pauses between songs.

I configured a second router as 192.168.10.xx
It has no physical connection to anything (except when I swap my network connection cable from my pc, no wireless.)

In case the pictures do not come through

FPP is the master and is
eth0  DHCP  (only connected to hub to run wired show, no connection to outside)
WLAN  192.168.10.40

FPP10  is a remote
eth0  DHCP  not even connected.
WLAN  192.168.10.41

FPP6  is a remote  sending 48 channels to an ESP  192.168.10.203 unicast
eth0  DHCP  not even connected
WLAN  192.168.10.42

I can talk to all three devices with no problem.
I can also play sequences from the playlist in standalone mode.
Even the ESP response is smooth being driven from a BBB driving a 64x64 matrix.

But when they are in remote mode there is no output. :(
When they were all on the 192.168.1.XX network they did work, just not all the time.

Has to be something simple,  what did I miss.

Joel


What does the MultiSync screen look like on the Master FPP? It should list all three of your FPP's there.



Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: JoelRose on December 12, 2016, 06:26:03 PM
It is showing the master twice, once on each interface.
Is that the problem?


Joel
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: ThreeSizes on December 12, 2016, 06:46:50 PM
Having it listed twice is expected. You do need to check the boxes for the Remotes you want to send sync packets to or check the All Remotes option.



Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: JoelRose on December 12, 2016, 07:37:19 PM
Call that a V8 moment.   :-[

I thought those checks were only for copying the files to the remotes.

Makes sense now.

Everything is working great.

JOel
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: Mattera68 on December 15, 2016, 02:33:27 PM
I cant figure out where to set up the routes on my router, ARRISGW.

I have no idea where to go to add the routes on my laptop in option 2
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: jnealand on December 15, 2016, 05:03:43 PM
On a computer you have to bring up a command prompt in admin mode then just enter your route command.  In Win10 right click on the start button and select command prompt (admin).
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: Mattera68 on December 15, 2016, 06:36:57 PM
I got a "the requested operation requires elevation." message
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: jnealand on December 15, 2016, 07:12:20 PM
That message is due to the fact that you are not running the command prompt in admin mode.  Just because your user id has admin privileges is not sufficient.  You must START the command prompt by right clicking on the icon or if running win 10 right clicking on the start button as I stated above.
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: Mattera68 on December 18, 2016, 08:15:23 AM
ok, I was able to get the route into the command prompt.
When I trace to the controller, 192.168.101.50 this is what I get:

1    13 ms     3 ms     4 ms  FPP [192.168.0.21]
2     3 ms     3 ms     3 ms  192.168.0.1
3    11 ms    14 ms    11 ms  10.249.64.1
4   155 ms    12 ms    11 ms  ge-15-0-cmts1.leonardtown.md.metrocast.net [216.
.30.140]
5   345 ms    33 ms    21 ms  static-216-36-22-226.cpe.metrocast.net [216.36.2
226]
6     *        *        *     Request timed out.
7     *        *        *     Request timed out.
8     *        *        *     Request timed out.
9     *        *        *     Request timed out.
0     *        *        *     Request timed out.
1     *        *        *     Request timed out.
2     *        *        *     Request timed out.
3     *        *        *     Request timed out.
4     *        *
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: ThreeSizes on December 18, 2016, 09:01:51 AM
ok, I was able to get the route into the command prompt.
When I trace to the controller, 192.168.101.50 this is what I get:

1    13 ms     3 ms     4 ms  FPP [192.168.0.21]
2     3 ms     3 ms     3 ms  192.168.0.1
3    11 ms    14 ms    11 ms  10.249.64.1
4   155 ms    12 ms    11 ms  ge-15-0-cmts1.leonardtown.md.metrocast.net [216.
.30.140]
5   345 ms    33 ms    21 ms  static-216-36-22-226.cpe.metrocast.net [216.36.2
226]
6     *        *        *     Request timed out.
7     *        *        *     Request timed out.
8     *        *        *     Request timed out.
9     *        *        *     Request timed out.
0     *        *        *     Request timed out.
1     *        *        *     Request timed out.
2     *        *        *     Request timed out.
3     *        *        *     Request timed out.
4     *        *

Can you post more details on your setup? We need to see how you have both interfaces configured on the FPP as well as how you have the controller configured.

How you are setup now shows that it's getting the FPP and then something afterwords is sending it out your internet provider.


Sent from my iPad using Tapatalk Pro
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: Mattera68 on December 18, 2016, 11:14:14 AM
Here are the FPP settings

My F16 is set to 192.168.101.50
I think the Gateway was set to 192.168.0.21 which is the FPP wlan ip
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: ThreeSizes on December 18, 2016, 11:23:09 AM
Here are the FPP settings

My F16 is set to 192.168.101.50
I think the Gateway was set to 192.168.0.21 which is the FPP wlan ip

Remove the gateway on eth0 on the FPP and make sure the gateway on the F16 is the eth0 address of the FPP.




Sent from my iPad using Tapatalk Pro
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: Mattera68 on December 18, 2016, 12:16:02 PM
I should have set the controller gateway to the etho ip like it explains on the 1st page here, going from memory.
I changed the ip settings on the controller so now I cannot connect to it.


While writing this I rebooted FPP, then checked the connection to the F16 and it worked. I guess getting rid of the gateway in the eth0 settings did it!

Thanks for everyone's help!!!!!!!
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: Mattera68 on December 18, 2016, 12:18:53 PM
So if I add another Pi in the future I will just have to add another route to my PC like I did for this one?

If I add a controller to this Pi, I should be able to connect with the route I have already written as long as I set it to this same subnet?
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: Mattera68 on December 18, 2016, 12:42:39 PM
Also, what is the reason to have a Pi just connected to the transmitter? and no controller? Referring to the diagrams on the 1st page
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: ThreeSizes on December 18, 2016, 01:35:22 PM
So if I add another Pi in the future I will just have to add another route to my PC like I did for this one?

If I add a controller to this Pi, I should be able to connect with the route I have already written as long as I set it to this same subnet?


If you add a second PI with something behind it, then you will need to add a second route. The route is not for the FPP itself but to the devices behind the FPP. When you add a second FPP, you need to make sure its unique on both sides so your WLAN0 would be say 192.168.0.22 and ETH0 would be say 192.168.102.1.



Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: ThreeSizes on December 18, 2016, 01:41:19 PM
Also, what is the reason to have a Pi just connected to the transmitter? and no controller? Referring to the diagrams on the 1st page


In my example, the Master FPP was dedicated to sending sync packets to the remote FPP and transmitting the audio since it has a HiFiBerry DAC PiHat for better audio. I was also toying with the ideal of doing video projection mapping and I would have been using the Master FPP to drive the projector. In reality it was just a personal preference of mine to have the Master FPP only do master things.







Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: jnealand on December 18, 2016, 02:15:10 PM
Also, what is the reason to have a Pi just connected to the transmitter? and no controller? Referring to the diagrams on the 1st page

My master has only the FM transmitter on it, because it is inside the house and is a Bplus while all the Pis attached to controllers are Pi3s.  There have been lot of issues with Pi3 and audio so I repurposed my Bplus unit.  Plus I keep the transmitter inside the house and have no wires going from inside to outside.  It also is right next to my wifi show router.  All 3 items are mounted to a piece of pegboard on a wall inside a closet on the front side of the house.
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: Mattera68 on December 18, 2016, 02:46:27 PM
So if I add another Pi in the future I will just have to add another route to my PC like I did for this one?

If I add a controller to this Pi, I should be able to connect with the route I have already written as long as I set it to this same subnet?


If you add a second PI with something behind it, then you will need to add a second route. The route is not for the FPP itself but to the devices behind the FPP. When you add a second FPP, you need to make sure its unique on both sides so your WLAN0 would be say 192.168.0.22 and ETH0 would be say 192.168.102.1.

That's what I meant with the 2nd Pi, thanks!
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: Mattera68 on December 18, 2016, 02:49:11 PM
Also, what is the reason to have a Pi just connected to the transmitter? and no controller? Referring to the diagrams on the 1st page

My master has only the FM transmitter on it, because it is inside the house and is a Bplus while all the Pis attached to controllers are Pi3s.  There have been lot of issues with Pi3 and audio so I repurposed my Bplus unit.  Plus I keep the transmitter inside the house and have no wires going from inside to outside.  It also is right next to my wifi show router.  All 3 items are mounted to a piece of pegboard on a wall inside a closet on the front side of the house.

Wifi show router? Can you explain that setup? Sorry for so many ?'s, just trying to understand all this stuff.
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: ThreeSizes on December 18, 2016, 05:23:27 PM
Also, what is the reason to have a Pi just connected to the transmitter? and no controller? Referring to the diagrams on the 1st page

My master has only the FM transmitter on it, because it is inside the house and is a Bplus while all the Pis attached to controllers are Pi3s.  There have been lot of issues with Pi3 and audio so I repurposed my Bplus unit.  Plus I keep the transmitter inside the house and have no wires going from inside to outside.  It also is right next to my wifi show router.  All 3 items are mounted to a piece of pegboard on a wall inside a closet on the front side of the house.

Wifi show router? Can you explain that setup? Sorry for so many ?'s, just trying to understand all this stuff.

Some people setup a dedicated WiFi network for their show separate from their home WiFi network. If you are use sending FPP sync packets there is not an issue. If you are sending actual E1.31 packets they are rather noisy and will flood your WiFi network and make it tough to do things like surf the net. By having the E1.31 on its own WiFI you don't impact your home network.




Sent from my iPad using Tapatalk Pro
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: jnealand on December 18, 2016, 05:31:02 PM
And I had a second router already that was used last year also.
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: Mattera68 on December 24, 2016, 08:41:15 AM
Is the show wifi connected to the Internet?
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: jnealand on December 24, 2016, 07:00:33 PM
My show router has internet access.  Works great for updates.
Title: Re: FPP WiFi Setup (Originally Master + Remotes + WiFi How-To)
Post by: Mattera68 on December 25, 2016, 12:19:37 PM
Can you explain the set up? Maybe a drawing