Author Topic: Noobie can't see the controller behind the pi.  (Read 558 times)

Offline acer1171

  • Newbie
  • *
  • Join Date: Nov 2018
  • Location:
  • Posts: 7
  • Kudos: 0
Noobie can't see the controller behind the pi.
« on: November 25, 2018, 01:35:01 PM »
I have followed the instructions in the manual and I have followed several different post, main post being from Brian Hensley, and I still can't find the controller behind the pi.
I need some expert help here.
I spent 2 days crashing both my pi and my controller only to have to reset and start over several times, both would disappear on me and I could not get them back.
I am now able to see the pi via wireless or wired and the controller when it is wired but the minute I plug the pie into the controller I am only able to see the pi? I am pulling my hair out here spending hours trying to figure this out.
I think it may have to do with my network but I am not sure?
Any help would be appreciated!

Offline K-State Fan

  • Sr. Member
  • ****
  • Join Date: Dec 2014
  • Location:
  • Posts: 312
  • Kudos: 5
Re: Noobie can't see the controller behind the pi.
« Reply #1 on: November 25, 2018, 01:39:57 PM »
Posting screen shots of your network settings would help people determine what is wrong.

Offline acer1171

  • Newbie
  • *
  • Join Date: Nov 2018
  • Location:
  • Posts: 7
  • Kudos: 0
Re: Noobie can't see the controller behind the pi.
« Reply #2 on: November 25, 2018, 01:41:45 PM »
Just let me know what you need and I will post it!

Offline acer1171

  • Newbie
  • *
  • Join Date: Nov 2018
  • Location:
  • Posts: 7
  • Kudos: 0
Re: Noobie can't see the controller behind the pi.
« Reply #3 on: November 25, 2018, 02:03:41 PM »
Here are the current settings for the pi and the controller.
I have google wifi set up and I do not use the wifi on my cable modem it has been turned off, I prefer the mesh networking from the google wifi. The gateway listed on the Pi wlan0 is for my google wifi, my cable modem has a different gateway. I am wondering if that maybe my issue?
When I used that gateway, that is when I lost everything and had to reset both my pi and my controller to factory to be able to see them again.I did not catch it in the pictures but yes I have the "Enable Routing between network interfaces" box checked.

Offline tbone321

  • Hero Member
  • *****
  • Join Date: Oct 2014
  • Location:
  • Posts: 1,585
  • Kudos: 50
Re: Noobie can't see the controller behind the pi.
« Reply #4 on: November 25, 2018, 06:43:13 PM »
The settings look good but you will need to either set up a route command on the PC that you are using to look at the controller with or add a route to your routers routing table set the gateway for the show network.  The problem is that when you are attempting to see the controller, it is on a different network and your PC is using your router as the gateway to your show network but it has no route for your show network so you see nothing.  The route between interfaces checkbox on the PI turns it into a gateway between your show and home networks but your PC does not know to use that gateway so it doesn't send any requests to the PI.  You can use the route command to tell the PC to send any requests for the show network to the PI or set up a route on your router to also redirect requests for the show network to the PI.  If you are using a PC the route command is easier but if you are using multiple devices including cell phones, configuring s route on your home router may be the only way to go.

Offline acer1171

  • Newbie
  • *
  • Join Date: Nov 2018
  • Location:
  • Posts: 7
  • Kudos: 0
Re: Noobie can't see the controller behind the pi.
« Reply #5 on: November 26, 2018, 04:22:21 AM »
Thank you for the reply tbone. I have added the route to the pc and I am still not able to see the controller. I am not able to find any place on my router to be able to insert specific routes, so I have been doing this through my pc. I have tried several different configurations with adding this to the pc but it can't find the path?

Offline tbone321

  • Hero Member
  • *****
  • Join Date: Oct 2014
  • Location:
  • Posts: 1,585
  • Kudos: 50
Re: Noobie can't see the controller behind the pi.
« Reply #6 on: November 26, 2018, 05:59:04 AM »
Please show the route command that you issued on the PC.

Offline darksideofdmoon

  • Newbie
  • *
  • Join Date: Sep 2018
  • Location:
  • Posts: 5
  • Kudos: 0
Re: Noobie can't see the controller behind the pi.
« Reply #7 on: November 26, 2018, 03:10:53 PM »
Did you try this tutorial?


http://www.brianhensley.net/2017/10/network-setup-falcon-player-fpp-falcon-f16v3-controller.html


I followed this to a T and had zero issues.

Offline acer1171

  • Newbie
  • *
  • Join Date: Nov 2018
  • Location:
  • Posts: 7
  • Kudos: 0
Re: Noobie can't see the controller behind the pi.
« Reply #8 on: November 27, 2018, 05:27:40 PM »
Sorry I had to get to the computer and that isn't so easy with a 2 yo. Here are the routes I tried: route add 192.168.0.10 mask 255.255.255.0 192.168.86.250 -p again with the -p first, saw it this way on another tutorial. Then route add 192.168.0.10 mask 255.255.255.0 (192.168.0.1 this is the ip address of my cable modem) and it doesn't seem to matter which way I have it I still can't see the controller?
Yes I have followed his tutorial to a T and I can't get it to work?
Thanks again for the help guys.
« Last Edit: November 27, 2018, 05:33:59 PM by acer1171 »

Offline pixelpuppy

  • Hero Member
  • *****
  • Join Date: Aug 2015
  • Location: Dallas, TX
  • Posts: 1,402
  • Kudos: 44
Re: Noobie can't see the controller behind the pi.
« Reply #9 on: November 27, 2018, 05:53:28 PM »
tried: route add 192.168.0.10 mask 255.255.255.0 192.168.86.250 -p again with the -p first

That should be correct.  Doesn't matter if -p is first or last, its just an option to make the route "persistent" (preserved across reboots)

One thing you didn't show on any screenshot is if you have "Enable Routing between network interfaces" enabled on the FPP.   Its a small checkbox in the very bottom left corner of the Network Configuration screen
-Mark

Offline acer1171

  • Newbie
  • *
  • Join Date: Nov 2018
  • Location:
  • Posts: 7
  • Kudos: 0
Re: Noobie can't see the controller behind the pi.
« Reply #10 on: November 27, 2018, 06:32:44 PM »
Pixel puppy I noted that in one of my posts that I didn't catch it in the pictures but I do have it checked.
I did not catch it in the pictures but yes I have the "Enable Routing between network interfaces" box checked.

Offline tbone321

  • Hero Member
  • *****
  • Join Date: Oct 2014
  • Location:
  • Posts: 1,585
  • Kudos: 50
Re: Noobie can't see the controller behind the pi.
« Reply #11 on: November 28, 2018, 05:35:46 PM »
The correct route command is route add 192.168.0.0 mask 255.255.255.0 192.168.86.250 -p  This tells your PC that to reach anything on your 192.168.0.X show network, send the request to address 192.168.86.250 which is your PI's wireless interface.  Using a specific host address such as 192.168.0.10 with a network level mask of 255.255.255.0 causes issues and where it appears to accept it, it usually doesn't work.  Make sure to get rid of the other entries for your show network in the table because they will be ahead of this one in the table and this one will never be used. 

Offline acer1171

  • Newbie
  • *
  • Join Date: Nov 2018
  • Location:
  • Posts: 7
  • Kudos: 0
Re: Noobie can't see the controller behind the pi.
« Reply #12 on: November 28, 2018, 08:37:00 PM »
tbone you are the awesome-est! I know that's not a real word but it should be! I have been beating my head against a wall for a week and all it took was that one line to get it to work! Everyone here was in bed when I saw your post so I ran down stairs to my lab, entered  the route command and viola it works!
As for the commands I entered earlier,if it didn't work I would delete it right away! Now I have to figure out how to set up xlights so I can find out if my controller works on anything but test mode, lol!
Thank you very much! ;D Chris

 

Back to top