The Lab (Technical Talk) > Designer Troubleshooting and Help

Major problems with my mega tree pixels -- out of ideas help

(1/3) > >>

wsmithmusic:

I have a very strange problem that I don't understand and really need some ideas please. 
I built a 500 pixel 5v megatree a year ago.  10 strings with 50 pixels each.  Power injection at every 100 pixels.  The pixels came from Alitove on Amazon.  Power supply is a Tanbaby 60amp 5v.  I used a teensy octo with a separate data lead every 100 pixels and raspberry pi with fpp to run it.  Everything worked.  I stored everything connected.  This year, I can't get the colors to work correctly.

I've switched the controller to a Falcon F4V3.  I go into test mode blue.  The first 50 pixels are blue, pixel 51 through about 80 are green and 81 through 100 are blue.  Other color tests do similar.  Test mode white show all pixels white with even brightness.  I get this result on multiple strands/combinations.  The first 50 always show correctly but then seem to go crazy.  I cut the first pixel out and now pixels 2-51 are blue, the next 20-30 are green and the last few are blue. 

I've tried a different power supply, new 18-2 power wire and cat6 for the data line.  I've isolated just 2 strands and get the same result.  The teensy doesn't show correct colors either when I tried hooking it back up. 

I have 4 new strings and a star I wanted to add this year; they all work perfectly on the same equipment/same wiring. 

Are all my pixels bad?  It's like I'm getting data corruption somehow, but in a consistent pattern from my start point. Any ideas?

Thanks,
Weston

tmarshall:

What is your output voltage? If it is too high, that can cause strange issues. A single color test will have a lower voltage drop than an all white test. It could be that the all white test results in enough of a voltage drop to make the lights start functioning properly again.


Just a thought.


wsmithmusic:
On the tanbaby with nothing connected it tested at almost 9v.  I used a different 5v switching adapter, which tested at 5.6v if I remember correctly.  I had the same result with both.  I've also tried just powering 100 pixels with the output of the F4V3 because it tests at 5.1v.  I get the same pixel output problems hooked all the 3 ways . . .

need_help:
What kind of pixels are they? (WS2811, WS2801), etc?

wsmithmusic:
They're supposed to be WS2811.  Here is a link to what I purchased: 


ALITOVE 500pcs WS2811 12mm Diffused Digital Dream Color RGB LED Pixel String Light Individually Addressable LED Pixels Module for LED Screen Wall Outdoor Advertising Board Signs IP68 Waterproof DC 5V
https://www.amazon.com/gp/product/B01NCAG8KV/ref=oh_aui_detailpage_o07_s00?ie=UTF8&psc=1


The thing that keeps stumping me is a year ago they worked.  They've been unplugged and stored for a year and now they don't. 

Navigation

[0] Message Index

[#] Next page

Go to full version