Author Topic: F16V2 - RED - Firmware Update Problem  (Read 479 times)

Offline tonyatlafb

  • Newbie
  • *
  • Join Date: Jan 2017
  • Location:
  • Posts: 2
  • Kudos: 0
F16V2 - RED - Firmware Update Problem
« on: December 05, 2018, 03:18:41 PM »
Currently my F16V2 (Red board) has a blank screen when powered up. So, I have attempted to load the firmware by following "Falcon F16v2 Firmware Upgrade" via Youtube.

My problem starts when launching "F16v2 Firmware Programmer" I receive a error stating that I am not connected to the F16V2 via USB. 

I have used over 5 micro USB cables that I own and even purchased a new one today that permits data transfer and still get the same error.

Can my controller be brought back to life?

Any help would be greatly appreciated!
« Last Edit: December 05, 2018, 03:54:11 PM by tonyatlafb »

Offline jnealand

  • Developer
  • ******
  • Join Date: Aug 2013
  • Location: Kennesaw, GA
  • Posts: 2,947
  • Kudos: 68
Re: F16V2 - RED - Firmware Update Problem
« Reply #1 on: December 05, 2018, 04:21:11 PM »
Make sure the USB cable is plugged into the computer and F16 before you power on the F16.  At least that is what I remember from the last time I saw the same error message.  If all else fail call David,
Jim Nealand
Kennesaw, GA all Falcon controllers, all 12v Master Remote Multisync with Pi and BBB P10 and P5

Offline JonB256

  • Supporting Member
  • ******
  • Join Date: Mar 2013
  • Location: Granbury, Texas
  • Posts: 5,303
  • Kudos: 127
    • Granbury Christmas Lights
Re: F16V2 - RED - Firmware Update Problem
« Reply #2 on: December 05, 2018, 08:26:44 PM »
Have you done a Factory Reset ?  That fixes a lot of similar problems.

If you can access the F16v2 web page, you can try a Save Settings. A factory reset will clear any settings you have made.

This process is used to reset all settings set by the user on the controller. This does not reset the firmware.

Perform the following steps:
1. Power off your controller and wait at least 20 seconds before proceeding.
2. Hold down the "Select" button. Keep holding it down while applying power to the controller.
3. Keep holding down the "Select Button" until you see Status LED1 and LED2 rapidly blink together and the OLED Display will display "Resetting
4. Release the "Select Button", the controller will reboot with the default settings.


Back to top