Author Topic: f16 not talking to network  (Read 251 times)

Offline enjoylife22

  • Newbie
  • *
  • Join Date: Dec 2015
  • Location:
  • Posts: 46
  • Kudos: 0
f16 not talking to network
« on: December 07, 2018, 10:04:23 AM »
I can only get the f16 to talk back to my computer once in awhile.  I have a netgear nighthawk router.  I will not let me do a static Ip address to a 255.255.255.0 subnet.  Every time I try it puts the Ip address at 192.168.1.0.  I have my pi wlan at 192.168.1.22 the eth0 is at 192.168.22.1.  I have my f16 at 192.168.22.2.  I believe it is something to do with the subnet.  I can get it to communicate once in awhile when I put the eth0 of the pi and the f16 to subnet 255.255.255.254 but it is sporadic at best.  Any help would be greatly appreciated.

Offline KBCoggin

  • Jr. Member
  • **
  • Join Date: Nov 2018
  • Location:
  • Posts: 51
  • Kudos: 0
Re: f16 not talking to network
« Reply #1 on: December 07, 2018, 10:22:24 AM »
Subnet 255.255.255.0 will cover IP ranges 192.168.22.1 through 192.168.22.256, so it shouldn't be the issue.  If you are trying to communicate to the controller from your computer, through a Pi, you'll need to add a persistent route.  192.168.22.x is a different network than your computer is on.  For example, I have my pis wlan0 at 192.168.1.247; my eth0 is at 10.0.0.200.  My controller is at 10.0.0.100.  So I have to tell my computer when trying to talk to the controller at 10.0.0.100, it needs to go through 192.168.1.247.  Then I needed to tether the connection in the Pi networking page.
PS - I have the same router.


If you are on windows, you need to run CMD as admin, and type route -p ADD 192.168.22.2 MASK 255.255.255.0 192.168.1.22

Offline jnealand

  • Developer
  • ******
  • Join Date: Aug 2013
  • Location: Kennesaw, GA
  • Posts: 2,883
  • Kudos: 67
Re: f16 not talking to network
« Reply #2 on: December 07, 2018, 10:37:49 AM »
The key words there are "run as admin".  In windows 10 you can right click on the start button and you will get a different menu than when you left click.  Select  Command Prompt (Admin) or PowerShell (Admin).  you can also put than in a batch file and run it, but when you run it right click on it and select "Run as admin"
Jim Nealand
Kennesaw, GA all Falcon controllers, all 12v Master Remote Multisync with Pi and BBB P10 and P5

Offline tbone321

  • Hero Member
  • *****
  • Join Date: Oct 2014
  • Location:
  • Posts: 1,583
  • Kudos: 50
Re: f16 not talking to network
« Reply #3 on: December 08, 2018, 08:32:51 AM »
I can only get the f16 to talk back to my computer once in awhile.  I have a netgear nighthawk router.  I will not let me do a static Ip address to a 255.255.255.0 subnet.  Every time I try it puts the Ip address at 192.168.1.0.  I have my pi wlan at 192.168.1.22 the eth0 is at 192.168.22.1.  I have my f16 at 192.168.22.2.  I believe it is something to do with the subnet.  I can get it to communicate once in awhile when I put the eth0 of the pi and the f16 to subnet 255.255.255.254 but it is sporadic at best.  Any help would be greatly appreciated.


I don't understand what you are referring to.  255.255.255.0 is normally referring to a subnet mask, not a subnet and this mask allows for 254 host addresses.  I am unaware of any router allowing for the setting of a static address.  That is not what a router does.  You can in most modern routers lock a dynamic address to a specific device but that is not a static address on the device.  You can also reduce the size of your DHCP pool on the router and then assign your static addresses outside of this pool.  Remember, when you assign a static address on a device such as the PI, it does not make a DHCP IP request so the router does not know or care about that devices IP.  Where issues do exist is when you assign static addresses within the DHCP pool.  Then the router may assign the same IP address to another device making a DHCP IP request and that causes other issues with duplicate addresses.


The issue is that you are working with two separate networks and they cannot talk to each other directly.  192.168.1.0 is one network and 192.168.22.0 is the other.  In order for them to talk to each other, the packets need to be routed.  This is what the Enable routing between interfaces checkbox in the FPP network configuration page does.  It turns the PI into a mini router between the two separate networks on its two interfaces.  The problem is that your PC does not know how to get to your show network to talk to the F16.  When you attempt to communicate with an IP address that is on a different network than the PC, it knows that the packet needs to be routed and unless there is a known path to that network, it will send the packet to its default gateway which happens to be your router.  The issue there is that unless your router also has a path defined to the show network it will pass the packet to your ISP router which also doesn't know how to get there so the packet will be dropped.  There are two ways to fix this.  One is to set up a static route on your home router that directs these packets to your PI and the other is to use the route command on your PC so that it knows to send any show network packets directly to the PI rather than your router.  Setting static routes on a home router can be difficult and in some cases impossible while using the route command is rather easy on a PC.  Just make sure that when using the route command on a PC that you need to run cmd  as an administrator or it will not allow you to run the command.

Offline Poporacer

  • Sr. Member
  • ****
  • Join Date: Dec 2017
  • Location: Meridian Idaho
  • Posts: 399
  • Kudos: 5
Re: f16 not talking to network
« Reply #4 on: February 04, 2019, 05:42:50 PM »
If you are on windows, you need to run CMD as admin, and type route -p ADD 192.168.22.2 MASK 255.255.255.0 192.168.1.22
Don't you mean route -p ADD 192.168.22.0 MASK 255.255.255.0 192.168.1.22?  I think that using 192.168.22.2 will only handle that specific address but if you use 192.168.22.0 it will cover all devices in the .22 subnet.
If to err is human, I am more human than most people.

 

Back to top