Author Topic: Plugins that work in 2.5  (Read 521 times)

Offline needbrew

  • Full Member
  • ***
  • Join Date: Dec 2015
  • Location:
  • Posts: 141
  • Kudos: 0
Plugins that work in 2.5
« on: December 26, 2018, 10:12:50 AM »
Just wondering if all the plugins continue to work in 2.5 as I am looking to switch over now that the main part of the season is over.

Offline CaptainMurdoch

  • Administrator
  • *****
  • Join Date: Sep 2013
  • Location: Washington
  • Posts: 9,856
  • Kudos: 214
Re: Plugins that work in 2.5
« Reply #1 on: December 26, 2018, 11:27:34 AM »
You should probably mention specific ones  you are interested in.  Some have been tested with v2.x and some have not.  We probably should clean up the list in v2.x to only include ones that are known working or put a flag by the untested ones.
-
Chris

Offline needbrew

  • Full Member
  • ***
  • Join Date: Dec 2015
  • Location:
  • Posts: 141
  • Kudos: 0
Re: Plugins that work in 2.5
« Reply #2 on: December 26, 2018, 11:32:25 AM »
specifically looking for the MessageQueue, rdsToMatrix and MatrixMessage.  Want to display the song name on my tune to sign

Offline jcross

  • Developer
  • ******
  • Join Date: Dec 2014
  • Location: Brandon, Manitoba, Canada
  • Posts: 141
  • Kudos: 1
    • Crosslights Christmas
Re: Plugins that work in 2.5
« Reply #3 on: January 11, 2019, 10:22:16 AM »
I have been wondering if there would be a good way to improve on plugin version management?  I'm no github expert but there is branching and versioning... Should we move towards having third party plugins utilize this in some fashion so that the plugin installer could warn when a plugin is not compatible or not tested on the current fpp version?  Perhaps even the plugin installer list could identify and only show compatible plugins since you have to be online to install plugins through that page anyway.


I have no idea how this would work but would be willing to put some time into figuring something out if any developers have some thoughts on it.
I started thinking about this a little bit last year but haven't wrapped my head around it yet.

Offline CaptainMurdoch

  • Administrator
  • *****
  • Join Date: Sep 2013
  • Location: Washington
  • Posts: 9,856
  • Kudos: 214
Re: Plugins that work in 2.5
« Reply #4 on: January 11, 2019, 12:18:33 PM »
I have no idea how this would work but would be willing to put some time into figuring something out if any developers have some thoughts on it.
I started thinking about this a little bit last year but haven't wrapped my head around it yet.

I agree, I'd like to see the plugin code updated in FPP v2.x on both the installer side and on the fppd side.  Mat wrote the plugin code and I rarely touched it and never used it, so I'm trying to come up to speed on some of it as well.

I split off another plugin discussion from the 2.6 release thread to talk about plugin issues in v2.x, so maybe we can continue enhancement talks over there. https://falconchristmas.com/forum/index.php/topic,10496.0.html

Offline dkulp

  • Developer
  • ******
  • Join Date: Sep 2013
  • Location: Framingham, MA
  • Posts: 1,677
  • Kudos: 96
    • KulpLights.com
Re: Plugins that work in 2.5
« Reply #5 on: January 11, 2019, 12:55:07 PM »


One big issue, IMO, is mandating that all plugins are hosted in a repository in the FalconChristmas organization.    Thus, if the author "goes away", we can fix things.  To add a new plugin to the plugin page, we add the repo to FalconChristmas and then grant that original person write access to that one repo. 

 

Back to top