Author Topic: Can't Get HiFiBerry Script to Complete - FPP 2.5  (Read 488 times)

Offline mikentn

  • Newbie
  • *
  • Join Date: Jan 2015
  • Location:
  • Posts: 23
  • Kudos: 0
Re: Can't Get HiFiBerry Script to Complete - FPP 2.5
« Reply #15 on: January 09, 2019, 09:42:59 PM »
I know back in the V1.x days it caused issues.  I've been re-reading the old thread where the issues with the hifiberry were worked out.  I'll see if it's still causing issues tomorrow night.

OK, just let me know.  If it needs to be disabled, I can give you another command to test to disable it and if that works fine then I can add it to the script in the repository.
Good news!  Set my antenna back up tonight and broadcast through my transmitter, and the hifiberry sounds pretty good as is.  The FPP volume slider works, and player stays set to the hifiberry and the mixer stays set to Digital after I power the Pi down and back up.   

Just for grins, I'm going to try a Soundblaster3 USB audio card I have, just to see how it works with it as well. Got the antenna set up, might as well use it.

Thanks again Chris for all of the help. I appreciate it.

Offline CaptainMurdoch

  • Administrator
  • *****
  • Join Date: Sep 2013
  • Location: Washington
  • Posts: 9,856
  • Kudos: 214
Re: Can't Get HiFiBerry Script to Complete - FPP 2.5
« Reply #16 on: January 10, 2019, 12:18:15 AM »
OK, great, so that means we don't have to modify the script to disable the onboard audio and the user can just use the FPP Settings to choose which audio output they want. Thanks for reporting back.
-
Chris

Offline Reys Dad

  • Jr. Member
  • **
  • Join Date: May 2018
  • Location: SJC
  • Posts: 70
  • Kudos: 1
Re: Can't Get HiFiBerry Script to Complete - FPP 2.5
« Reply #17 on: January 16, 2019, 10:20:03 PM »
Can someone help make a minor update to the script instructions. For those of us using the AMP2 it seems logical to put set "Hifiberry=Amp" however after knocking out my Amp2 I noticed on the Hifiberry website https://www.hifiberry.com/build/documentation/configuring-linux-3-18-x/     the Amp2 needs to be configured as "Hifiberry=Dacplus" which isn't really obvious at first
Thanks

Offline CaptainMurdoch

  • Administrator
  • *****
  • Join Date: Sep 2013
  • Location: Washington
  • Posts: 9,856
  • Kudos: 214
Re: Can't Get HiFiBerry Script to Complete - FPP 2.5
« Reply #18 on: January 16, 2019, 11:09:05 PM »
Can someone help make a minor update to the script instructions. For those of us using the AMP2 it seems logical to put set "Hifiberry=Amp" however after knocking out my Amp2 I noticed on the Hifiberry website https://www.hifiberry.com/build/documentation/configuring-linux-3-18-x/     the Amp2 needs to be configured as "Hifiberry=Dacplus" which isn't really obvious at first
Thanks

Done, thanks for reporting that.  I also updated the comment with some of the other boards mentioned on that page.  I also added that link to the top of the script as well right above the config lines.

 

Back to top