Author Topic: Volume Control Not Working - Soundblaster 3 / FPP v2.6  (Read 338 times)

Offline mikentn

  • Newbie
  • *
  • Join Date: Jan 2015
  • Location:
  • Posts: 23
  • Kudos: 0
Volume Control Not Working - Soundblaster 3 / FPP v2.6
« on: January 13, 2019, 06:20:55 PM »
Hello gang,
I decided I'd try setting up my FPP with a Soundblaster 3 USB audio card today (I previously had it set up with a HiFiBerry card). I decided to start with a fresh install of FPP, so I re-imaged my SD card with v2.5.3, and then upgraded to v2.6.  I grew the file system, then added back my usb drive, wireless dongle, and and the Soundblaster card.  I was able to choose the Soundblaster and speaker in the FPP settings menu, but for some reason the FPP volume control does not work at all.

Has anyone else with a Soundblaster 3 experienced this with v2.x???
Thanks!
« Last Edit: January 13, 2019, 07:36:47 PM by mikentn »

Offline lightingfool

  • Newbie
  • *
  • Join Date: Nov 2017
  • Location:
  • Posts: 26
  • Kudos: 0
Re: Volume Control Not Working - Soundblaster 3 / FPP v2.6
« Reply #1 on: January 13, 2019, 09:20:38 PM »
go to settings and change OMXPlayer (mp4 playback) Audio Output: to local

Offline jnealand

  • Developer
  • ******
  • Join Date: Aug 2013
  • Location: Kennesaw, GA
  • Posts: 2,936
  • Kudos: 68
Re: Volume Control Not Working - Soundblaster 3 / FPP v2.6
« Reply #2 on: January 14, 2019, 08:53:38 AM »
I was on v2.5.3 for the last month and the volume worked with my Soundblaster.
Jim Nealand
Kennesaw, GA all Falcon controllers, all 12v Master Remote Multisync with Pi and BBB P10 and P5

Offline CaptainMurdoch

  • Administrator
  • *****
  • Join Date: Sep 2013
  • Location: Washington
  • Posts: 9,856
  • Kudos: 214
Re: Volume Control Not Working - Soundblaster 3 / FPP v2.6
« Reply #3 on: January 14, 2019, 09:31:20 AM »
You may need to select a different mixer device, I haven't picked up a SB3 to test with yet so am not quite sure.
-
Chris

Offline mikentn

  • Newbie
  • *
  • Join Date: Jan 2015
  • Location:
  • Posts: 23
  • Kudos: 0
Re: Volume Control Not Working - Soundblaster 3 / FPP v2.6
« Reply #4 on: January 14, 2019, 10:13:50 PM »
go to settings and change OMXPlayer (mp4 playback) Audio Output: to local
Out of town at the moment. I'll give this a try when I get back home.  Thanks!

Offline mikentn

  • Newbie
  • *
  • Join Date: Jan 2015
  • Location:
  • Posts: 23
  • Kudos: 0
Re: Volume Control Not Working - Soundblaster 3 / FPP v2.6
« Reply #5 on: January 15, 2019, 08:27:33 PM »
OK, back home.

Tried setting the OMXPlayer Audio Output to local, still no volume control. Set it back to ALSA.

Changed the mixer setting from speaker to mic, then moved it back to speaker before I rebooted the Pi.  Now the volume control works. Don't know why, but not looking a gift horse in the mouth.

Thanks for everyone's responses.

 

Back to top