Author Topic: yet another networking issue  (Read 421 times)

Offline Kringle

  • Newbie
  • *
  • Join Date: Dec 2018
  • Location:
  • Posts: 22
  • Kudos: 0
yet another networking issue
« on: January 19, 2019, 12:02:35 AM »
I feel bad having to ask yet another question but I just can't figure this out.  I'm trying to talk to my f48 through my pi.  I can see the pi and it is set-up I can even type in the ethernet ip address of the pi and it pulls up while on the wifi only.  However, i can not get to the controller on wifi but i can get to it when it connected to ethernet.  if that makes any sense.


Ip address:
Home gateway 192.168.0.1
pi wlan0  192.168.0.100
pi eth0 192.168.10.10
controller 192.168.10.100
all subnets 255.255.255.0
DNS 192.168.0.1
no gateway set on eth0 on the pi
 
Oh and I'm on a mac so I used sudo route -n add 192.168.10.0/24 192.168.0.100 to route the ip
[/size]
[/size]Enable routing is checked and so is ArtNet outputArtNet Interface is set to eth0[size=78%][/size]  [size=78%]    [/size][size=78%]










I would love y'alls assistance on this please, Im sure Im missing something dumb from looking at it for so long.




Offline Kringle

  • Newbie
  • *
  • Join Date: Dec 2018
  • Location:
  • Posts: 22
  • Kudos: 0
Re: yet another networking issue
« Reply #1 on: January 19, 2019, 12:02:58 AM »
pdf of my settings.  Also i have changed the controllers DNS to 192.168.10.10 as per the manual and still no love.
« Last Edit: January 19, 2019, 01:13:04 AM by Kringle »

Offline thaistalyn

  • Newbie
  • *
  • Join Date: Dec 2018
  • Location: Navarre, FL
  • Posts: 6
  • Kudos: 1
    • Lights by the Sea
Re: yet another networking issue
« Reply #2 on: January 19, 2019, 07:52:00 AM »

  • Make sure that you have FPP set up as a Network Bridge.
  • Make sure that the gateway setting on the F48 is set to the RPi eth0 address of 192.168.10.10


See the video below from AusChristmas Light where Keith Westly discusses bridging.


https://youtu.be/g0fOZs6UgXw?t=409
Robert EM1/SS(NUC)(U.S. Navy Retired)
Lights by the Sea

Offline TNF250

  • Jr. Member
  • **
  • Join Date: Mar 2016
  • Location: SpringField, TN
  • Posts: 84
  • Kudos: 2
Re: yet another networking issue
« Reply #3 on: January 21, 2019, 10:38:33 AM »
Did you Enable Routing between network interfaces?
Zane
Springfield, TN

X-Lights - RPi3 - FPP - Falcon - DLA Lynx

Offline Xmas!

  • Full Member
  • ***
  • Join Date: Dec 2018
  • Location: Cocoa, FL
  • Posts: 162
  • Kudos: 2
Re: yet another networking issue
« Reply #4 on: January 21, 2019, 10:50:45 AM »
Kringle are you trying to use wifi on both the Pi and the F48? Or are you using wifi on the Pi and connecting your F48 via ethernet cable to your Pi? Thanks.
My name is Steve and I'm just getting started. but I think this will become a huge hobby!!

Offline Kringle

  • Newbie
  • *
  • Join Date: Dec 2018
  • Location:
  • Posts: 22
  • Kudos: 0
Re: yet another networking issue
« Reply #5 on: January 21, 2019, 07:38:42 PM »
Did you Enable Routing between network interfaces?
   Yes, I did enabled routing between network interfaces.  I believe my issue is with Terminal on the Mac to route make sure 192.168.10.X IP's go to the pi.


Kringle are you trying to use wifi on both the Pi and the F48? Or are you using wifi on the Pi and connecting your F48 via ethernet cable to your Pi? Thanks.


No, I am trying to use wifi on the pi and then ethernet to the F48.  Looking at the ethernet ports I can see that the F48 is sending and receiving based off of the lights but the Pi is just receiving.  I can ping the Pi's ethernet side at 192.168.10.10, but not the F48 at 192.168.10.100.  so I am assuming that the sudo route command is working?  I don't know, I thought I had all this down and was ready to rock and roll till now.  hahah

Offline tbone321

  • Hero Member
  • *****
  • Join Date: Oct 2014
  • Location:
  • Posts: 1,584
  • Kudos: 50
Re: yet another networking issue
« Reply #6 on: January 21, 2019, 08:08:22 PM »
Can you communicate with the controller when directly connected to it.

Offline Kringle

  • Newbie
  • *
  • Join Date: Dec 2018
  • Location:
  • Posts: 22
  • Kudos: 0
Re: yet another networking issue
« Reply #7 on: January 21, 2019, 08:33:25 PM »
Can you communicate with the controller when directly connected to it.

Yes, if I connect my router directly to the F48 I can talk with it.  Same goes for the Pi, over both WiFi and Ethernet.

Offline Kringle

  • Newbie
  • *
  • Join Date: Dec 2018
  • Location:
  • Posts: 22
  • Kudos: 0
Re: yet another networking issue
« Reply #8 on: January 21, 2019, 09:51:25 PM »
Ok so I was messing with the networking a bit tonight again.  Well the verdict is I can not talk through the PI.  as in I can not ping the ethernet side of the pi from the wifi side.  I have enable routing between network interfaces enabled and the Pi is in Master mode.  Ive tried multiple iterations of sudo route -n add 192.168.10.0/24 192.168.0.100.  No /24 using 10.10, everything I can think of.

Offline tbone321

  • Hero Member
  • *****
  • Join Date: Oct 2014
  • Location:
  • Posts: 1,584
  • Kudos: 50
Re: yet another networking issue
« Reply #9 on: January 21, 2019, 10:29:25 PM »
Try sudo route -n add -net 192.168.10.0/24 192.168.0.100

Offline TNF250

  • Jr. Member
  • **
  • Join Date: Mar 2016
  • Location: SpringField, TN
  • Posts: 84
  • Kudos: 2
Re: yet another networking issue
« Reply #10 on: January 22, 2019, 09:35:11 AM »
Try added the route in your router instead of on the MAC.

Offline Kringle

  • Newbie
  • *
  • Join Date: Dec 2018
  • Location:
  • Posts: 22
  • Kudos: 0
Re: yet another networking issue
« Reply #11 on: January 22, 2019, 10:06:50 AM »

Try sudo route -n add -net 192.168.10.0/24 192.168.0.100
. Ill give the -net a try tonight (fingers crossed)

Try added the route in your router instead of on the MAC.

I would like to but I dont know the ports for up forwarding.  Ive never messed with it before.  I read somewhere that 80 and 8085 worked for someone?

Offline Kringle

  • Newbie
  • *
  • Join Date: Dec 2018
  • Location:
  • Posts: 22
  • Kudos: 0
Re: yet another networking issue
« Reply #12 on: January 25, 2019, 08:13:21 AM »
Ok so this is really weird and I don't get it.  I finally go a chance to work on this issue.  Anyway, today I plug everything in and it works.  I did nothing different, plugged in the pi then the F48.  Now I can talk to the F48 through the pi.   Crazy right

Offline JonB256

  • Supporting Member
  • ******
  • Join Date: Mar 2013
  • Location: Granbury, Texas
  • Posts: 5,187
  • Kudos: 124
    • Granbury Christmas Lights
Re: yet another networking issue
« Reply #13 on: January 25, 2019, 09:32:04 AM »
Not weird. Happens a lot. Some routers seem to need time to actually implement their routes. Time and reboots cure many problems.

Offline Kringle

  • Newbie
  • *
  • Join Date: Dec 2018
  • Location:
  • Posts: 22
  • Kudos: 0
Re: yet another networking issue
« Reply #14 on: January 25, 2019, 02:30:31 PM »
yeah I know a reboot can help.  just wish I knew which one fixed it.  I have the -net on my computer running and 80 8085 for forwarding on my router.  guess ill just chalk it up to its working and not worry as to why.  hahaha.

 

Back to top