Author Topic: Noob trying to use FPP RPIWS281X Output only with Xlights  (Read 1046 times)

Offline TikiBird

  • Newbie
  • *
  • Join Date: Jan 2019
  • Location: Austin, Texas
  • Posts: 15
  • Kudos: 0
    • TikiBird Land
Re: Noob trying to use FPP RPIWS281X Output only with Xlights
« Reply #30 on: January 21, 2019, 06:31:26 PM »
IIRC, the pixel driver uses the same PWM that's used for audio. It makes sense that you can't do MP3 and WS8211 at the same time.

I would have thought the USB audio card I have would work since it doesn't use that at all. Maybe I need to go into the kernel and disable the sound drivers.
So, if I'm going to jump into this with more HW, should I make the next step the Pi-Hat or bite the bullet and get the F4V3 (I'd like to make small steps...)
Thoughts?

Offline CaptainMurdoch

  • Administrator
  • *****
  • Join Date: Sep 2013
  • Location: Washington
  • Posts: 9,856
  • Kudos: 214
Re: Noob trying to use FPP RPIWS281X Output only with Xlights
« Reply #31 on: January 21, 2019, 06:41:47 PM »
When you had the USB sound card plugged in, did you go to the FPP Settings page and select the USB card as the audio output device?
-
Chris

Offline Bwinter

  • Sr. Member
  • ****
  • Join Date: Jul 2016
  • Location:
  • Posts: 436
  • Kudos: 10
    • First Show 2016
Re: Noob trying to use FPP RPIWS281X Output only with Xlights
« Reply #32 on: January 21, 2019, 10:34:23 PM »
I use multiple PiHats for my show.  Theyre simple to work with, and inexpensive to add a few more (and keep spares for backup).

Ive never seen a reason to go with larger controllers.  But many people go that route.  Bottom line:  theres multiple ways to skin a cat.

Offline TikiBird

  • Newbie
  • *
  • Join Date: Jan 2019
  • Location: Austin, Texas
  • Posts: 15
  • Kudos: 0
    • TikiBird Land
Re: Noob trying to use FPP RPIWS281X Output only with Xlights
« Reply #33 on: January 27, 2019, 06:29:26 PM »
SOLVED.
Primary issue I had was that I plugged in the USB sound card without configuring it in the FPP Settings page. That affected the sequencing.

I was able to reproduce the problem tonight along with getting it all straightened out. I can create a sequence with sound going out the usb audio card.

Thanks everyone for all your help in untangling this. Next step will be ordering controller. Still deciding between the PiCap or the F4v3. Looks like I've got a week or two to decide since the PiCaps won't be here until Valentines day.

 

Back to top