Author Topic: 2.6 Effect Behavior  (Read 143 times)

Offline gc2016

  • Jr. Member
  • **
  • Join Date: Nov 2016
  • Location:
  • Posts: 73
  • Kudos: 0
2.6 Effect Behavior
« on: February 09, 2019, 08:49:32 PM »
I have noticed that on the effects page, the background effect starts out running, then disappears from the running effects list.


If I refresh the page, the background effect re-appears in the running list. Then eventually disappears from the running list again.


I'm still seeing if its linked to the occasional event of the background effect stopping, but the effect seems to be running even though the background effect is no longer listed in the running effects list.

Offline CaptainMurdoch

  • Administrator
  • *****
  • Join Date: Sep 2013
  • Location: Washington
  • Posts: 9,749
  • Kudos: 205
Re: 2.6 Effect Behavior
« Reply #1 on: February 10, 2019, 10:12:13 PM »
There could very well be a bug in the way that code works.  If so, I'll likely just convert it to use an API endpoint with the results passed back to the browser in JSON rather than a CSV back to PHP which translates that to XML to give to the browser.  Before we were using JSON for communicating back and forth, we had quite a bit of XML going to the browser and this is one of those cases.  Converting to JSON and the REST API would also let us pass back info on whether the effect was looping or not.

If you can reliably reproduce the background effect issue, I can take a look at the code to see if I see anything, but otherwise it may have to wait until a JSON/REST-API conversion.
-
Chris

Offline gc2016

  • Jr. Member
  • **
  • Join Date: Nov 2016
  • Location:
  • Posts: 73
  • Kudos: 0
Re: 2.6 Effect Behavior
« Reply #2 on: February 12, 2019, 07:19:12 AM »
Thanks. I'll dig into it and see what I can provide for you.

 

Back to top