Author Topic: fseq doesn't autostart on power up  (Read 449 times)

Offline srtate1

  • Newbie
  • *
  • Join Date: Jul 2018
  • Location:
  • Posts: 33
  • Kudos: 0
fseq doesn't autostart on power up
« on: May 19, 2019, 09:36:25 PM »
Noob to both Raspberry Pi and PiCap here, so on a steep learning curve using mostly  videos as tutors.  i'm wanting to have a standalone pi and PiCap running from a battery.  Got that working.  I have a sequence for two strands made in Xlights and loaded onto the Pi.  It runs fine from the status page if I hit play.  But I thought it would autostart when booting the Pi if the scheduler started at 00:00:00 and ended at 23:59:59 and set to everyday.  But when I boot everything up, nothing will start unless I hit play on the status page of the interface.  Should the program start running when I power up?  Is there anything I can do to make that happen?
Thanks!

Offline Sawdust

  • Hero Member
  • *****
  • Join Date: Nov 2015
  • Location: Folsom, CA - - - - - - - - - - - Cell Block 7
  • Posts: 679
  • Kudos: 8
Re: fseq doesn't autostart on power up
« Reply #1 on: May 19, 2019, 11:58:18 PM »
I set an schedule to start today and run thru 2099, with start time at 0:00:00 end 24:00:00
Worked for me on reboot, and shutdown and power on

Enable and repeat are both checked.

Are you running FPP version2.7 or 2.7.1

Offline pixelpuppy

  • Hero Member
  • *****
  • Join Date: Aug 2015
  • Location: Dallas, TX
  • Posts: 1,430
  • Kudos: 45
Re: fseq doesn't autostart on power up
« Reply #2 on: May 20, 2019, 06:07:14 AM »
It sounds like you don't have the "repeat" box checked on the schedule. My guess is if you waited until the start time (00:00:00 in this case) rolled around, it would have started and played once that day and same thing again on the each day.    If you want it to run continuously, and start at any time during the schedule time window, then you need to have the "enable" and "repeat" both checked like Sawdust mentioned above
-Mark

Offline srtate1

  • Newbie
  • *
  • Join Date: Jul 2018
  • Location:
  • Posts: 33
  • Kudos: 0
Re: fseq doesn't autostart on power up
« Reply #3 on: May 20, 2019, 10:24:09 AM »
Got it working.  I did have repeat and I did have repeat and enable selected.  So, I went ahead and updated FFP from 2.5 to 2.7, and updated Xlights, which was still on a 2018 version.  Doing both things made the program start on reboot.  Thank!  Now, I'm wondering if I will have trouble running my show from last Christmas on the updated Xlights.  Is that likely to be a problem?

Offline Poporacer

  • Hero Member
  • *****
  • Join Date: Dec 2017
  • Location: Meridian Idaho
  • Posts: 641
  • Kudos: 9
Re: fseq doesn't autostart on power up
« Reply #4 on: May 20, 2019, 10:54:35 AM »
That shouldn't be a problem, just re-render all of your sequences in xLights and upload them to your FPP so they are all on the new FSEQ version.
If to err is human, I am more human than most people.

Offline tomhammond

  • Jr. Member
  • **
  • Join Date: May 2016
  • Location:
  • Posts: 54
  • Kudos: 0
Re: fseq doesn't autostart on power up
« Reply #5 on: May 23, 2019, 07:26:25 PM »
I am having the same issue, but I am running v2.7.1.  I created a scheduled playlist with dates of 5-23-2019 through 12-31-2019, start time of 00:00:00 and end time of 24:00:00, set it to repeat, enabled it, then saved the schedule.  When I reboot, it does not automatically start.  Any idea what could be wrong?  Screenshots attached.  I also tried end times of 00:00:00 and 23:59:59, but to no avail.


I read that if I upload the fseq as background.eseq, it will automatically play in the background.  Rebooting, it does not automatically play, either.


Thanks for your help,
Tom
« Last Edit: May 23, 2019, 07:39:11 PM by tomhammond »

Offline Sawdust

  • Hero Member
  • *****
  • Join Date: Nov 2015
  • Location: Folsom, CA - - - - - - - - - - - Cell Block 7
  • Posts: 679
  • Kudos: 8
Re: fseq doesn't autostart on power up
« Reply #6 on: May 23, 2019, 08:23:12 PM »
Try setting to start 5/22/2019 (the day before)
« Last Edit: May 23, 2019, 10:37:41 PM by Sawdust »

Offline tomhammond

  • Jr. Member
  • **
  • Join Date: May 2016
  • Location:
  • Posts: 54
  • Kudos: 0
Re: fseq doesn't autostart on power up
« Reply #7 on: May 24, 2019, 06:56:20 AM »
Thanks for the advice.  Does my BBG need to have a realtime clock enabled for the autostart playlist to work?


Tom


Offline Poporacer

  • Hero Member
  • *****
  • Join Date: Dec 2017
  • Location: Meridian Idaho
  • Posts: 641
  • Kudos: 9
Re: fseq doesn't autostart on power up
« Reply #8 on: May 24, 2019, 07:37:51 AM »
Thanks for the advice.  Does my BBG need to have a realtime clock enabled for the autostart playlist to work?
It depends. If you are running a 24 hour schedule and do not care about when it starts and stops, then no, just make sure that your schedule is in the range of the time the BBG is reflecting. But if you want some sort of control, then you have some options.
1. Manually set the time in FPP. The time will drift off of being accurate due to the timing crystal but will be fairly close.
2. If the BBG is connected to the internet, you can use the NTP server in the Time Configuration. (most commonly used)
3. Use a RTC

Did changing the start date fix your problem? Your date and time in FPP do not look correct?
Using the 00:00-24:00 schedule is good for a 24 hour schedule as long as the start time is in the past and you have the playlist set to repeat. Think about this, what day is it if you say to start at 00:00 on Saturday? Is it Friday going into Saturday or Saturday going into Sunday? Is 00:00 a valid time, or is 24:00 a valid time?

Offline Sawdust

  • Hero Member
  • *****
  • Join Date: Nov 2015
  • Location: Folsom, CA - - - - - - - - - - - Cell Block 7
  • Posts: 679
  • Kudos: 8
Re: fseq doesn't autostart on power up
« Reply #9 on: May 24, 2019, 08:29:16 AM »
I suspect there is a problem with the play list.  Maybe it is empty?
Show me a screen shot of playlists

Offline tomhammond

  • Jr. Member
  • **
  • Join Date: May 2016
  • Location:
  • Posts: 54
  • Kudos: 0
Re: fseq doesn't autostart on power up
« Reply #10 on: May 24, 2019, 01:13:21 PM »
Well, I feel stupid.  :)  I am not using a real time clock, yet I programmed the Scheduler to start yesterday.  The BBG didn't know the date, so it probably set itself to a non-2019 date. 

I set the start date to 1980-01-01, end date to 2099-12-31, start time to 00:00:00 and end time to 23:59:59.  Now it starts up automatically perfectly, whether connected or not connected to the network.


Thanks everyone for bearing with me through this!
Tom


Offline Poporacer

  • Hero Member
  • *****
  • Join Date: Dec 2017
  • Location: Meridian Idaho
  • Posts: 641
  • Kudos: 9
Re: fseq doesn't autostart on power up
« Reply #11 on: May 24, 2019, 01:35:56 PM »
Don't feel stupid, we all make mistakes, but just a FYI, if you are truly wanting the show to run continuously then make your end time 24:00:00. There could be a slight issue ending it like you do. Say, for example, that just before midnight your playlist was actually playing the first song in your playlist. When 23:59:59 rolled around, it would finish playing that song and then start your playlist over so you would have the same song play twice in a row.
If your BBG has access to the internet, then use the NTP!

Offline tomhammond

  • Jr. Member
  • **
  • Join Date: May 2016
  • Location:
  • Posts: 54
  • Kudos: 0
Re: fseq doesn't autostart on power up
« Reply #12 on: May 24, 2019, 01:44:00 PM »
Thanks for the advice!  I'll update the end time to 24:00:00 and see what happens.  The BBG isn't on the Internet for what I need to do.  But when it is connected, FP automatically updates the time via NTP at boot.  Very nice. 


Tom


 

Back to top