Author Topic: BBB octoscroller troubleshooting  (Read 2616 times)

Offline drlucas

  • Developer
  • ******
  • Join Date: Sep 2013
  • Location: Whitby, Ontario - Canada
  • Posts: 1,424
  • Kudos: 3
BBB octoscroller troubleshooting
« on: March 20, 2015, 07:14:56 PM »
Not getting any output to the panel... first attempt with the octoscroller.

Have 1 panel connected to port 1. In /var/log/messages I see this  - is this good, bad or otherwise?
Quote
Mar 20 18:59:27 FPP kernel: [  536.925361] bone-capemgr bone_capemgr.9: part_number 'CAPE-BONE-OCTO', version 'N/A'
Mar 20 18:59:27 FPP kernel: [  536.925465] bone-capemgr bone_capemgr.9: slot #11: generic override
Mar 20 18:59:27 FPP kernel: [  536.925483] bone-capemgr bone_capemgr.9: bone: Using override eeprom data at slot 11
Mar 20 18:59:27 FPP kernel: [  536.925500] bone-capemgr bone_capemgr.9: slot #11: 'Override Board Name,00A0,Override Manuf,CAPE-BONE-OCTO'
Mar 20 18:59:27 FPP kernel: [  536.925596] bone-capemgr bone_capemgr.9: slot #11: Requesting part number/version based 'CAPE-BONE-OCTO-00A0.dtbo
Mar 20 18:59:27 FPP kernel: [  536.925613] bone-capemgr bone_capemgr.9: slot #11: Requesting firmware 'CAPE-BONE-OCTO-00A0.dtbo' for board-name 'Override Board Name', version '00A0'
Mar 20 18:59:27 FPP kernel: [  536.925647] bone-capemgr bone_capemgr.9: slot #11: dtbo 'CAPE-BONE-OCTO-00A0.dtbo' loaded; converting to live tree

Channel outputs looks like this...
fpp@FPP:~/media$ more channeloutputs
1,LEDscapeMatrix,1,6144,panels=0:0:N:0:0

(assuming the 0 means port 1, and that I could connect 1 panel)

I'm a bit concerned with the chip I used on the osctoscroller. I've seen some lights (on a reboot of the bob) come on - like two lines of a panel not the first two lines, and the colors are green and yellow)

any way to troubleshoot further?
Ryan

Offline bakerlights

  • Supporting Member
  • ******
  • Join Date: Oct 2013
  • Location: Amelia, VA
  • Posts: 56
  • Kudos: 0
Re: BBB octoscroller troubleshooting
« Reply #1 on: March 20, 2015, 07:45:13 PM »
In your channel outputs file the panels= should look lie this:  panels=0:7:N:0:0 
The wiki explains the format, but basically first number is port, second number is the panel number which starts at 7 and counts down the further you get from the BBB

Offline bakerlights

  • Supporting Member
  • ******
  • Join Date: Oct 2013
  • Location: Amelia, VA
  • Posts: 56
  • Kudos: 0
Re: BBB octoscroller troubleshooting
« Reply #2 on: March 20, 2015, 07:51:50 PM »
Be sure to restart the fppd process after you change the channeloutputs file to pick up the change

Offline drlucas

  • Developer
  • ******
  • Join Date: Sep 2013
  • Location: Whitby, Ontario - Canada
  • Posts: 1,424
  • Kudos: 3
Re: BBB octoscroller troubleshooting
« Reply #3 on: March 21, 2015, 07:45:43 AM »
OK - read and now understand the configuration file a bit better this morning. Same problem with the device.

I'll post pictures later of my board, think i have the 8x2 keyed port set the right way (the key hole faces the barrel connector and the chip is on the underside of the board).

fpp@FPP:~/media$ more channeloutputs
1,LEDscapeMatrix,1,6144,panels=0:7:N:0:0

I think my problem is that I'm not using this chip: SN74LVC245AN, but rather this one

http://ca.mouser.com/ProductDetail/Texas-Instruments/SN74LS641-1N/?qs=sGAEpiMZZMs9F6aVvY09boxqkfoFuirMDFc83EppPQA%3d

because my store didn't have the other and it looked close. I'm not an electronics guy so i'm only guessing. they both had same pin count and some similar words ... i know - i know - i know...probably WAY different.

anyways, let me know if that is the problem and I'll go hunt down the right part. just don't want to pay $20 for shipping for a $1 part and thought i could substitute.

Offline egenoup

  • Supporting Member
  • ******
  • Join Date: Dec 2014
  • Location: San Antonio, TX
  • Posts: 61
  • Kudos: 2
Re: BBB octoscroller troubleshooting
« Reply #4 on: March 21, 2015, 08:29:34 AM »
You can substitute, but the parts have to be identical in function.  the one you purchased is an "Open collector" output and the one you need is tri-state outputs.

you need SN74LS645N (non-inverting tri-state)

http://www.mouser.com/ProductDetail/Texas-Instruments/SN74LS645N/?qs=sGAEpiMZZMs9F6aVvY09bhwfQrNqig7qZY1BRjiAQB4%3d

cheers!

Offline drlucas

  • Developer
  • ******
  • Join Date: Sep 2013
  • Location: Whitby, Ontario - Canada
  • Posts: 1,424
  • Kudos: 3
Re: BBB octoscroller troubleshooting
« Reply #5 on: March 21, 2015, 09:45:26 AM »
Thank you. I found that one locally. Will pickup this afternoon and give it a try!!

Offline drlucas

  • Developer
  • ******
  • Join Date: Sep 2013
  • Location: Whitby, Ontario - Canada
  • Posts: 1,424
  • Kudos: 3
Re: BBB octoscroller troubleshooting
« Reply #6 on: March 21, 2015, 12:43:18 PM »
....go figure http://www.sayal.com/zinc/zinc_SEARCH.asp?txtSEARCH=SN74LS645N have them in a "warehouse" and charge $15 to pull it from inventory. Looks like i'll be putting in my order with Mouser.

 

Back to top