Author Topic: so lost  (Read 13857 times)

Offline CaptainMurdoch

  • Administrator
  • *****
  • Join Date: Sep 2013
  • Location: Washington
  • Posts: 9,856
  • Kudos: 214
Re: so lost
« Reply #30 on: September 09, 2015, 01:00:05 PM »
I put the list in for now.  I have some code I was testing to discover but wasn't pretty since I really couldn't find a nice way to pick out the players vs other devices on the network.  It first pinged the subnet the computer is on to find all "alive" devices and then tested each one to find the share.  As you could imagine not the fastest and was way overkill just for my use since I know the ip addresses.  Took about 10 seconds to ping and then a few mins to test for shares (based on ~30 alive devices).

You should be able to put in something to discover them via ZeroConf, that is how the MultiSync config screen in FPP works.  Each FPP instance runs the avahi daemon and the MultiSync UI uses avahi-browse to find the other FPP instances on the network.  You should be able to look for systems advertising _fpp-fppd._udp and in their advertised info, you'll find the mode they are running in (Player/Bridge/Master/Remote), and the platform they are running (Raspberry Pi/BeagleBone Black).
-
Chris

Offline twooly

  • Supporting Member
  • ******
  • Join Date: Oct 2013
  • Location:
  • Posts: 1,117
  • Kudos: 12
Re: so lost
« Reply #31 on: September 09, 2015, 01:02:11 PM »
Powershell on windows don't think that exists for windows, but I could be wrong 😀

Offline CaptainMurdoch

  • Administrator
  • *****
  • Join Date: Sep 2013
  • Location: Washington
  • Posts: 9,856
  • Kudos: 214
Re: so lost
« Reply #32 on: September 09, 2015, 01:29:01 PM »
Probably right.  A few minutes of googling leads me to believe it wouldn't be as simple as it would seem.

Offline twooly

  • Supporting Member
  • ******
  • Join Date: Oct 2013
  • Location:
  • Posts: 1,117
  • Kudos: 12
Re: so lost
« Reply #33 on: September 09, 2015, 01:44:41 PM »
Probably right.  A few minutes of googling leads me to believe it wouldn't be as simple as it would seem.

I looked at the code from the multisync initially to see if I could figure out something windows wise.  You can install bonjour but Ill pass on doing that for what I need :)

Offline stallionent

  • Full Member
  • ***
  • Join Date: Feb 2015
  • Location:
  • Posts: 161
  • Kudos: 0
Re: so lost
« Reply #34 on: October 05, 2015, 02:06:08 PM »
I removed my PI from the control box, outside, thinking my WiFi wasn't working (new modem from my cable company)

I installed it at my desk: power to PC USB, internet direct to modem. SD formatted and FPP installed. small speaker to hear the PI speak on startup.

Lights on PI come on, green & red, some times just red, some times nothing. nothing on the speaker. Internet has lights.

Enter IP address via keyboard, nothing. Tried many times, removed power and waited, still nothing

Computer says "this webpage is not available"


« Last Edit: October 05, 2015, 02:17:43 PM by stallionent »

Offline stallionent

  • Full Member
  • ***
  • Join Date: Feb 2015
  • Location:
  • Posts: 161
  • Kudos: 0
Re: so lost
« Reply #35 on: October 05, 2015, 02:18:34 PM »
I just installed a new SD card formatted with FPP at the same time as the first SD card, Green light on PI blinking, still no sound on startup. and no webpage

This used to work about a month ago.

Offline stallionent

  • Full Member
  • ***
  • Join Date: Feb 2015
  • Location:
  • Posts: 161
  • Kudos: 0
Re: so lost
« Reply #36 on: October 05, 2015, 02:36:48 PM »
OK, I got startup sound, IP address. Still no webpage when typing in IP address. Tried it with internet connected to modem, then with WiFi, then with both. WiFi does light up, so does modem cable. Still nothing

Offline CaptainMurdoch

  • Administrator
  • *****
  • Join Date: Sep 2013
  • Location: Washington
  • Posts: 9,856
  • Kudos: 214
Re: so lost
« Reply #37 on: October 05, 2015, 02:47:21 PM »
Do you have a HDMI TV or monitor you can connect?

Offline stallionent

  • Full Member
  • ***
  • Join Date: Feb 2015
  • Location:
  • Posts: 161
  • Kudos: 0
Re: so lost
« Reply #38 on: October 05, 2015, 02:58:52 PM »
I have only the PC.

Offline stallionent

  • Full Member
  • ***
  • Join Date: Feb 2015
  • Location:
  • Posts: 161
  • Kudos: 0
Re: so lost
« Reply #39 on: October 05, 2015, 03:06:07 PM »
I remember that Dave had to go into my old modem to check on IP? maybe the new modem needs the same thing to check?

Offline CaptainMurdoch

  • Administrator
  • *****
  • Join Date: Sep 2013
  • Location: Washington
  • Posts: 9,856
  • Kudos: 214
Re: so lost
« Reply #40 on: October 05, 2015, 03:22:51 PM »
What IP did you hear over the speakers?

Offline stallionent

  • Full Member
  • ***
  • Join Date: Feb 2015
  • Location:
  • Posts: 161
  • Kudos: 0
Re: so lost
« Reply #41 on: October 05, 2015, 03:31:02 PM »

Offline stallionent

  • Full Member
  • ***
  • Join Date: Feb 2015
  • Location:
  • Posts: 161
  • Kudos: 0
Re: so lost
« Reply #42 on: October 05, 2015, 03:33:18 PM »
I have the user name and password for the new modem.

Offline stallionent

  • Full Member
  • ***
  • Join Date: Feb 2015
  • Location:
  • Posts: 161
  • Kudos: 0
Re: so lost
« Reply #43 on: October 05, 2015, 03:45:14 PM »
Time for supper, back in 30 min or so

Offline stallionent

  • Full Member
  • ***
  • Join Date: Feb 2015
  • Location:
  • Posts: 161
  • Kudos: 0
Re: so lost
« Reply #44 on: October 05, 2015, 04:22:06 PM »
I'm back

 

Back to top