Author Topic: FPP and Internet  (Read 865 times)

Offline JDM1oc

  • Newbie
  • *
  • Join Date: Jul 2013
  • Location: Orange, CA
  • Posts: 25
  • Kudos: 0
FPP and Internet
« on: October 24, 2013, 03:05:38 PM »
I'm having a problem accessing the FPP via it's ip address.  My setup is a wireless router connected to the FPP and to an e6804.  When the router is connected to my network via the WAN port, I can connect to the FPP in seconds.  When I don't have the router connected to my network, it takes several minutes for the FPP to respond to it's ip address.  Does the FPP need a connection to the internet to work properly or is there a setting I am missing somewhere?

Thanks,

Josh

Offline bajadahl

  • Supporting Member
  • ******
  • Join Date: Jul 2013
  • Location: Austin, TX
  • Posts: 228
  • Kudos: 2
Re: FPP and Internet
« Reply #1 on: October 24, 2013, 03:13:01 PM »
The FPP does not need to connected to the internet to respond to LAN connection requests.  It is only recommended for Updates and Time sync.  It is not required, something in your setup is a little off I would say.



Offline bajadahl

  • Supporting Member
  • ******
  • Join Date: Jul 2013
  • Location: Austin, TX
  • Posts: 228
  • Kudos: 2
Re: FPP and Internet
« Reply #2 on: October 24, 2013, 03:38:41 PM »
While my statement above is true about an internet connection not being "required"... I was able to duplicate the problem with a router.  Kind of peculiar... When I tested it was always with a switch instead of a router unless I was trying to get to the internet.  I am willing to bet if you switch out the router for a switch you won't see the problem any more..... however, that doesn't solve the why.


 

Offline bajadahl

  • Supporting Member
  • ******
  • Join Date: Jul 2013
  • Location: Austin, TX
  • Posts: 228
  • Kudos: 2
Re: FPP and Internet
« Reply #3 on: October 24, 2013, 04:49:46 PM »
Ok - I have "kind of" figured out what's going on.  The reason that the pages load slow when you remove internet access from the router is because there is some slick automation happening that is configuring the resolv.conf file on the Pi to use the router for name resolution. (On my old Solaris boxes this is not automatic but I digress)   The bottom line is that it is slow to respond because it is trying to"resolve" the name/address of the web request (Your PC) in this case.  Eventually it and the router gives up and serves the page.  Interestingly once it has gotten this information from the router it doesn't appear to be smart enough to clear it at each reboot.....which means that once it's been connected to the router that information is there and it will behave poorly without the internet connection.  Of course the router gets it's name resolution from the service provider so when you disconnect the service provider the router just goes "uhhhh I don't know the answer" and has to tell the Pi it doesn't know the answer.   So you might be able to change a setting on the router to spoof name resolution when not connected to a service provider.  I tried turning my pc into a known host on the pi but that didn't help....I'm still playing with it.  But once I gutted the resolv.conf file on the Pi it started behaving appropriately again.

I am not recommending anyone go out and start mucking with their config.  I was just seeing what I could do.

Rebuilding it is so easy if I mess it up.... There's a video for that you know! haha


Offline JDM1oc

  • Newbie
  • *
  • Join Date: Jul 2013
  • Location: Orange, CA
  • Posts: 25
  • Kudos: 0
Re: FPP and Internet
« Reply #4 on: October 30, 2013, 05:03:48 PM »
Thank you for checking it out.  It is good to know it is not just me, because I tried it with a couple of different routers.  I may try adjusting the resolv.conf file when I have some time and make a backup.  Please update if you find a better fix.

Thanks,

Josh

 

Back to top