Author Topic: "Advanced" Networking  (Read 12073 times)

Offline ThreeSizes

  • Developer
  • ******
  • Join Date: Dec 2015
  • Location: Fulton, MD
  • Posts: 532
  • Kudos: 32
Re: "Advanced" Networking
« Reply #60 on: August 26, 2016, 09:36:49 AM »
The patch here was setup for v1.7. I've been out of town and have not tested the impact yet of updating from v1.7 to v1.8 with the patch installed or applying it to v1.8. I've been working on a updated version and will release a new patch which can be overlayed on top v1.8 once ready.


This is fantastic! I am using an RP3 with only the internal wifi adapter and it all seems to work fine.
My laptop is wirelessly connected to the Pi and my Pi is hardwired into my home router. Now I'm writing to you :) .



For creating a mesh, you recommend getting a Pi2 with two USB Antennas or could we get a Pi3 and only one USB Antenna?
Also, any thoughts as to when that might get implemented into the GUI?


Sorry for the late reply, somehow I missed this message.


What you do will depend on your environment and the ranges you need to traverse. People are experiencing range issues with the Pi3's internal antenna so that would be a factor on whether you go with 1 or 2 USB WiFi Adapters. There are also adapters with external antennas you can replace to higher gain antennas or directional antennas to increase your range. There is also the new issue with bridge mode not working on the Pi3 for some reason. That would also affect repeater mode working on the Pi3 since it leverages bridge mode.


I have a new version of this patch that is waiting in the queue for me to get tested and sent over for integration in FPP v2. Once that happens the GUI guys will work their magic. I don't have a schedule on when any of this will happen though. The new version should also be compatible with v1.8 but you would need to manually install it and the manually make the configuration changes via the command line.












"And what happened then? Well, in Whoville they say that the Grinch's small heart grew three sizes that day."

Offline ThreeSizes

  • Developer
  • ******
  • Join Date: Dec 2015
  • Location: Fulton, MD
  • Posts: 532
  • Kudos: 32
Re: "Advanced" Networking
« Reply #61 on: August 26, 2016, 09:52:10 AM »
A couple of examples for the AP mode at home would be:  A) if you use an ESPixelStick (or equivalent) for pixel control you could create a new wireless network for show traffic; B) extend wifi access further into the yard.  Is this correct and are there other great examples I am missing?

Yes. Access Point mode simply connects a WiFi network to a wired network without any of the routing or NAT happening. Devices do not see any differences between the wired portion and the wireless portion, everybody is in the same IP subnet.

Hotspot mode does the above but one step further in that the Pi will provide DHCP and DNS so you could take it anywhere, power up and connect via wifi to activate show; say a Pi and a P10 setup?  Same question, is this correct and am I missing any great examples.

Yes. Hotspot mode is essentially all the same functions as your home router. There is a major difference between Access Point and Hotspot modes, in Access Point the WiFi (WLAN0) and wired (ETH0) are in the same IP subnet. In Hotspot mode, in addition to having DHCP and DNS enabled, the WiFi (WLAN0) and wired (ETH0) are in DIFFERENT IP subnets. The intention was like your example to allow portable shows. The FPP is hardwired via some sort of PiHat or ESPixelSticks and you want to pull out your phone/tablet to connnect in to control them.  The reason ETH0 was left in a different subnet was so it could be connected to some sort of Internet connection. Think of hotspot mode just like you home router, but without any LAN ports, just WiFi and a WAN port.

One other question - FPP sync packets...can they traverse a show network without delay or is it best to keep that traffic on the "home" network?

That is the intention for primarily the sync packets to traverse the show network. You still want to minimize E1.31 traversing the WiFi signals as much as possible.



Offline ThreeSizes

  • Developer
  • ******
  • Join Date: Dec 2015
  • Location: Fulton, MD
  • Posts: 532
  • Kudos: 32
Re: "Advanced" Networking
« Reply #62 on: August 26, 2016, 10:00:57 AM »
Interesting though the troubleshooting commands related to bridges still show no br0 but it is working.


FYI, bridge mode does not actually use any bridges (br0). It uses some tricks with routing and proxy arps to work to avoid hardware compatibility issues. At least that was the intention until the Pi3 came along and messed that up (see next post).




Offline ThreeSizes

  • Developer
  • ******
  • Join Date: Dec 2015
  • Location: Fulton, MD
  • Posts: 532
  • Kudos: 32
Re: "Advanced" Networking
« Reply #63 on: August 26, 2016, 10:06:42 AM »
The patch here was setup for v1.7. I've been out of town and have not tested the impact yet of updating from v1.7 to v1.8 with the patch installed or applying it to v1.8. I've been working on a updated version and will release a new patch which can be overlayed on top v1.8 once ready.


A little info for you as you work on new patch.  My testing on a PI3 with FPP v1.8 shows bridging does not work - looks like it should be working, DHCP assigned, etc but Pi will not respond to an ARP request, PING, etc. for the device on the inside (eth0).  I tried the same FPP v1.8 on a PI2 with a canakit USB wifi module and it works perfectly so it seems to be related to the Pi3 with onboard wifi.


I have found a repeatable process which makes the bridging start to work on the PI3 - I do not know enough to understand why but hopefully this helps you out.  I understand you should not have to do this when using parprouted but it works every time...


For my testing I setup everything correctly for bridging and have a F4V2 plugged into the eth0 port.
With a ping running trying to hit the device on the inside interface, If I go into the file /proc/sys/net/ipv4/conf/all/proxy_arp  and change the 0 to a 1 the ping instantly resolves.  If I change the 1 back to a 0 the ping will stop responding within the next couple of minutes.  If I leave the flag as a 1 the ping continues to resolve without fail.  IP routes look the same when it is working or not...seems very odd.


Again, not sure why this is on a PI3 vs Pi2 using the same FPP v1.8 image.  Hopefully it provides you some help as you work on this awesome patch!  Let me know if I can help out further.


Thanks-Dave


I should have a "quieter" weekend this weekend. I'll find some time to look at bridge mode on the Pi3 and see if its something simple to resolve.




Offline DMJPixel

  • Full Member
  • ***
  • Join Date: Jan 2016
  • Location: Beavercreek OH
  • Posts: 110
  • Kudos: 2
"Advanced" Networking
« Reply #64 on: August 27, 2016, 05:49:56 AM »
Interesting though the troubleshooting commands related to bridges still show no br0 but it is working.


FYI, bridge mode does not actually use any bridges (br0). It uses some tricks with routing and proxy arps to work to avoid hardware compatibility issues. At least that was the intention until the Pi3 came along and messed that up (see next post).
Thanks for the clarification. I started to figure that out as I looked more at your code and research some of the commands.

Thanks also for your other responses. I live on 6 acres and see this patch helping to extend wifi over to a barn near the road via mesh option.

I have another Pi3 running minibian and installed FPP manually via install script - may try patch to see if it works with Jessie - will let you know.



Sent from my iPhone using Tapatalk

Offline DMJPixel

  • Full Member
  • ***
  • Join Date: Jan 2016
  • Location: Beavercreek OH
  • Posts: 110
  • Kudos: 2
Re: "Advanced" Networking
« Reply #65 on: August 27, 2016, 06:21:55 AM »
Loaded patch on the Pi3 with Minibian and FPP - got a few error messages during install script but overall patch seemed to take. Was able to switch eth0 to bridge mode and setup wlan0.

Same behavior as above - inside device picks up DHCP fine but no ping until I make the change to proxy_arp then ping instantly starts to resolve and keeps working. Change that flag back to 0 and in a minute or so ping will start to fail.

Again, hope this is helpful and appreciate your work!


Sent from my iPhone using Tapatalk

Offline jholmes

  • Full Member
  • ***
  • Join Date: Apr 2016
  • Location:
  • Posts: 164
  • Kudos: 0
Re: "Advanced" Networking
« Reply #66 on: September 21, 2016, 10:53:37 AM »
Hello! Question about which hardware mode to use:

The chip on the Raspberry Pi 3 includes 2.4 GHz WLAN IEEE 802.11 b/g/n.
Does this mean we can select the "gn" designation on the GUI or do we stick to just "g"?

Thanks!

Offline code

  • Newbie
  • *
  • Join Date: Sep 2015
  • Location:
  • Posts: 12
  • Kudos: 0
Re: "Advanced" Networking
« Reply #67 on: January 26, 2017, 05:23:39 AM »
Is this still a thing? Link for patch won't work as certificate for Https is not trusted, Looking at bridging my pixlite 16 ethernet with my fpp?

Offline ThreeSizes

  • Developer
  • ******
  • Join Date: Dec 2015
  • Location: Fulton, MD
  • Posts: 532
  • Kudos: 32
Re: "Advanced" Networking
« Reply #68 on: January 26, 2017, 08:35:26 AM »
Is this still a thing? Link for patch won't work as certificate for Https is not trusted, Looking at bridging my pixlite 16 ethernet with my fpp?

There shouldn't be any certificate issues, the server is running a valid certificate issued from GoDaddy (at least its a trusted issuer in Chrome). As for the patch file itself, that is no longer up on the site. There where a few issues with the patch itself and at the time was out-of-pocket and could work on it any further. However, I have been working on re-working it, but even with the reworking, I think it will still be problematic with the Pixlite due to the way their software discovers the Pixlite. Give this thread a read and see what happens: http://falconchristmas.com/forum/index.php/topic,5065.msg65406.html#msg65406

Offline code

  • Newbie
  • *
  • Join Date: Sep 2015
  • Location:
  • Posts: 12
  • Kudos: 0
Re: "Advanced" Networking
« Reply #69 on: January 26, 2017, 12:07:57 PM »
Thanks


Sent from my iPhone using Tapatalk

Offline Arti G

  • Newbie
  • *
  • Join Date: Jun 2017
  • Location: Bialystok, Poland
  • Posts: 30
  • Kudos: 1
Re: "Advanced" Networking
« Reply #70 on: July 26, 2017, 10:22:49 AM »
Updated patch which resolves the issue (again) with Realtek-based Edimax WiFi Adapters:

On the BeagleBone, after doing the above but before you reboot do:
  • sudo systemctl disable bonescript.socket
  • sudo systemctl disable bonescript-autorun.service
Everything else is the same from the previous instructions (Reply #5 and #21).  The next version of the patch will properly handle (re)disabling bone script.

It's the only way to get Access Point working on Raspberry and don't need router to connect with phone.
I've installed it on Pi Zero W, FPP 1.9. DHCP is not working! Neither on Access Point nor Hotspot. I see network, I can connect with PC only (PC is searching for IP and sets some random IP(169.254.175.79), phone won't connect because it can't get IP. On AP there is no way to get to GUI. On Hotspot at least on PC when I set address of wlan0 to 192.168.0.1 and set static IP (192.168.0.123) on my PC I can get to GUI (192.168.0.1).
Is there anything I can do to activate DHCP?

http://falconchristmas.com/forum/index.php/topic,7388.0.html

 

Back to top