Author Topic: Weird issue with Falcon SSC firmware (128 node backwards)  (Read 1330 times)

Offline Frankr

  • Supporting Member
  • ******
  • Join Date: Jul 2013
  • Location: Rocklin, CA
  • Posts: 268
  • Kudos: 0
    • Rocklin Lights
Weird issue with Falcon SSC firmware (128 node backwards)
« on: November 17, 2013, 11:20:44 AM »
Hello all,

I just reprogrammed 2 different SSCs, a moded v1 and a modded v2,  both were programmed to be 128 nodes backwards addressing. For some reason the nodes that should be 1-8 are locking on one color and not changing like the rest of the string. I tried 2 different strings with the same behavior.

Any thoughts?

Frank

Offline Frankr

  • Supporting Member
  • ******
  • Join Date: Jul 2013
  • Location: Rocklin, CA
  • Posts: 268
  • Kudos: 0
    • Rocklin Lights
Re: Weird issue with Falcon SSC firmware (128 node backwards)
« Reply #1 on: November 17, 2013, 11:28:45 AM »
Adding data as I go. Just did a unmodded v2 on a third string and got the exact same results.

Updating...

Changed to forward on that last ssc and the string behaves properly.

Frank

Offline Frankr

  • Supporting Member
  • ******
  • Join Date: Jul 2013
  • Location: Rocklin, CA
  • Posts: 268
  • Kudos: 0
    • Rocklin Lights
Re: Weird issue with Falcon SSC firmware (128 node backwards)
« Reply #2 on: November 17, 2013, 02:58:54 PM »
For the record this was a PEBKAC problem (problem exists between Keyboard and Chair...).  I was not paying attention to the fact that the falcon grouping software defaults to 10 groups.  When I switched back to only one group everything works as expected.

Thanks again to David for taking time out of his day to straighten me out <FacePalm>

Frank

Offline jnealand

  • Developer
  • ******
  • Join Date: Aug 2013
  • Location: Kennesaw, GA
  • Posts: 2,883
  • Kudos: 67
Re: Weird issue with Falcon SSC firmware (128 node backwards)
« Reply #3 on: November 18, 2013, 07:32:01 AM »
A lot of us have gotten hit with the default of 10 on the grouping.  I wish David would change the default to 1 and make a settings file where we could set defaults that we want to use.
Jim Nealand
Kennesaw, GA all Falcon controllers, all 12v Master Remote Multisync with Pi and BBB P10 and P5

Offline rdebolt

  • Supporting Member
  • ******
  • Join Date: Aug 2013
  • Location: Boise, ID
  • Posts: 554
  • Kudos: 3
    • Christmas in Boise
Re: Weird issue with Falcon SSC firmware (128 node backwards)
« Reply #4 on: November 18, 2013, 08:45:58 AM »

I wish David would change the default to 1 and make a settings file where we could set defaults that we want to use.



+1

Offline David Pitts

  • Administrator
  • *****
  • Join Date: Mar 2013
  • Location: Falcon, CO
  • Posts: 3,929
  • Kudos: 76
Re: Weird issue with Falcon SSC firmware (128 node backwards)
« Reply #5 on: November 18, 2013, 12:45:49 PM »

I wish David would change the default to 1 and make a settings file where we could set defaults that we want to use.



+1

You guys are right. I have had two people in last two days that had a problem because of default being 10. I will change it early next year.
PixelController, LLC
PixelController.com

 

Back to top