Author Topic: PC to wifi to PFF to controller  (Read 617 times)

Offline Babybear

  • Full Member
  • ***
  • Join Date: Jan 2016
  • Location: Rochester, New York
  • Posts: 165
  • Kudos: 2
PC to wifi to PFF to controller
« on: November 03, 2016, 06:44:34 PM »
Ok finely got my Pi up and running.   Now I need to install a batch file so my PC can talk to my controller through the PFF  different subnets

      Router 192.168.1.1  to  wlan0 PFF 192.168.1.22   to  eth0 PFF 192.168.3.35  to  eth0 F16v2 192.168.3.36

my CMD starts with    c:\users\home>

is that where I enter the command and what should it say?
really did not understand the manual on this part
running windows 10
« Last Edit: November 03, 2016, 06:53:49 PM by Babybear »
JimmyG
Rochester, New York

Offline tbone321

  • Hero Member
  • *****
  • Join Date: Oct 2014
  • Location:
  • Posts: 1,535
  • Kudos: 46
Re: PC to wifi to PFF to controller
« Reply #1 on: November 03, 2016, 07:33:35 PM »
The first thing that you need to do is see if your controllers have a default gateway address setting.  If not, then there is no easy way to connect with them across networks.  If they do, then you need to do the following.
 
1. Set their default gateway address on your show controllers to that of the PI's Ethernet address. 
2. Go into the network settings of the PI and check the Enable Routing Between Network Interfaces checkbox.
3. On your PC, open a command line and enter the following command:  route -p add 192.168.3.0 mask 255.255.255.0 192.168.1.22
 
This will allow your PC to communicate with the show network thru the PI

Offline Babybear

  • Full Member
  • ***
  • Join Date: Jan 2016
  • Location: Rochester, New York
  • Posts: 165
  • Kudos: 2
Re: PC to wifi to PFF to controller ..solved..
« Reply #2 on: November 03, 2016, 07:51:23 PM »
ok Ill give that a shot
I typed in


C:/>route -p add 192.168.3.0 mask 255.255.255.0 192.168.1.22
 and got back

The required operation requires elevation.

and that means?

well I found out. what a bitch to get permission in windows 10 ((Administrative Privileges))
 for some reason the command prompt icon is grayed out in my windows.
 
Worked like a champ thanks so much.
« Last Edit: November 04, 2016, 05:05:37 AM by Babybear »

Offline JonB256

  • Supporting Member
  • ******
  • Join Date: Mar 2013
  • Location: Granbury, Texas
  • Posts: 4,893
  • Kudos: 109
    • Granbury Christmas Lights
Re: PC to wifi to PFF to controller
« Reply #3 on: November 16, 2016, 04:18:41 PM »
Using the "route add -p 192.168.1.0 mask 255.255.255.0 192.168.0.13"  worked great on my 2 working computers.

If I add that to my Asus Router in the LAN settings, should that work for every PC or Smartphone that tries to use that route?

ps, in Win10, if you search for CMD, then right click on it, it will let you quickly use it in Administrator mode.

Offline jnealand

  • Developer
  • ******
  • Join Date: Aug 2013
  • Location: Kennesaw, GA
  • Posts: 2,740
  • Kudos: 57
Re: PC to wifi to PFF to controller
« Reply #4 on: November 16, 2016, 07:15:41 PM »
Even easier in win 10 is to right click on the start button and select "Command Prompt (admin)"
Jim Nealand
Kennesaw, GA all Falcon controllers, all 12v Master Remote Multisync with Pi and BBB P10 and P5

 

Back to top