Author Topic: 2x1 Matrix - Panels show exact same thing  (Read 2447 times)

Offline Popo-B-Trippin

  • Jr. Member
  • **
  • Join Date: Aug 2014
  • Location: Surprise, Az
  • Posts: 69
  • Kudos: 0
Re: 2x1 Matrix - Panels show exact same thing
« Reply #15 on: October 04, 2017, 11:11:12 AM »
So put the new image on there and it's still doing it when they are daisy chained together. When I put panel 2 on a different output and set it at P2, nothing is displayed (which is a step up from what was happening previously). If I set panel 2 on O2 to P1, then it show the same image as panel 1 (as expected). I've tried every variable I can think of, but I cannot get the text to scroll to the 2nd panel.


This certainly isn't show ending for me as I can display the text on my other matrix. Now it's just a mission to get this to work.


Guess it's time to wave the white flag on this one... for now...

Online dkulp

  • Moderator
  • *****
  • Join Date: Sep 2013
  • Location: Framingham, MA
  • Posts: 1,503
  • Kudos: 87
    • KulpLights.com
Re: 2x1 Matrix - Panels show exact same thing
« Reply #16 on: October 04, 2017, 01:10:43 PM »
Wait.. if you put it on a separate output, why would you set it to P2?    If you have two panels, each on a separate output, they should be "P1" on their given output.      So if using outputs  1 and 2, it would be O1/P1 for one and O2/P1 for the other.




Offline Popo-B-Trippin

  • Jr. Member
  • **
  • Join Date: Aug 2014
  • Location: Surprise, Az
  • Posts: 69
  • Kudos: 0
Re: 2x1 Matrix - Panels show exact same thing
« Reply #17 on: October 04, 2017, 01:17:59 PM »
Wait.. if you put it on a separate output, why would you set it to P2?    If you have two panels, each on a separate output, they should be "P1" on their given output.      So if using outputs  1 and 2, it would be O1/P1 for one and O2/P1 for the other.

When I did that, it showed the identical image as before.

Offline Sawdust

  • Hero Member
  • *****
  • Join Date: Nov 2015
  • Location: Northern CA
  • Posts: 618
  • Kudos: 8
Re: 2x1 Matrix - Panels show exact same thing
« Reply #18 on: October 04, 2017, 04:16:08 PM »
I don't recall you stating, but have you tried other outputs. I do not think you need to start with output 1.  Using your latest posted screen, change o1's to o2's and cable from output 2 to input panel 1.   Also try output 3.  You may have a octoscroller problem

You must change and save LED Panel screen to match cabling.


Offline Popo-B-Trippin

  • Jr. Member
  • **
  • Join Date: Aug 2014
  • Location: Surprise, Az
  • Posts: 69
  • Kudos: 0
Re: 2x1 Matrix - Panels show exact same thing
« Reply #19 on: October 04, 2017, 04:25:50 PM »
I don't recall you stating, but have you tried other outputs. I do not think you need to start with output 1.  Using your latest posted screen, change o1's to o2's and cable from output 2 to input panel 1.   Also try output 3.  You may have a octoscroller problem

You must change and save LED Panel screen to match cabling.


That was my thought as well, so I actually changed the octoscoller out for a different one, and same issue.

Offline Sawdust

  • Hero Member
  • *****
  • Join Date: Nov 2015
  • Location: Northern CA
  • Posts: 618
  • Kudos: 8
Re: 2x1 Matrix - Panels show exact same thing
« Reply #20 on: October 04, 2017, 04:52:13 PM »
I guess we are down to the BBB.  Any way to borrow one.....anybody in your area you can ask for help?

Offline Popo-B-Trippin

  • Jr. Member
  • **
  • Join Date: Aug 2014
  • Location: Surprise, Az
  • Posts: 69
  • Kudos: 0
Re: 2x1 Matrix - Panels show exact same thing
« Reply #21 on: October 04, 2017, 05:14:21 PM »
I guess we are down to the BBB.  Any way to borrow one.....anybody in your area you can ask for help?


Not in my area, however, I do have a working one in my other matrix. As much as I hate to disturb one that I know works, I'll get in there in the near future and see if that is the issue.


Thanks for all the suggestions

Online dkulp

  • Moderator
  • *****
  • Join Date: Sep 2013
  • Location: Framingham, MA
  • Posts: 1,503
  • Kudos: 87
    • KulpLights.com
Re: 2x1 Matrix - Panels show exact same thing
« Reply #22 on: October 04, 2017, 05:49:33 PM »
Can you repost the screen shots from the new image?  I just want to make sure that is setup right.   Can you also then make the fseq available someplace?   I can try duplicating the setup and using the same fseq file and seeing what I get with it.

Offline Popo-B-Trippin

  • Jr. Member
  • **
  • Join Date: Aug 2014
  • Location: Surprise, Az
  • Posts: 69
  • Kudos: 0
Re: 2x1 Matrix - Panels show exact same thing
« Reply #23 on: October 05, 2017, 05:23:25 PM »
Can you repost the screen shots from the new image?  I just want to make sure that is setup right.   Can you also then make the fseq available someplace?   I can try duplicating the setup and using the same fseq file and seeing what I get with it.


The fseq can be found here: https://drive.google.com/file/d/0B1tY3s9lcvVUd3RZRFdFb0JON2s/view?usp=sharing


I'll do the screen shots on Saturday as work is calling my name for the next two days (the life of a cop...).

Online dkulp

  • Moderator
  • *****
  • Join Date: Sep 2013
  • Location: Framingham, MA
  • Posts: 1,503
  • Kudos: 87
    • KulpLights.com
Re: 2x1 Matrix - Panels show exact same thing
« Reply #24 on: October 05, 2017, 07:36:30 PM »



I think your setup in your sequencer is wrong which is causing most of your issues.   It seems to be setup as a vertical matrix (with channels going up the first column) instead of as a horizontal matrix.   If I create a horizontal matrix 16 wide by 64 tall, I see the text scroll up the matrix.  So basically, got back to your sequencer and make sure the matrix is defined correctly.   The channels should start top left and go across for 64 pixels.


You MIGHT be able to convince FPP/BBB to display it by setting it to 2 panels tall by 1 wide with the arrows pointing to the right.  That said, I'd still suggest fixing it in your sequencer.   

Offline Sawdust

  • Hero Member
  • *****
  • Join Date: Nov 2015
  • Location: Northern CA
  • Posts: 618
  • Kudos: 8
Re: 2x1 Matrix - Panels show exact same thing
« Reply #25 on: October 05, 2017, 08:32:47 PM »
Chris, this post has a Vixen fseq test file.  I ran it on my 2x1 Pi Zero W.  Works fine
http://doityourselfchristmas.com/forums/showthread.php?47988-P10-users-Need-some-assistance-Please!&p=472882#post472882
« Last Edit: October 05, 2017, 08:40:14 PM by Sawdust »

Offline Popo-B-Trippin

  • Jr. Member
  • **
  • Join Date: Aug 2014
  • Location: Surprise, Az
  • Posts: 69
  • Kudos: 0
Re: 2x1 Matrix - Panels show exact same thing
« Reply #26 on: October 07, 2017, 02:08:59 PM »
It's working! Here's a surprise for ya; operator error...


Dan, you nailed it. It was my set-up in Vixen.


Thank you all so much for your help. It's truly appreciated!!!


Chris

 

Back to top