Author Topic: Soundblaster 3 USB problems in 2017 works great in 2018  (Read 520 times)

Offline jnealand

  • Developer
  • ******
  • Join Date: Aug 2013
  • Location: Kennesaw, GA
  • Posts: 2,840
  • Kudos: 62
Soundblaster 3 USB problems in 2017 works great in 2018
« on: October 30, 2017, 04:58:34 PM »
Well I tried to use the Soundblaster 3 USB after hearing it would improve my sound.  The sound was so bad you could not tell the words that were being sung at during the song.  I swapped my FM radio back to my old unit and still had bad sound.  Removed the blaster and went back to using standard Pi audio and sound is great.  I'm using a Pi B+ as my master.  Had 2 other folks listen to the show after I removed the blaster and they all said the sound was great.  But then I have not had any complaints about sound in past years except for some parts of one song and have been using the same master all the time.
« Last Edit: November 26, 2018, 04:57:06 PM by jnealand »
Jim Nealand
Kennesaw, GA all Falcon controllers, all 12v Master Remote Multisync with Pi and BBB P10 and P5

Offline EButler

  • Jr. Member
  • **
  • Join Date: Jan 2016
  • Location: Lenoir City, TN
  • Posts: 77
  • Kudos: 0
Re: Soundblaster 3 USB gave me terrible sound.
« Reply #1 on: October 30, 2017, 08:34:40 PM »
Hi Jim,


This may not explain your issue but I know when I started using the blaster I had to go into Audacity and run the "Limiter".  The default setting seems to be -3.  That made a pretty big difference in how things sounded for me.  Prior to that, unless I turned my mixer volume way down, some of the mp3's I had would be so loud coming out of the blaster that they were muffled and really over driving my transmitter.


Before the blaster when I had everything coming out of the 3.5mm analog port, I never had to do any editing to the mp3's I assume because the volume would never create the need to run a limiter or any other feature of Audacity.


Once I got the mp3's limited and the sound levels right on my mixer to prevent clipping.....the sound is significantly improved in my opinion.  My wife also believes it sounds quite a bit better. 


Take Care!




Offline jtrpop

  • Jr. Member
  • **
  • Join Date: Jan 2017
  • Location: Southern California
  • Posts: 73
  • Kudos: 0
  • Jason Rasmussen
    • Lights On Symphony St
Re: Soundblaster 3 USB gave me terrible sound.
« Reply #2 on: November 20, 2018, 11:48:50 AM »
Set volume in FPP to 70 for Sound Blaster, otherwise FPP clips the output. I'm running FPP 2.4 with Sound Blaster with no latency and superb audio.

Offline abrianbaker

  • Supporting Member
  • ******
  • Join Date: Oct 2013
  • Location: DFW - Justin
  • Posts: 103
  • Kudos: 1
Re: Soundblaster 3 USB gave me terrible sound.
« Reply #3 on: November 20, 2018, 01:15:41 PM »
Set volume in FPP to 70 for Sound Blaster, otherwise FPP clips the output. I'm running FPP 2.4 with Sound Blaster with no latency and superb audio.

I had the same issue as you Jim however I set min at 65 and it is now Crystal Clear!

Offline jtrpop

  • Jr. Member
  • **
  • Join Date: Jan 2017
  • Location: Southern California
  • Posts: 73
  • Kudos: 0
  • Jason Rasmussen
    • Lights On Symphony St
Re: Soundblaster 3 USB gave me terrible sound.
« Reply #4 on: November 20, 2018, 01:55:02 PM »
Set volume in FPP to 70 for Sound Blaster, otherwise FPP clips the output. I'm running FPP 2.4 with Sound Blaster with no latency and superb audio.

I had the same issue as you Jim however I set min at 65 and it is now Crystal Clear!

65 is the more conservative route, but if you set either 65 or 70, you should be good. The onboard Pi audio doesn't output to 0db even when set to 100% volume, so when a good sound card is introduced that actually outputs good levels is introduced, that 100% volume clips the output. Because the onboard Pi audio isn't that good, has noise, and doesn't output a good enough signal level, you have to turn up your other outputs (FM transmitter, etc) to compensate, thus upping the noise as well. With the Sound Blaster, not only is it a vastly superior sound card, it's signal to noise ratio is superior as well. In fact when I plug in good headphones to it, there is zero noise or hum, only dead silence. Now you have more signal and everything will be cleaner down the line.

If you want to optimize your output levels, here is the quick way:
1. Plug in good headphones to audio output, pick a loud song and turn volume up till it distorts, then back it down until distortion goes away (65 or 70 for the Sound Blaster).
2. Plug in audio to FM transmitter and turn on FM radio receiver and put radio volume low. Now playing the same song turn up FM transmitter gain until you hear distortion on your low volume FM receiver, then back gain down until it goes away. You have now maximized your signal to noise ratio for maximum performance!

You may find that your FM transmitter level is lower than what you had to set it before. This is a good thing, as you had to up your output levels to compensate for the poor input levels, thus introducing more noise. Glad it sounds crystal clear!!

Offline jnealand

  • Developer
  • ******
  • Join Date: Aug 2013
  • Location: Kennesaw, GA
  • Posts: 2,840
  • Kudos: 62
Re: Soundblaster 3 USB gave me terrible sound.
« Reply #5 on: November 20, 2018, 07:55:05 PM »
You folks are replying to a post form 2017.  This year I am running v2.4.2 on a Pi3B+ and using the Soundblaster Play 3 with no problems (so far).

Offline corydorning

  • Full Member
  • ***
  • Join Date: Nov 2016
  • Location:
  • Posts: 138
  • Kudos: 0
Re: Soundblaster 3 USB gave me terrible sound.
« Reply #6 on: November 23, 2018, 03:19:56 PM »
for anyone else who has this issue, the limiter helped me a lot.

Offline jtrpop

  • Jr. Member
  • **
  • Join Date: Jan 2017
  • Location: Southern California
  • Posts: 73
  • Kudos: 0
  • Jason Rasmussen
    • Lights On Symphony St
Re: Soundblaster 3 USB gave me terrible sound.
« Reply #7 on: November 23, 2018, 04:59:14 PM »
for anyone else who has this issue, the limiter helped me a lot.
I wouldn't recommend this. By doing this you are reducing your original file quality by lowering the volume and not resolving the actual issue. Set the volume out in FPP (or PC) to the right level so it will not clip, then set the FM transmitter to the correct volume. I made a quick and dirty impromptu video on setting correct levels which applies to any sound output of FM transmitter as many this year are having sound issues, regardless of their setup: https://youtu.be/FfW9airaXiU
« Last Edit: November 26, 2018, 11:03:44 AM by jtrpop »

 

Back to top