Author Topic: Standalone mode.  (Read 547 times)

Offline bpos

  • Full Member
  • ***
  • Join Date: Mar 2015
  • Location:
  • Posts: 117
  • Kudos: 2
Standalone mode.
« on: June 03, 2018, 02:32:25 PM »
Over the years and versions I have been able to make the Pi Player run with FPP in standalone mode with no internet at all. I must have forgotten how to do this because I cannot get the Pi to boot and run in standalone on version 596? (with no internet or wireless)

Seems I recall being able to set the etho to "static" and add the mask and gateway  then FPP will run. But when I do this now the FPP boots but does not get to the login screen because it is searching for a IP address?

If I plug in to the internet all is well and it picks up the IP as expected. I can even run wlano in static and pick up a smartphone IP on wlano.

But unplug hard wire and turn off smartphone and FPP will not start. Schedule is set to 24hr, all works as expected with internet connection.

Can someone refresh my memory on how to set up the network to get FPP to run in "standalone" mode with no internet or wireless connection?

I have read the network setup thread but it refers to adding multiple IPs and networking with remotes?

For this test I am using PiCap as controller. No wireless or internet connection at all.

Any ideas?





« Last Edit: June 03, 2018, 09:14:56 PM by bpos »

Offline Sawdust

  • Hero Member
  • *****
  • Join Date: Nov 2015
  • Location: Northern CA
  • Posts: 522
  • Kudos: 6
Re: Standalone mode.
« Reply #1 on: June 04, 2018, 09:50:03 PM »
On the bottom of the FPP network page look at Tethering
I haven't done this, but there are threads if you search Tethering

Offline bpos

  • Full Member
  • ***
  • Join Date: Mar 2015
  • Location:
  • Posts: 117
  • Kudos: 2
Re: Standalone mode.
« Reply #2 on: June 04, 2018, 11:53:05 PM »
Ok so I must not understand what really happens with the Pi and FPP. I have run a few shows on a router hub in the past that are not connected to any internet at all. (version 1.7 & 1.8 ) So I am assuming that the router is assigning an IP for the pi to connect to?

Does the Pi/FPP have the ability to assign its own IP? How can I get FPP to transmit straight to a controller without the use of a smart phone, router or home network connection?

Not sure what tethering actually does. I can connect to a smartphone via hot spot without the need of tethering? It is simple to set the etho to static and give it the proper IP for home networking then set wlano to either DHCP or static and give it the correct smart phone IP and log into the fpp via smartphone screen.

But when you get away from home network to a remote location there is no way for FPP to connect to login except by smartphone?

In version 1.8 all this seems to work without a connection. But with the latest version (604) I cannot connect static and run solo at all.

Best I can do is to trick FPP/control into thinking it has an IP connection by turning on hot spot long enough to connect to smart phone then turn it off after FPP player starts.

What am I missing?

Offline Sawdust

  • Hero Member
  • *****
  • Join Date: Nov 2015
  • Location: Northern CA
  • Posts: 522
  • Kudos: 6
Re: Standalone mode.
« Reply #3 on: June 05, 2018, 12:10:42 AM »
Maybe you could do similar to what I do for my portable system....I bought a cheap router off craigslist $5. Pi connects to the router and controllers connect to the router....and/or...the wifi of the router for my ESPixelSticks.  This also allows for connection of the iPhone to access the Pi.  The router is your DHCP which ties everything together.  No internet required, but you need to set FPP time and date.

Offline bpos

  • Full Member
  • ***
  • Join Date: Mar 2015
  • Location:
  • Posts: 117
  • Kudos: 2
Re: Standalone mode.
« Reply #4 on: June 05, 2018, 11:44:45 PM »
What does setting the time and date do if I only need it to start and run continuously when I power on? Or is this just for scheduling events?

Offline Sawdust

  • Hero Member
  • *****
  • Join Date: Nov 2015
  • Location: Northern CA
  • Posts: 522
  • Kudos: 6
Re: Standalone mode.
« Reply #5 on: June 06, 2018, 07:34:56 AM »
I guess no need for time and date if schedule isn't being used.

Offline jnealand

  • Developer
  • ******
  • Join Date: Aug 2013
  • Location: Kennesaw, GA
  • Posts: 2,619
  • Kudos: 54
Re: Standalone mode.
« Reply #6 on: June 06, 2018, 09:52:41 AM »
I believe that setting the time and date is mostly useful if you have a clock module installed in order to set the correct time and date in that module.  This assumes that the Pi will not be connected to the internet.  At least that is how I understand it.
Jim Nealand
Kennesaw, GA all Falcon controllers, all 12v Master Remote Multisync with Pi and BBB P10 and P5

Offline bpos

  • Full Member
  • ***
  • Join Date: Mar 2015
  • Location:
  • Posts: 117
  • Kudos: 2
Re: Standalone mode.
« Reply #7 on: June 06, 2018, 10:57:10 PM »
I believe that setting the time and date is mostly useful if you have a clock module installed in order to set the correct time and date in that module.  This assumes that the Pi will not be connected to the internet.  At least that is how I understand it.

So I wonder if using a clock module will let the PI self assign an IP to run with no internet? I don't think FPP will finish loading without finding an IP first?

Offline jnealand

  • Developer
  • ******
  • Join Date: Aug 2013
  • Location: Kennesaw, GA
  • Posts: 2,619
  • Kudos: 54
Re: Standalone mode.
« Reply #8 on: June 07, 2018, 08:13:17 AM »
Set the ip with a static address.

Offline bpos

  • Full Member
  • ***
  • Join Date: Mar 2015
  • Location:
  • Posts: 117
  • Kudos: 2
Re: Standalone mode.
« Reply #9 on: July 07, 2018, 02:21:52 AM »
IP is static?

So the real question is: Will FPP boot without IP connection of any kind?


Offline gadgetsmith

  • Hero Member
  • *****
  • Join Date: Apr 2014
  • Location: Charlton, NY
  • Posts: 980
  • Kudos: 14
Re: Standalone mode.
« Reply #10 on: July 07, 2018, 05:55:40 AM »
Running FPP without being connected to any network has always been possible with pre v2 versions.

If there is an issue with this now, it's probably helpful to provide logs to figure out why fppd is not starting.  The only way I can see to troubleshoot while not connected to a network would be to use a keyboard and monitor and use the command line.

You could also just download logs while connected to a network, as logs will have all events written to them.


Offline gadgetsmith

  • Hero Member
  • *****
  • Join Date: Apr 2014
  • Location: Charlton, NY
  • Posts: 980
  • Kudos: 14
Re: Standalone mode.
« Reply #11 on: July 07, 2018, 06:00:10 AM »
Another thought would be if the default time/date assigned to the Pi at startup (since it has no RTC, or ability to contact time server) is outside the time/date set in your schedule?

You said previously that FPPD was not started, but it's not clear how you figured that out. Command line, or simply observing lights not working?

Offline bpos

  • Full Member
  • ***
  • Join Date: Mar 2015
  • Location:
  • Posts: 117
  • Kudos: 2
Re: Standalone mode.
« Reply #12 on: July 07, 2018, 04:20:24 PM »
I am connected to a keyboard and monitor watching the boot sequence. Without IP address it will not make it to the FPP login.  Once this happens you can go back and try hardwired etho connection and there is a good chance it will boot to the login BUT now when you pull up the FPP browser screen you will notice that now the FPPD is stopped and will not restart.
I can provide logs but this happens like clock work every time.  I have loaded the latest version in 12 different SDs with same result. Boot sequence seems to stop on Connman every time before this problem starts.

 

Back to top