Author Topic: Routing issue between wlan0 and eth0  (Read 357 times)

Offline clutchgp

  • Newbie
  • *
  • Join Date: Oct 2018
  • Location:
  • Posts: 3
  • Kudos: 0
Routing issue between wlan0 and eth0
« on: October 06, 2018, 11:11:23 AM »
Hopefully I'm missing something simple here, but this is the second attempt to move from RPi to BBB with the same result.  I can get everything working just fine except routing between interfaces (with the option in Network page checked).  Here's the details:


Home network - 192.168.7.0/24
Controller network - 192.168.0.0/24


BBB wlan0 - 192.168.7.230
BBB eth0 - 192.168.0.10
Controller - 192.168.0.50


From a Windows machine on my home network (192.168.7.38) I can ping both the wlan0 address (192.168.7.230) and the eth0 interface (192.168.0.10).  However, I cannot ping the controller at 192.168.0.50.


The route statement I used in Windows is:  route ADD 192.168.0.0 MASK 255.255.255.0 192.168.7.230
I assume this is working since I can ping the inside (eth0) interface.  From shell on the BBB I can ping 192.168.0.50 just fine...


FWIW, I have this exact same configuration on the RPi and it works perfectly.  Completely stumped.

Offline pixelpuppy

  • Hero Member
  • *****
  • Join Date: Aug 2015
  • Location: Dallas, TX
  • Posts: 1,389
  • Kudos: 43
Re: Routing issue between wlan0 and eth0
« Reply #1 on: October 06, 2018, 09:24:41 PM »
From a Windows machine on my home network (192.168.7.38) I can ping both the wlan0 address (192.168.7.230) and the eth0 interface (192.168.0.10).  However, I cannot ping the controller at 192.168.0.50.

The route statement I used in Windows is:  route ADD 192.168.0.0 MASK 255.255.255.0 192.168.7.230
I assume this is working since I can ping the inside (eth0) interface.  From shell on the BBB I can ping 192.168.0.50 just fine...


That usually means one of the gateway settings is wrong.  Make sure your controller has its gateway set to point to the BBB's eth0 interface.  AND make sure the BBB has gateway on eth0 set to blank and gateway on wlan0 set to your home network gateway address
-Mark

Offline clutchgp

  • Newbie
  • *
  • Join Date: Oct 2018
  • Location:
  • Posts: 3
  • Kudos: 0
Re: Routing issue between wlan0 and eth0
« Reply #2 on: October 06, 2018, 10:16:16 PM »
That usually means one of the gateway settings is wrong.  Make sure your controller has its gateway set to point to the BBB's eth0 interface.  AND make sure the BBB has gateway on eth0 set to blank and gateway on wlan0 set to your home network gateway address


I did try blanking the gateway IP for eth0, didn't work but I did have it set to its own address previously.  The controller doesn't have a gateway setting, only IP and subnet. Guessing they don't need/want to support routing yet (AlphaPix).

 

Back to top