Author Topic: Picsp DMX issues  (Read 223 times)

Offline skulltronix

  • Jr. Member
  • **
  • Join Date: Nov 2016
  • Location:
  • Posts: 82
  • Kudos: 0
Picsp DMX issues
« on: October 11, 2018, 09:56:49 AM »
Damn...  My FireDog animatronic was working fine and now the picap is not outputting DMX.  I have the same issue with the MeTrike animatronic.  Both will play from VSA and Xlights via USB Enttec (both pro and Open) but do not output DMX from the Pi/PiCap.  OTHER is set to DMX Open on ttyxxx. No other outputs.  IE no lights.
I'm having intermittent  problems also with FPP not starting.  It just says STOPPED and will not respond to the START button.  But when it does start it doesn't output DMX.
I've tried setting the VSA output to both Enttec Open and Enttec Pro and then imported that to Xlights and then to FPP where I have the same settings on OTHER output. 

The RJ45 to 3 Pin DMX cable between SOC board and Pcap is good.  FPP is running fine otherwise. No USB drive. All data is saved to the SD card. Latest FPP version on both animatronics.
The FireDog has DMX in the Model Layout window of Xlights set to DMX:11.  On MeTrike I have all models set to DMX:1.  Not sure why FireDog is at 11.  Not sure what the :xx means.
Suggestions? 

Offline JonB256

  • Supporting Member
  • ******
  • Join Date: Mar 2013
  • Location: Granbury, Texas
  • Posts: 5,163
  • Kudos: 122
    • Granbury Christmas Lights
Re: Picsp DMX issues
« Reply #1 on: November 21, 2018, 10:06:10 AM »
First time I've needed DMX from the Falcon PiCap (for another person's project).

FPP v2.4.2 working perfectly in Tether Mode for this project.

I enabled the DMX in the "Other" tab
Tried ttyAMA0 and ttyS0 on both DMX Open and DMX Pro.

Never got DMX from any of the 4 combinations.
Ending using a USB DMX dongle. No problem there.

Left the PiCap connected though because they need the RTC feature.

Offline gizmohd

  • Newbie
  • *
  • Join Date: Dec 2013
  • Location:
  • Posts: 40
  • Kudos: 0
Re: Picsp DMX issues
« Reply #2 on: November 24, 2018, 01:18:53 PM »
i had that issue as well.. but in my case it was outputting DMX... then just stopped... ended up using a usb dmx cable directly instead of the picap...

 

Back to top