Author Topic: BBB P10 Panels Not Working for xLights  (Read 382 times)

Offline chrism

  • Newbie
  • *
  • Join Date: Oct 2018
  • Location:
  • Posts: 2
  • Kudos: 0
BBB P10 Panels Not Working for xLights
« on: October 25, 2018, 08:43:36 PM »
Good evening all,


I'm new to the forum and tried searching everywhere for a direction on my issue with no luck so I figured I would post it here to see if anyone has any suggestions.  I just got 4 P10 panels with an Octoscroller today.  I configured everything on the FP and all tests work as expected.  My next step was to put it into Bridge mode and send a test message from xLights and that is where i'm having issues.  I created a simple xLights test file with only a Matix and single controller and the standard 1-12 universes needed and I turned up logging on the FP and am getting messages "(7195) e131bridge.cpp:389:Received data packet for unconfigured universe 1" all the way up to 12.  It looks like data from xLights and I have universe 1-12 defined on my E1.31 page and am in bridge mode but still no output.  I then pushed my fseq to my BBB and put in standalone mode and sure enough, it's works.  Any thoughts on what I am doing wrong?




Thank you very much for any help!


-Chris

Online dkulp

  • Moderator
  • *****
  • Join Date: Sep 2013
  • Location: Framingham, MA
  • Posts: 1,509
  • Kudos: 88
    • KulpLights.com
Re: BBB P10 Panels Not Working for xLights
« Reply #1 on: October 25, 2018, 08:49:03 PM »
Why are you setting e1.31 OUTPUTS on the BBB?   You need INPUTS.


That said, you are using 2.2 and xLights.  Don't use e1.31 at all.  Instead, in xLights, configure a DDP output for all the channels the Matrix needs.   You don't need to configure anything other than the panels on the BBB side. 

Offline chrism

  • Newbie
  • *
  • Join Date: Oct 2018
  • Location:
  • Posts: 2
  • Kudos: 0
Re: BBB P10 Panels Not Working for xLights
« Reply #2 on: October 25, 2018, 08:54:09 PM »
Well that was an easy fix  :o  DPP made it a lot easier!  Thank you very very much Dan, should have posted this 4 hours ago :)

Offline pixelpuppy

  • Hero Member
  • *****
  • Join Date: Aug 2015
  • Location: Dallas, TX
  • Posts: 1,390
  • Kudos: 44
Re: BBB P10 Panels Not Working for xLights
« Reply #3 on: October 26, 2018, 06:49:49 AM »
Well that was an easy fix  :o  DPP made it a lot easier!  Thank you very very much Dan, should have posted this 4 hours ago :)


DDP is the way to go.  SOOOOO much easier than universes.   Hopefully we'll eventually see it added to FPP channel *outputs* and ideally also in Falcon controller inputs  ;D
-Mark

Online dkulp

  • Moderator
  • *****
  • Join Date: Sep 2013
  • Location: Framingham, MA
  • Posts: 1,509
  • Kudos: 88
    • KulpLights.com
Re: BBB P10 Panels Not Working for xLights
« Reply #4 on: October 26, 2018, 06:59:37 AM »
DDP is the way to go.  SOOOOO much easier than universes.   Hopefully we'll eventually see it added to FPP channel *outputs* and ideally also in Falcon controller inputs  ;D


First part is already done.  On the (should be renamed) E1.31 outputs page, you can select DDP.     Second part would require people bugging Dave enough for him to add it.  :)

Offline pixelpuppy

  • Hero Member
  • *****
  • Join Date: Aug 2015
  • Location: Dallas, TX
  • Posts: 1,390
  • Kudos: 44
Re: BBB P10 Panels Not Working for xLights
« Reply #5 on: October 26, 2018, 11:27:49 AM »
First part is already done.  On the (should be renamed) E1.31 outputs page, you can select DDP.     Second part would require people bugging Dave enough for him to add it.  :)
Cool!   8)



 

Back to top