Author Topic: fpp to f48 and linux  (Read 334 times)

Offline Cogs

  • Newbie
  • *
  • Join Date: Nov 2018
  • Location:
  • Posts: 7
  • Kudos: 0
fpp to f48 and linux
« on: November 14, 2018, 12:48:44 PM »
Hi all,Total noob, just received my first controller two days ago
Having a hard time with the network setup and would appreciate if somebody could walk me through it.I have,F48Fpp on pi 3 B+Linux pcxlights with Queen MaryAsus RT-ACRH13 router
I Tried, http://www.brianhensley.net/2017/10/network-setup-falcon-player-fpp-falcon-f16v3-controller.htmlI tried route setup on router because it sounded good to access from all pcs and didn't know how to add route in linux.I have wireless connection to fpp and its dhcp.I seem to be stuck at DNS settings, How do I find the DNS of my router? Router is set to connect to DNS server automatically, Do I   need to change this?
I guess I'll give some numbersIP address of router 192.168.50.1
IP address of FPP 192.168.50.202
IP on f48 static 192.168.051.002
Gateway on F48 192.168.051.001
DNS on f48 192.168.050.001
Unable to connect to f48 
Thanks in advance!


Offline pixelpuppy

  • Hero Member
  • *****
  • Join Date: Aug 2015
  • Location: Dallas, TX
  • Posts: 1,353
  • Kudos: 43
Re: fpp to f48 and linux
« Reply #1 on: November 14, 2018, 08:18:03 PM »
Those settings all look correct.  Bur youre still missing a static route on either your home router or on your PC.


The best place is to add it to the router, but each router is different.  Youll have to look up the user manual for your router to find out how to add a static route.


If your PC is windows you can add a static route that will give you connectivity from that PC only.   Bring up a windows command prompt and type this:


Route add -p 192.168.51.0 mask 255.255.255.0 192.168.50.202
-Mark

Offline Yisonco

  • Newbie
  • *
  • Join Date: Nov 2018
  • Location:
  • Posts: 10
  • Kudos: 0
fpp to f48 and windows
« Reply #2 on: November 26, 2018, 10:43:22 PM »
Another networking issue...


I have my FPP set up on my home wireless network with a subnet as described in CanispaterChristmas setup. The FPP controls an F48 Differential running v2.04
[/size]I am able to control the FPP just fine, but I have to take the F48 out of the setup and bring to my office to reprogram the string setup with my office computer because my laptop will not connect to the f48 over Ethernet (they have yet to patch the realtek pcie driver to work with controllers like the falcon). What I would like to do is fix the networking conflict so that I can flash the necessary programs to the f48 without unhooking my 10k pixels, and potentially test run a few sequences over bridge (probably a later question...). These are my settings best I have been able to piece together.
[/size]
[/size]FPP:
[/size]Eth0
[/size]IP - 192.168.1.100
[/size]Net Mask - 255.255.255.0
[/size]Gateway - 192.168.1.1
[/size]Wan
[/size]IP - 192.168.0.100
[/size]DNS Server 1 - 192.168.0.1
[/size]DNS Server 2 - 192.168.0.1
[/size]
[/size]F48:
[/size]Static
[/size]IP - 192.168.1.50
[/size]Net Mask - 255.255.255.0
[/size]Gateway - 192.168.1.1
[/size]DNS - 192.168.0.1
[/size]
[/size]TP Link Router:
[/size]Network Destination - 192.168.1.0
[/size]Subnet mask - 255.255.255.0
[/size]Default Gateway - 192.168.0.100
[/size]Interface - WAN
[/size]
[/size]
[/size]
[/size]

Offline pixelpuppy

  • Hero Member
  • *****
  • Join Date: Aug 2015
  • Location: Dallas, TX
  • Posts: 1,353
  • Kudos: 43
Re: fpp to f48 and windows
« Reply #3 on: November 27, 2018, 01:00:49 PM »
These are my settings best I have been able to piece together.


Some of those settings are wrong:


1. Gateway on FPP should be set on your wlan0 interface, not the eth0 interface and it should be the Internet Router's address (192.168.0.1)
2. DNS Server 2 on FPP should be an external PUBLIC DNS server like 8.8.8.8 or 1.1.1.1
3. Gateway on F48 should be the IP address of FPP's eth0 (192.168.1.100)


Offline Yisonco

  • Newbie
  • *
  • Join Date: Nov 2018
  • Location:
  • Posts: 10
  • Kudos: 0
Re: fpp to f48 and linux
« Reply #4 on: November 27, 2018, 01:53:09 PM »
Beautiful!!! Thank you! ;D ;D ;D

 

Back to top