News:

LATEST RELEASE:  FPP 6.1 - Download from here - https://github.com/FalconChristmas/fpp/releases/tag/6.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15473
Latest: vb
New This Month: 95
New This Week: 10
New Today: 9
Stats
Total Posts: 126853
Total Topics: 15550
Most Online Today: 74
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 6
Guests: 26
Total: 32

Enable Routing

Started by Nelly79, June 02, 2022, 12:08:48 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Nelly79

Evening all, I am just in the process of configuring my F16v4 with FPP, its all gone well apart from the fact that I seem to be missing the check box to enable routing.

Any help would be gratefully received.

  • QUOTE
  • QUICK EDIT
  • MORE...

CaptainMurdoch

What version of FPP are you running?  It should be visible on the 'Interface Routing' tab on the Network config screen in FPP.
-
Chris

Poporacer

Quote from: Nelly79 on June 02, 2022, 12:08:48 PMapart from the fact that I seem to be missing the check box to enable routing.
You are probably following a video or manual that is not the same version of FPP you are running. Like Captain Murdoch mentioned, what version of FPP are you running?
If to err is human, I am more human than most people.

pixelpuppy

It's an Advanced setting.  Go to the UI settings and enable Advanced mode.  Then you will see the IP forwarding under network interface setting
-Mark

Nelly79

Thanks all, I was running the latest BETA, rolled back to the previous version and the check box is now there.

pixelpuppy

Quote from: Nelly79 on June 03, 2022, 12:58:40 PMThanks all, I was running the latest BETA, rolled back to the previous version and the check box is now there.
Ummm, not sure which "BETA"you were running, but this is the latest BETA and the check box is there...
You cannot view this attachment.

-Mark

Aaron Maue

Sorry to resurrect an older thread, but does the above "IP Forwarding" setting provide the same functionality as the old "Enable Routing" checkbox on the Interface Routing tab in the network settings dialog?

You cannot view this attachment.

JonD

#7
Quote from: Aaron Maue on August 30, 2022, 10:44:10 PMSorry to resurrect an older thread, but does the above "IP Forwarding" setting provide the same functionality as the old "Enable Routing" checkbox on the Interface Routing tab in the network settings dialog?

"Enable Routing" and "IP Forwarding" are basically two names for the same function.  They decided to change the labeling this version to confuse everyone. ;) 

Technically there is a small difference between the two functions.  Routing calculates the best path to send the data, and ip forwarding has a set path where to send it.

Enable Advanced UI Mode
You cannot view this attachment.
Enable IP Forwarding
You cannot view this attachment.

Av_Shad

Quote from: JonD on August 31, 2022, 05:39:52 AM
Quote from: Aaron Maue on August 30, 2022, 10:44:10 PMSorry to resurrect an older thread, but does the above "IP Forwarding" setting provide the same functionality as the old "Enable Routing" checkbox on the Interface Routing tab in the network settings dialog?

"Enable Routing" and "IP Forwarding" are basically two names for the same function.  They decided to change the labeling this version to confuse everyone. ;) 

Technically there is a small difference between the two functions.  Routing calculates the best path to send the data, and ip forwarding has a set path where to send it.

Enable Advanced UI Mode
You cannot view this attachment.
Enable IP Forwarding
You cannot view this attachment.
Champion! thank you

Meeki

Hi all,

I am struggling also with this setting last year with the older version everything worked fine. But after update to v6 my f16v4 cannot get time from ntp click.

When i go on my wifi I can connect to the fpp and also see and change settings in my falcon f16v4 interface. But when I want to sync the clock or ping my router from my f16v4 it gives a time-out. I can ping my fpp from the f16v4

Or is this normal?

JonD

IP forwarding often involves adding a static route to the inside router or PC.  Did the IP remain exactly the same, or could that have changed with the upgrade?  Sounds like the PC knows how to get to the falcon, but the internet router does not.  Could it be a routing issue?

If NTP is the only issue, point the f16v4 NTP settings to the FPP.  The FPP will update from the internet, and the F16v4 will update from the FPP.

Meeki

Hi, thanks for your answer. I checked all settings and it seems everything is the same as before. Everything works except that the f16v4 cannot reach my router. For now it is ok but I don't know if this will give issues when expanding with more controllers? 

Can you tell me how to point the f16v4 NTP settings to the FPP

JonD

On the settings tab of the F16v4 there should be a NTP Server setting.  Set the correct time zone, and enter the IP address of the FPP as the NTP server.  Make sure internet access is enabled even if it does not have internet access.

Eastern Time Zone -5  (minus 5 as in negative number)
Central Time Zone -6
Mountain Time Zone -7
Pacific Time Zone -8

350 John

I am struggling with IP Forwarding as well.  

First, I am running a MacBook Pro and I was able to connect to my F16V3 wirelessly via FPP last year.  
I updated to FPP 6.2 and now I cannot connect to the F16V3 thru FPP.
I do not have the ability to connect a router to my FPP and Controller based on my home setup.

My FPP config;
wlan0 ip   x.x.1.137
eth0 ip   x.x.0.137
Netmask  255.255.255.0
Gateway   x.x.1.1
IP forwarding is set to 'Forwarding'

F16V3 config;
ip address  x.x.0.50
Gateway   x.x.0.137
Netmask  255.255.255.0
ethernet cable connected and tested. 

I can connect to the F16V3 config settings using the "Proxy Settings" on the FPP so I know it is talking but that is all it will do. 
What am I missing?  Thank you in advance. 

JonD

Most likely the issue is on the home network side.  The MAC can not talk directly to the remote x.x.0.x network.  Since it is not a local address, it forwards the traffic to the MACs gateway... most likely the internet router @ x.x.1.1.  Since is it not local to the internet router either, the router forwards the traffic on to the internet.  Guessing you will need to add a static route either to the MAC or the home internet router.  You need to tell one of them to send x.x.0.x traffic to the FPP instead of the internet.  MACs are hard to set persistent routes (routes that will return after a power cycle), so you would probably be happier if you added the static route to the internet router as it would stay after a reboot.

MAC route add command

sudo route -n add -net x.x.0.0/24 x.x.1.137

Support FPP

+- Recent Topics

USB Wifi Adapter by jnealand
Today at 07:55:51 AM

FPP connect by jnealand
Today at 07:53:14 AM

What is the second best way to get rid of pixel gap errors? by jnealand
Today at 07:51:13 AM

WLED Plugin not working by Negativez0
Today at 07:14:00 AM

EDM Audio and RemoteFalcon plugin conflict by JonD
Today at 06:45:27 AM

F48 with Daisy Chained Smart Receivers by JonD
Today at 06:14:02 AM

show locks me out of falcon player by breese
Today at 04:11:38 AM

Unable to get DHCP after FPP install by Jlwright325
November 27, 2022, 11:31:30 PM

FPP Scheduler duplicate by Aaron Maue
November 27, 2022, 09:24:20 PM

Audio Stalls on 8th music sequence by JonD
November 27, 2022, 08:09:16 PM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod