News:

Server migration complete, Welcome to version 2.1.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15473
Latest: vb
New This Month: 95
New This Week: 10
New Today: 9
Stats
Total Posts: 126849
Total Topics: 15550
Most Online Today: 74
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 2
Guests: 42
Total: 44

Unable to activate PiFace outputs

Started by micropuller, November 24, 2022, 01:20:42 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

micropuller

I have an existing project that uses a PiFace.

After updating FPP to version 6.0, I have some difficulties setting up the outputs.
On the "Other Outputs" page, I set the output type to GPIO and after that configure the outputs to "PiFace-1 (GPIO: 200)", "PiFace-2 (GPIO: 201)" etc.
But when I go to save the settings and restart the FPP deamon, the deamon doesn't restart and I when I go to the status page, I get an error saying so.
When I try to go back to the Other Outputs page, I get an error message that says "Unable to retrieve GPIO pin info".
Only when I refresh the page and deactivate the outputs, the deamon starts running again.

What am I doing wrong? Any help will be greatly appreciated!

darylc

I've not been able to make my piface work in FPP's more recent versions over the past few years.  Let me know if you ever get it going.

micropuller

#2
I've tried running an older version of FPP on my Raspberry Pi (FPP 1,8), but when I try to run the sequence it stops the deamon also. Older sequences run fine (including activating the PiFace outputs). I guess the files the current version of Xlights creates, don't work wit FPP 1.8?

darylc

just set xlights to produce v1 fseq files for very old fpp versions

micropuller

I tried that, but got the same problem as when I tried it in FPP V6.0
I installed FPP V1.8 onto the Pi. Older programs that were still on the USB stick worked, but the new sequence I made in Xlights 2022.23 and saved as an old Xlights sequence wouldn't start (and brought the deamon to a halt)

Support FPP

+- Recent Topics

WLED Plugin not working by Negativez0
Today at 07:14:00 AM

FPP connect by rudybuddy
Today at 06:53:17 AM

EDM Audio and RemoteFalcon plugin conflict by JonD
Today at 06:45:27 AM

F48 with Daisy Chained Smart Receivers by JonD
Today at 06:14:02 AM

USB Wifi Adapter by jem5136
Today at 05:37:34 AM

show locks me out of falcon player by breese
Today at 04:11:38 AM

Unable to get DHCP after FPP install by Jlwright325
November 27, 2022, 11:31:30 PM

What is the second best way to get rid of pixel gap errors? by k6ccc
November 27, 2022, 10:32:34 PM

FPP Scheduler duplicate by Aaron Maue
November 27, 2022, 09:24:20 PM

Audio Stalls on 8th music sequence by JonD
November 27, 2022, 08:09:16 PM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod