News:

LATEST RELEASE:  FPP 6.1 - Download from here - https://github.com/FalconChristmas/fpp/releases/tag/6.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15520
Latest: stacker1001
New This Month: 28
New This Week: 16
New Today: 10
Stats
Total Posts: 127270
Total Topics: 15622
Most Online Today: 79
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 6
Guests: 36
Total: 42

Unable to activate PiFace outputs

Started by micropuller, November 24, 2022, 01:20:42 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

micropuller

I have an existing project that uses a PiFace.

After updating FPP to version 6.0, I have some difficulties setting up the outputs.
On the "Other Outputs" page, I set the output type to GPIO and after that configure the outputs to "PiFace-1 (GPIO: 200)", "PiFace-2 (GPIO: 201)" etc.
But when I go to save the settings and restart the FPP deamon, the deamon doesn't restart and I when I go to the status page, I get an error saying so.
When I try to go back to the Other Outputs page, I get an error message that says "Unable to retrieve GPIO pin info".
Only when I refresh the page and deactivate the outputs, the deamon starts running again.

What am I doing wrong? Any help will be greatly appreciated!

darylc

I've not been able to make my piface work in FPP's more recent versions over the past few years.  Let me know if you ever get it going.

micropuller

#2
I've tried running an older version of FPP on my Raspberry Pi (FPP 1,8), but when I try to run the sequence it stops the deamon also. Older sequences run fine (including activating the PiFace outputs). I guess the files the current version of Xlights creates, don't work wit FPP 1.8?

darylc

just set xlights to produce v1 fseq files for very old fpp versions

micropuller

I tried that, but got the same problem as when I tried it in FPP V6.0
I installed FPP V1.8 onto the Pi. Older programs that were still on the USB stick worked, but the new sequence I made in Xlights 2022.23 and saved as an old Xlights sequence wouldn't start (and brought the deamon to a halt)

Support FPP

+- Recent Topics

Text inverted by dreiman
Today at 06:53:43 PM

f16v4 wont play in Player or Master Mode by Oxytousc
Today at 06:33:28 PM

Error- Cannot Ping e1.31 Channel Data Target by MichaelnotMike
Today at 06:12:34 PM

New to FPP6.2 - Interface issue, I think? by MasterTJ
Today at 05:23:28 PM

Odd Colors Showing Up Where They Are Not Supposed To by MasterTJ
Today at 05:21:50 PM

5 expresses by tombmatt
Today at 04:46:17 PM

FPP 6.2 ColorLight Issues by dennismccreery
Today at 04:17:09 PM

F16V2R expansion board issues by michaelc
Today at 03:29:47 PM

XLights Variant by dkulp
Today at 02:33:06 PM

K8-PB Network Issue by Kensington Graves
Today at 02:20:15 PM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod