LATEST RELEASE:  FPP 6.1 - Download from here -



Welcome, Guest.
Please login or register.
Forgot your password?

+-Site Stats

Total Members: 15502
Latest: UpSyD0wN
New This Month: 10
New This Week: 38
New Today: 3
Total Posts: 127149
Total Topics: 15597
Most Online Today: 72
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 8
Guests: 55
Total: 63

Unable to activate PiFace outputs

Started by micropuller, November 24, 2022, 01:20:42 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


I have an existing project that uses a PiFace.

After updating FPP to version 6.0, I have some difficulties setting up the outputs.
On the "Other Outputs" page, I set the output type to GPIO and after that configure the outputs to "PiFace-1 (GPIO: 200)", "PiFace-2 (GPIO: 201)" etc.
But when I go to save the settings and restart the FPP deamon, the deamon doesn't restart and I when I go to the status page, I get an error saying so.
When I try to go back to the Other Outputs page, I get an error message that says "Unable to retrieve GPIO pin info".
Only when I refresh the page and deactivate the outputs, the deamon starts running again.

What am I doing wrong? Any help will be greatly appreciated!


I've not been able to make my piface work in FPP's more recent versions over the past few years.  Let me know if you ever get it going.


I've tried running an older version of FPP on my Raspberry Pi (FPP 1,8), but when I try to run the sequence it stops the deamon also. Older sequences run fine (including activating the PiFace outputs). I guess the files the current version of Xlights creates, don't work wit FPP 1.8?


just set xlights to produce v1 fseq files for very old fpp versions


I tried that, but got the same problem as when I tried it in FPP V6.0
I installed FPP V1.8 onto the Pi. Older programs that were still on the USB stick worked, but the new sequence I made in Xlights 2022.23 and saved as an old Xlights sequence wouldn't start (and brought the deamon to a halt)

Support FPP

+- Recent Topics

Sequence freeze by jnealand
Today at 02:51:04 PM

Raspberry PI 4 won't connect to WIFI by jnealand
Today at 02:46:23 PM

new piCaps in the works? by jnealand
Today at 02:38:26 PM

FPP not releasing control to WLED when idle by cwr89
Today at 01:04:54 PM

FPP 6.2 Video Issue by ppanelli3
Today at 12:04:54 PM

Beagle Bone Black for sale by ppanelli3
Today at 10:40:18 AM

Port 11 not working by rossg10
Today at 09:57:03 AM

Remote script issue by mac1321
Today at 06:43:26 AM

BRP Voting Plugin - Allow others to vote for your songs! by plaberge
December 02, 2022, 11:15:17 PM

Bacground sequence by darylc
December 02, 2022, 07:34:21 PM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod