LATEST RELEASE:  FPP 7.5 - Download from here -



Welcome, Guest.
Please login or register.
Forgot your password?

+-Site Stats

Total Members: 16481
Latest: Dronyx_belgium
New This Month: 13
New This Week: 1
New Today: 1
Total Posts: 132763
Total Topics: 16481
Most Online Today: 111
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 1
Guests: 57
Total: 58

7.5 wlan ARP issue?

Started by peterjp, July 05, 2024, 04:52:27 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


I just pulled my Kulp K8-PB from storage, fired it up and upgraded FPP to 7.5. So, I'm running FPP on the Beagle Bones. The upgrade reportedly completed successfully, but after a reboot I wasn't able to connect to FPP GUI. The FPP IP, learned via reserved DHCP address, was not responding to ping either. The LCD on the BB indicated the expected IP address had been learned and FPP looked to be operating normally. 

Network connectivity is via a wireless USB adapter. This issue occurs when the wireless adapter is connected directly to the K8 USB port and when a USB hub is used, with the wireless adapter connected to the hub.

After a bit of troubleshooting, I saw that my workstation did not have an ARP entry for the FPP IP. Adding a static ARP entry for the FPP IP resolved the connectivity issue. I was able to repeat this behavior from two different workstations.

Additionally, a packet capture indicates a response to the ARP "who has" request is not being received, which leads me to believe FPP is not responding to the ARP request.

Also of note, this issue does not occur when I use the wired LAN port on the USB hub for connectivity.


Have not seen anyone else post any arp issues with FPP 7.5.  Have you tried using linux drivers instead of external, or using a different wifi adapter?  What kind of wireless USB adapter are you using?


The wifi adapter is wifi 5 AC1300Mbps that Kulp sells. I picked it up with the K8-PB and flawlessly ran with it all last season. I haven't tried the linux drivers nor another wifi adapter. I'll try the drivers and another adapter if I find one and will update.


How did you upgrade and from what version?  (Did you upgrade, or install new and restore from backup?)  An upgrade to 7.5 generally keeps all settings, but a new install and restore would not.  Not missing IP Forwarding?  What is the WLAN and LAN IP and subnet?

Some Access Points will filter arp, but not usually the home user variety .  If you installed a new wireless system since it worked last, might be something to check.


I upgraded with the big green button from 7.3. There are no issues with my ip addressing scheme or wireless networks. If no one else is complaining the most likely culprit is the wifi adapter. I'll pick up a new one and am betting that will resolve it.


Support FPP

+- Recent Topics

Changing FPP firmware by dkulp
July 19, 2024, 06:20:26 PM

Intro to the Octoscroller by dkulp
July 19, 2024, 04:41:13 AM

xCapture Playback Issues by dkulp
July 19, 2024, 04:38:54 AM

UDP error by Poporacer
July 17, 2024, 07:19:13 PM

do I need license for my picap New? by Poporacer
July 15, 2024, 03:35:02 PM

Audio Issue with Pi Zero 2 W by robbiet
July 14, 2024, 12:07:12 PM

USB (and other) issues on Pi Zero 2w by zaicik
July 14, 2024, 04:20:33 AM

Multiple text effects cause re-render by dkulp
July 13, 2024, 08:44:07 AM

FPP led Panel Troubleshooting. by Poporacer
July 12, 2024, 09:29:56 AM

output controller by JonD
July 12, 2024, 09:29:07 AM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod