Falcon Christmas

PixelController . com => Differential Receivers and F16 Differential Expansion => Topic started by: Davis80 on December 01, 2021, 08:04:08 PM

Title: Smart Differential Expansion No Data on Port 1
Post by: Davis80 on December 01, 2021, 08:04:08 PM
I've got a smart receiver that is only getting 3 data lights to light and port 1 will not put out the test pattern to a string connected to it through the controller test page.  Port 1 functions normally while operating test mode from the receiver.

I've tried new cables and swapped cables around and one of the smart receivers works great, just nothing for port 1 on one of them.

Any ideas?
Title: Re: Smart Differential Expansion No Data on Port 1
Post by: rudybuddy on December 01, 2021, 08:19:34 PM
You need to explain your setup in more detail. I'm assuming you have 2 smart receivers connected to your controller. Are receivers setup in Normal mode and independent from each other or are they chained together as receiver (A) and receiver (B)?
Title: Re: Smart Differential Expansion No Data on Port 1
Post by: Davis80 on December 01, 2021, 09:10:09 PM
I have 2 smart receivers with the DIP switches set appropriately for A and B with B having the terminators set to on.

They are both attached to my K16 AB. If I attach receiver B first in the string, all 4 data LEDs light and receiver A 2nd, only 3 data LEDs light.

I switched things over to A first B second and behavior is the same. All 4 data LEDs light on receiver B and only 3 data LEDs on receiver A.
Title: Re: Smart Differential Expansion No Data on Port 1
Post by: rudybuddy on December 02, 2021, 06:38:26 AM
Take receiver B and set the DIPS to make it A and terminate. Connect it to the controller and check the results.
Title: Re: Smart Differential Expansion No Data on Port 1
Post by: tbone321 on December 02, 2021, 11:11:26 AM
I would take a close look at the cable you are using to connect the two receivers together.  If reversing the positions of the two receivers is causing the change you are describing, that is one of the two primary causes.  The other could be the terminator switches but that is uncommon.  Make sure that BOTH sets of terminator switches on the last receiver are set in the same direction and try again with a different cable between the two receivers.
Title: Re: Smart Differential Expansion No Data on Port 1
Post by: algerdes on December 02, 2021, 07:13:57 PM
The description you provide says you have the terminators on for the "B" unit, yet it is first in the string.  The terminators should be on for the last unit (no matter what designation) in the physical string.

Having termination on at the first unit means the signal will be less than desirable to the second unit as the first unit has placed a resistor across all ports.
Powered by SMFPacks Menu Editor Mod