Falcon Christmas

Sequencers and Software Tools => xLights => Topic started by: Stoney on July 18, 2022, 11:26:48 AM

Title: P5 6x7 Matrix not lighting
Post by: Stoney on July 18, 2022, 11:26:48 AM
Sorry to bother you experts, I suspect it is simple for you all but I'm really can't figure out what settings I have got wrong.
I built a 42 panel 6 columns, 7 rows P5 (indoors) Matrix using a 5A-75B color-card & Raspberry Pi 4 & FPP ver. 5.5 connected to show by wifi. When I test the panel in FPP test all the panels work, but when I setup the matrix in xlights ver. 2022.14 matrix size 384x224 the top 2 panel rows don't light up. And column 6 starts repeating.
Can anyone please let me know what I've got wrong?
Sorry for the poor attachment.
stoney
Title: Re: P5 6x7 Matrix not lighting
Post by: k6ccc on July 18, 2022, 12:30:35 PM
If the panels light correctly from the built in test function in FPP and the ColorLight LED Vision, that means you most likely have it set right in both FPP and LED Vision.  You said driving it with WiFi.  Are driving the panels from xLights using E1.31 or DDP, or loading the sequences on FPP and playing from there?  If driving entirely from xLights,  504 universes is a LOT to be sending over WiFi.

Confirm that I am reading your layout correctly.  You have six vertical columns and 7 horizontal rows with each panel oriented in a vertical (or portrait) orientation.  That's the only way I could get your description and pixel count to match.  That makes the overall matrix just over 6 feet tall and 3 1/2 feet wide.  Did I get that right?  Are you cabling that with the panel to panel jumpers vertical (using 6 ColorLight outputs) or horizontal (using 7 ColorLight outputs)?  That should work as long as all the software has the same configuration - I think.  I do recall something about a ColorLight limitation of 256 pixels per row, but don't hold me to that as I don't use colorLights.

I can't help with xLights setup as I don't use xLights.
Title: Re: P5 6x7 Matrix not lighting
Post by: Stoney on July 18, 2022, 04:14:29 PM
Thanks for the response.
Wifi is driving DDP
Matrix layout is 6 feet wide by 3 1/2 feet tall
Title: Re: P5 6x7 Matrix not lighting
Post by: Poporacer on July 18, 2022, 08:35:38 PM
Quote from: Stoney on July 18, 2022, 04:14:29 PMWifi is driving DDP
Sending any type of pixel data over Wi-Fi is almost always prone to problems. What happens if you upload a sequence to your Pi and then play it directly? You might also have some configuration issues going on in FPP
Share some screenshots of your inputs and outputs in FPP and your LED Panel page.
You have this configured as a Virtual Matrix? That is normally used for outputting to a TV or projector. Also, you should strongly consider setting your Model of your Controller to LED Panel und use FPP Connect to upload your controller configuration, it sounds like you have some channel/configuration issues going on.
You can jump in the Zoom Room for quicker help!

Quote from: Stoney on July 18, 2022, 11:26:48 AMthe top 2 panel rows don't light up. And column 6 starts repeating.
I would almost bet this is a channel issue.
Your IP address look suspect as well
Title: Re: P5 6x7 Matrix not lighting
Post by: Stoney on July 19, 2022, 03:25:14 PM
The colorcard is directly connected to the pi and the xlights sequences are loaded on the SD card within the pi, and the wifi only sends a start & stop signals to the pi.
Title: Re: P5 6x7 Matrix not lighting
Post by: Poporacer on July 19, 2022, 04:08:20 PM
Quote from: Stoney on July 19, 2022, 03:25:14 PMThe colorcard is directly connected to the pi and the xlights sequences are loaded on the SD card within the pi, and the wifi only sends a start & stop signals to the pi.
That's good!
OK, so that that we can see more, you have a few problems going on.
You changed your controller configuration in xLights, but not sure where you got the info to use the settings that you did? A Pi-Hat is a board that mounts directly on top of the pi. The ColorLight does not connect directly on top. The Variant you chose, 2 output RPIWS281x is if you were going to connect 2 strings of pixels to the Pi. You want the Model to be LED Panels.
I have a feeling that you didn't use the Visualizer to assign your model and then FPP Connect to upload? I can see that you definitely have a channel problem like a suspected. If you use xLights to upload your Controller Configuration, then you don't have to worry about configuring them yourself!
You need to make sure that your Start Channel in xLights, matches the Start Channel for your LED panels (actually all models in your controller!) 
So look at the Start Channel of your LED Panel in xLights and the Start channel that you have your LED Panel configured for in your FPP.
Title: Re: P5 6x7 Matrix not lighting
Post by: Stoney on July 20, 2022, 07:06:28 PM
So the fix was correcting a mismatched start channel. Thanks for the help.
Powered by SMFPacks Menu Editor Mod