Server migration complete, Welcome to version 2.1.1



Welcome, Guest.
Please login or register.
Forgot your password?

+-Site Stats

Total Members: 15697
Latest: ejrich83
New This Month: 15
New This Week: 1
New Today: 1
Total Posts: 128620
Total Topics: 15828
Most Online Today: 47
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 1
Guests: 27
Total: 28

Falcon Player won't connect to AlphaPix Controller

Started by shinydiamond, December 09, 2018, 01:23:03 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Hello,I have a very simple setup using an AlphaPix(tm) 16 V3 - E1.31 & ArtNet to SPI Pixel Controller w/LCD Display - 16 SPI + 3 RS485 Outputs I just bought last year.  To get started I only had a couple of strings hooked up to the first channel and I used my laptop to control them running Xlights.  That worked great, so this year I bought a PI and installed FPP.  I can connect to my PI wirelessly and control it, but despite being plugged directly into my AlphaPix controller, I cannot talk to my AlphaPix controller with the PI.  When I use FPP to ping the controller, I get 100% packet loss.   :-\   If I plug my laptop back into the controller directly via the same ethernet cable, everything works.
Also, if I plug my computer directly into the ethernet port of the PI, I can bring up FPP so I know the ethernet port on the PI is working.

I've done some googling but haven't found any articles/videos discussing how to properly set up FPP for an AlphaPix so I thought I'd post here and hope that someone could point me in the right direction.
For reference, my Output configuration on FPP is:  FPP Channel = 1  Universe = 1  Universe Size = 510  Universe Type = E.1.31 - UnicastUnicast Address = (this matches the address on my controller)  Priority = 0
Any help would be greatly appreciated so we could get our lights working.


We need more information than this.  What are the IP addresses of the PI's interfaces and what is the IP of the controller?


The IP address of the controller is set the output of FPP to match.


You can set the output of FPP to whatever you want.  What matters is the IP address of the PI's Ethernet port if that is what you are connecting the controller too,


Oh.  That might be the issue.  How do you set that?  Can that be set from FPP?


In FPP, you need to go into Status/Control=Network settings.  The default setting is DHCP but you can change that to Static and set it to what you want.


Thank you for your help.  I assume I don't want it to match the same IP address as the controller?  What am I supposed to set it to?  If there's documentation on this, just point me in the right direction.  I'm not a network engineer like many people on this forum but I'm a quick learner.  Appreciate your help.


If your just connectecting 2 devices together, then you could leave your controller, and make FPP The last digits after the period could be any number between 1 to 254, just dont match one your already using for your controller.


Wow, that was easy enough and it worked!  I now see 0% packet loss when I ping the controller and the IP address.  Unfortunately our lights don't turn on when the sequences are running for some reason... ???



Nothing happens if I check the box "enable test mode" in the display testing.  I changed some of the other items on that screen as well and my lights are still dark.


Need screen shots. Otherwise we're just guessing in the dark.


Quote from: shinydiamond on December 10, 2018, 09:41:01 PM
Nothing happens if I check the box "enable test mode" in the display testing.  I changed some of the other items on that screen as well and my lights are still dark.

What kind of pixels are you using?  If "square" style, double check the back side of Pixel #1 and be certain the Arrow direction is point down the string and that your V+, Data and Gnd wires are correct.

If Bullet style, that can be harder, but they frequently put a white stripe on the Ground line, Data is usually Center wire. V+ is the "other"

If you are using 3-wire pixels, you normally setup for WS2811
4-wire pixels are commonly WS2801.
If you are unsure, pictures and/or links to where you bought things can help.
Long time Falcon, FPP and xLights user


Do the LEDs light when you manually enter test mode from the AlphaPix controller itself?


Thank you for the responses.  I really appreciate the help because my family is getting frustrated with me that I can't get our lights working.  The reason I'm baffled is that my sequences run if I plug my laptop straight into the controller via ethernet.  @bwinter - yes, they light if I enter test mode on the AlphaPix controller.  @JonB256 - I'm using the brilliant bulbs from Holiday Coro that they sold me with the controller.  Don't think I have an issue there since they do work in test mode and with my laptop.
I don't understand why I can ping the controller from FPP and get a response but not send test commands or my sequences.  Is there something else I need to configure?  Let me know what screenshots are needed and I will grab them.  Thanks!

Support FPP

+- Recent Topics

FPP 7 Kubernetes Error by Jlwright325
March 22, 2023, 11:11:59 AM

FPP Install on Raspberry Pi Zero W by k6ccc
March 21, 2023, 05:53:50 PM

FPP install script on Ubuntu, no video by AlexanderMedia
March 21, 2023, 09:37:23 AM

DMX to pneumatic solenoid by JerryPlak
March 20, 2023, 01:03:53 PM

Libre SBC with oled by mel4853
March 19, 2023, 12:24:34 PM

Limitations on Video file size? by darylc
March 19, 2023, 02:53:52 AM

F16v3 External Power Connector by darylc
March 16, 2023, 05:25:46 PM

FPP on PC HDMI Output by AlexanderMedia
March 15, 2023, 01:17:55 PM

Orange Pi One and external DS3231 RTC on rtc1 by Arti G
March 13, 2023, 09:29:28 AM

FM transmitters by Poporacer
March 12, 2023, 10:54:39 AM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod