News:

LATEST RELEASE:  FPP 6.1 - Download from here - https://github.com/FalconChristmas/fpp/releases/tag/6.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15487
Latest: cwr89
New This Month: 109
New This Week: 23
New Today: 4
Stats
Total Posts: 126970
Total Topics: 15575
Most Online Today: 63
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 0
Guests: 32
Total: 32

FPP will not light up Alphapix Controller

Started by AA62, January 05, 2019, 07:39:18 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

AA62

Hello, first time looking for help in a forum...  I have setup a Pi unit with FPP and by all accounts everything seems to work fine in running sequences on my friend's Alphapix  controller via the Pi / FPP unit.  However, when plugging it into my own identical controller it will not work.  I'm able to run the xlights program on my pixel tree without issue and the controller worked fine, but it will not run when I try to drive it with the pi/FPP.  I'm controlling the FPP by wi-fi through my network via laptop and know it's playing because I can start and stop the sequences (I can hear the audio playing), but no lights on the pixel tree.  Any ideas?

CaptainMurdoch

A few screenshots of your FPP E1.31, controller network config, and xLights network outputs pages would help us diagnose.
-
Chris

mighty_mace

What are the IP addresses you have set on your friends vs your alphapix?

AA62

I probably should have put in some more detail on my initial post...  I started off with a new raspberry pi 3 B+.  I tried loading FPP-v1.8 but ran into an issue where on boot up, the display (on my monitor via HDMI from the Pi) would lock up showing a large square with four colors (red, yellow, dark blue, light blue).  It would just sit at this page.  I waited up to 30 minutes with no further progress.  So, I then decided to load a later version of FPP software FPP-v2.5 and was able to get it to boot up and assign static IP addresses for both the ethernet and wi-fi communications.  I was also able to load up my fseq files and setup the scheduler.  The output was setup to run 16 x 150 pixel strings, all enabled and addressed to 192.168.0.50  All outputs are set to unicast.  This is the same address by default on my alpha pix controller.  I double checked that the controller was working by running it with my laptop an nutcracker.  The laptop IP is setup as 192.168.0.1 with subnet mask 255.255.255.0 (no default gateway and no DNS settings entered).  Now, disconnecting my laptop and running the ethernet cable from the Pi player to the alphapix controller, I used commands on wi-fi to IP address 192.168.0.22 to control the pi player.  The etho IP address on the Pi was setup as 192.168.0.10 with subnet mask at 255.255.255.0 and DNS's both setup to 192.168.0.1.  When starting the scheduler, I could hear the music from my first sequence through a speaker I plugged into the Pi audio output.  I could start and stop the sequence without any issues, but all along, there was no lighting on my pixel tree.  I'll take some snapshots of the settings pages for the IP addresses on the pi player and also the setup on the Alphapix controller and post them hopefully by tomorrow.  I did want to add that I was able to take the pi player to my friend's home and plugged it into his Alpha pix controller and it worked.  The only thing I found different between both of our Alphapix controllers is that the software version I have is a later version, 2.xxx while his is a version 1.xxx (sorry can't recall the actual version numbers).  The weird thing is that is pi player, running version 1.8 (also not a pi 3 B+) will operate my alphapix.  Maybe to save confusion I should focus on one problem.. That is, why is my Pi player not able to run the alpha pix controller ?  The only thing that makes sense to me is that I have a networking problem...

AAH

The first thing to note is that a Pi3B+ won't work on anything pre 2.x.Try setting to multicast initially to see if you get things working. After you know everything works then go back to the static IP's and Unicast.

Support FPP

+- Recent Topics

Very unexpected error message by darylc
Today at 02:54:04 AM

I'm Stumped by saleencb
November 29, 2022, 11:58:52 PM

Raspberry PI 4 won't connect to WIFI by Poporacer
November 29, 2022, 10:45:10 PM

Make FPP turn off ? by Poporacer
November 29, 2022, 10:36:13 PM

FPP not releasing control to WLED when idle by Poporacer
November 29, 2022, 10:35:09 PM

Christmas 2022 Lights by ShadowLight8
November 29, 2022, 05:54:00 PM

FPP and projector by morrydavis
November 29, 2022, 05:42:57 PM

Remote Relay Control by MGHaff007
November 29, 2022, 05:42:01 PM

E1.31 data not getting to WLED controller by morrydavis
November 29, 2022, 05:41:06 PM

Does FPP include an operating NTP server? by breese
November 29, 2022, 05:11:29 PM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod